summaryrefslogtreecommitdiff
path: root/dev-python/js2py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
commitb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (patch)
tree911928b566777494d08ebe2c16cb64f15af71901 /dev-python/js2py
parent61f10f985e19dfe20a4d9552902625edd5b6eabb (diff)
gentoo resync : 24.06.2021
Diffstat (limited to 'dev-python/js2py')
-rw-r--r--dev-python/js2py/Manifest4
-rw-r--r--dev-python/js2py/js2py-0.70_p20210218.ebuild2
-rw-r--r--dev-python/js2py/js2py-0.71.ebuild47
3 files changed, 51 insertions, 2 deletions
diff --git a/dev-python/js2py/Manifest b/dev-python/js2py/Manifest
index c14f39ee42f2..e2efc3977ad3 100644
--- a/dev-python/js2py/Manifest
+++ b/dev-python/js2py/Manifest
@@ -1,3 +1,5 @@
DIST Js2Py-0.70_p20210218.tar.gz 1969615 BLAKE2B 4702b2e771bfd2a5158a3539c33932335816c74f9dbd132679036aa2b7e53796764dd852e92d72a35ecc31efa34b849776c45d8c81e80f85f59308edf0996f00 SHA512 757c895bc0ba933020336a70473ec4455cb93c17040a39f17d645782011ea72273291448f3448ffd34658b48ada45b77facf3d326133f1c0d63e2e26e2cd7f30
-EBUILD js2py-0.70_p20210218.ebuild 1175 BLAKE2B 12b2cc6236aeb301315489f210ca340e00b614cbe98ddd27acf9a2b0e2a6462218031949e4ada6191b3614f4ab85414023c29ed6745dc72e61f65c8a6fddbc0c SHA512 50bd42efd887f3bd774519f30479635da71ded79726e912a5bc1b5181e9418d1edeffc48168b34f52cfc8e441582e063ccabff31f840b735d9351dd556fa045c
+DIST Js2Py-0.71.tar.gz 1969618 BLAKE2B 293a830f4188e66927b23900e8c376bf1a4bfdfa8726e33aa5aa75dcdf735cde89ce463741c142fc7e487ae89c7c11421e459d2fdd09ba88edfe953e4e087e42 SHA512 75bae61619d4766117f3c163d36427f3019825ecb08b745aee7c3b6f2d33a4ea8507ca180b63c0a8e575a5f9491eb64d6963acbb912edc7b934a676b38814597
+EBUILD js2py-0.70_p20210218.ebuild 1174 BLAKE2B 0c29b1ffa0f9807e5ec7b14779aa7b728e6cbb6d7209a38027324c0cc138e6be53dccc0d72c9e1c2404e5ac033a014b62eadb7e0822f46217b1f5076281d91f9 SHA512 c6edd54f7bf75c81610fd20b749535f9a67801ac68f76e411a88c0a48f63acb91e6c694d2f8d8b71b91dc3dd4fd51bd7fd85646d685d22baef9a270ed5394d43
+EBUILD js2py-0.71.ebuild 1103 BLAKE2B 4e3fa6cc638c26c311cc541ef6b1330b5e634533441317991ee97b98d57848fa0a7ae3d99b3e5f6a558a235ee147569e6314f5fe52b4832f04ed6b986ba40b8a SHA512 a27977a7008b2666d94985e6252b9183a7dd12a4f02d6d845511f8e27958cc44ece6eee616dca13b5b2f6ac0e7b3ef1d96a682134ecab7b2835de0eea131b7db
MISC metadata.xml 572 BLAKE2B e7e7fe7278ecadeedc310b4adbb1cc21c7c6a5e6cb522c31695196561e30f7bbfa0fc1e29315f931d3068ef6ede674e153e81207a7e5002d9adbe68c88e2e904 SHA512 c914912aac18c8984d4eb8ceed3d27a175fe89def2ba9bf778c3e3d8c729ad030125ea8f1096487b4c35cb9c1aa1f28a3d7a168b2c8992f6d58fb477bb9ca51c
diff --git a/dev-python/js2py/js2py-0.70_p20210218.ebuild b/dev-python/js2py/js2py-0.70_p20210218.ebuild
index c4128377646a..444e9561e4d7 100644
--- a/dev-python/js2py/js2py-0.70_p20210218.ebuild
+++ b/dev-python/js2py/js2py-0.70_p20210218.ebuild
@@ -8,7 +8,7 @@ MY_COMMIT="ea16b519a0f72e17416859a57890b8388fce6e39"
MY_PN="Js2Py"
MY_P="${MY_PN}-${PV}"
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8,9} )
inherit distutils-r1
diff --git a/dev-python/js2py/js2py-0.71.ebuild b/dev-python/js2py/js2py-0.71.ebuild
new file mode 100644
index 000000000000..5f2222fe1893
--- /dev/null
+++ b/dev-python/js2py/js2py-0.71.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_COMMIT="5f665f60083a9796ec33861240ce31d6d2b844b6"
+
+MY_PN="Js2Py"
+MY_P="${MY_PN}-${PV}"
+
+PYTHON_COMPAT=( python3_{8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="JavaScript to Python Translator & JavaScript interpreter in Python"
+HOMEPAGE="
+ http://piter.io/projects/js2py/
+ https://github.com/PiotrDabkowski/Js2Py/
+ https://pypi.org/project/Js2Py/
+"
+SRC_URI="https://github.com/PiotrDabkowski/${MY_PN}/archive/${MY_COMMIT}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pyjsparser-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/tzlocal-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_PN}-${MY_COMMIT}"
+
+python_test() {
+ pushd ./tests >/dev/null || die
+
+ # Tests require "node_failed.txt" file where the logs are kept
+ if [[ -f ./node_failed.txt ]]; then
+ rm ./node_failed.txt || die
+ fi
+
+ touch ./node_failed.txt || die
+ "${EPYTHON}" ./run.py || die "tests failed with ${EPYTHON}"
+
+ popd >/dev/null || die
+}