summaryrefslogtreecommitdiff
path: root/dev-python/jq/jq-1.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/jq/jq-1.1.2.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/jq/jq-1.1.2.ebuild')
-rw-r--r--dev-python/jq/jq-1.1.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/jq/jq-1.1.2.ebuild b/dev-python/jq/jq-1.1.2.ebuild
new file mode 100644
index 000000000000..51f86a3f79aa
--- /dev/null
+++ b/dev-python/jq/jq-1.1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for jq"
+HOMEPAGE="https://github.com/mwilliamson/jq.py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://github.com/stedolan/jq/releases/download/jq-1.6/jq-1.6.tar.gz
+ https://github.com/kkos/oniguruma/releases/download/v6.9.4/onig-6.9.4.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -e 's|import requests|#\0|' \
+ -e 's|urlretrieve(source_url, tarball_path)|shutil.copyfile(source_url, tarball_path)|' \
+ -e "s|source_url=.*kkos/oniguruma.*|source_url=\"${DISTDIR}/onig-6.9.4.tar.gz\",|" \
+ -e "s|source_url=.*stedolan/jq.*|source_url=\"${DISTDIR}/jq-1.6.tar.gz\",|" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}