summaryrefslogtreecommitdiff
path: root/dev-python/jinja
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
commitb284a3168fa91a038925d2ecf5e4791011ea5e7d (patch)
tree16fe44748708acacd909d4e2e160a09a7f6d936a /dev-python/jinja
parent77398e424e45d9e98c1cef3c43bdadb9d56e81ef (diff)
gentoo resync : 18.11.2019
Diffstat (limited to 'dev-python/jinja')
-rw-r--r--dev-python/jinja/Manifest3
-rw-r--r--dev-python/jinja/jinja-2.10.3-r1.ebuild88
-rw-r--r--dev-python/jinja/jinja-2.10.3.ebuild76
3 files changed, 167 insertions, 0 deletions
diff --git a/dev-python/jinja/Manifest b/dev-python/jinja/Manifest
index d1bd4c76f259..b4817cd403e0 100644
--- a/dev-python/jinja/Manifest
+++ b/dev-python/jinja/Manifest
@@ -1,3 +1,6 @@
DIST jinja-2.10.1.tar.gz 267828 BLAKE2B 0cd7e2880f1d41f3a6aafa0878343c2ff017099de6b2ad607baa3c9cba9d58c9241e1ba65cc23ea16244a1b3ea8720933f45f1061811e5f1abdcd881c4017bce SHA512 71c90be0b2aeefaa80279cba55f7827b5a42455f9dc55de9ca7e9e3e363678caa357426955267542f3c8a9b775e61aca55e439af192ed0a67f592be4ef91aff6
+DIST jinja-2.10.3.tar.gz 266316 BLAKE2B 0d8c10bb866eb887fd1c88ca5c5304f46d27930d8426587185ea72c0b79b512919bd5fa75987c26e433be049fd5764fb4ec08d42a4ec5ed00510fe8051e10f5e SHA512 566b781218b533c16b107b57e0252da5947fad262fd8d3fbb134b5916939c5e5d31c95e34bd6b14eec333d2ba3b4a6faa4168497a1ac774e7044f8220ac1b06e
EBUILD jinja-2.10.1.ebuild 1622 BLAKE2B 7c00ca9bd1b7a9d711d34a0a2d6323fef753d9ccba27a1c998e89b5a99ee99c43c776b5a5601b52790eacb2065b1bd80220c3d9142221b00ebd4833e3dc4a01f SHA512 7cd433f46d8270e5736c980c53563f4322cd254d17537120e617bfe414c3419615e59dcac6728f764a528253c05b8af76fe97f7f3bc041bc0f73b532ed7cf836
+EBUILD jinja-2.10.3-r1.ebuild 2047 BLAKE2B a3c146537ceafbb3fcad1f7bc6ae6b8de380f6af3f0715e771eff65333344bb3ea0e6984327884a7ac5d2a3c291199a80b54b23f1f45d856c0f993df0fcf3c3a SHA512 aec0265eb6a97457d66859c2ea3fba523d818ad828da7146a9a4143faeca0e2f0777f5584cceb78e99d095edf5624423212d05e3971ceaa1c81f60f0003ee4a2
+EBUILD jinja-2.10.3.ebuild 1758 BLAKE2B 1e1ac9dcf56902b1c030961bde39d4219a71726274ee65555f8f338eadf20682042ee3195a729cb198d42a6911cba7ce10651b4d3fa551ff44860c2fd6c2d5d9 SHA512 f7f4a756472300c1bc8482fa190bbd3b2449bd429f327b54a187ec84a480c8d1f46154148a9b45f28964c29c5055a1584550e94df7cfd5ba3a3585322759b1ae
MISC metadata.xml 374 BLAKE2B 7d6caffa81473cac206ff3ad29cc5be6ebc22d82bd3a7eb0befec7cd65a859aa9208851237c629d0c019307986eafda5a93d2977d62f847d68dfe5d415139daf SHA512 5c3b1f608d45786b27c3bf31f04816f6a85e2cfaa44eec5a9aa21029a2e8ab26264e87f9a6faa4c44a44d718aa8186110fb4d0878655dd76d880a7173b6e5d59
diff --git a/dev-python/jinja/jinja-2.10.3-r1.ebuild b/dev-python/jinja/jinja-2.10.3-r1.ebuild
new file mode 100644
index 000000000000..39131f10d5a9
--- /dev/null
+++ b/dev-python/jinja/jinja-2.10.3-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A full-featured template engine for Python"
+HOMEPAGE="http://jinja.pocoo.org/ https://pypi.org/project/Jinja2/"
+
+# pypi tarball is missing tests
+SRC_URI="https://github.com/pallets/jinja/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ !dev-python/jinja:compat"
+RDEPEND="${CDEPEND}
+ dev-python/markupsafe[${PYTHON_USEDEP}]"
+BDEPEND="${CDEPEND}
+ doc? (
+ dev-python/sphinx
+ dev-python/sphinx-issues
+ dev-python/pallets-sphinx-themes
+ )"
+
+distutils_enable_tests pytest
+
+# XXX: handle Babel better?
+
+wrap_opts() {
+ local mydistutilsargs=()
+
+ if [[ ${EPYTHON} == python* ]]; then
+ mydistutilargs+=( --with-debugsupport )
+ fi
+
+ "${@}"
+}
+
+src_prepare() {
+ # avoid unnecessary dep on extra sphinxcontrib modules
+ sed -i '/sphinxcontrib.log_cabinet/ d' docs/conf.py || die
+ printf "############################# SED ###############################\n"
+
+ distutils-r1_src_prepare
+}
+
+python_prepare() {
+ # async is not supported on python2
+ if ! python_is_python3; then
+ rm -f jinja2/async*.py || die "Failed to remove async from python2"
+ fi
+}
+
+python_compile() {
+ wrap_opts distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ if use examples ; then
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+
+ insinto /usr/share/vim/vimfiles/syntax
+ doins ext/Vim/*
+}
+
+pkg_postinst() {
+ if ! has_version dev-python/Babel; then
+ elog "For i18n support, please emerge dev-python/Babel."
+ fi
+}
diff --git a/dev-python/jinja/jinja-2.10.3.ebuild b/dev-python/jinja/jinja-2.10.3.ebuild
new file mode 100644
index 000000000000..def83f0e623c
--- /dev/null
+++ b/dev-python/jinja/jinja-2.10.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A full-featured template engine for Python"
+HOMEPAGE="http://jinja.pocoo.org/ https://pypi.org/project/Jinja2/"
+
+# pypi tarball is missing tests
+SRC_URI="https://github.com/pallets/jinja/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ !dev-python/jinja:compat"
+RDEPEND="${CDEPEND}
+ dev-python/markupsafe[${PYTHON_USEDEP}]"
+BDEPEND="${CDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+# XXX: handle Babel better?
+
+wrap_opts() {
+ local mydistutilsargs=()
+
+ if [[ ${EPYTHON} == python* ]]; then
+ mydistutilargs+=( --with-debugsupport )
+ fi
+
+ "${@}"
+}
+
+python_prepare() {
+ # async is not supported on python2
+ if ! python_is_python3; then
+ rm -f jinja2/async*.py || die "Failed to remove async from python2"
+ fi
+}
+
+python_compile() {
+ wrap_opts distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ if use examples ; then
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+
+ insinto /usr/share/vim/vimfiles/syntax
+ doins ext/Vim/*
+}
+
+pkg_postinst() {
+ if ! has_version dev-python/Babel; then
+ elog "For i18n support, please emerge dev-python/Babel."
+ fi
+}