summaryrefslogtreecommitdiff
path: root/dev-python/jedi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-22 13:06:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-22 13:06:25 +0000
commit5d0c50eb490582cf1277e150ee5bb63a90b85aa6 (patch)
tree7204c80f526d36b5a4c7c6cd1339971b97636808 /dev-python/jedi
parent13ec12ad28bc2ce6e2902be1d571befcca2b3f60 (diff)
gentoo auto-resync : 22:11:2022 - 13:06:24
Diffstat (limited to 'dev-python/jedi')
-rw-r--r--dev-python/jedi/Manifest2
-rw-r--r--dev-python/jedi/jedi-0.18.2.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/dev-python/jedi/Manifest b/dev-python/jedi/Manifest
index d8c08edd52d4..037c89f178d8 100644
--- a/dev-python/jedi/Manifest
+++ b/dev-python/jedi/Manifest
@@ -1,6 +1,8 @@
AUX jedi-0.18.1-python3.11.patch 693 BLAKE2B 51a08bd5270443af1bf0698b730e7fba43c858c092323fb269373d995621b40a040130e8a2d1e84fb0090bd0e7ad9416741cdcfe15103dbb0b4ba99d6f6bec6e SHA512 2926fe31001ec7d2f895dacb8f926757de3db79b3d2d29a0e814e25ecbad954572bdad6f75f234ad24aa446471dcff74817d3aedb3c667d9efa5ffd82d237f47
DIST django-stubs-fd057010f6cbf176f57d1099e82be46d39b99cb9.tar.gz 183312 BLAKE2B a68f6139903f5001db994ee0d881f40ab74932e81c3e2c3a0c22dc56e6be681d0fb42ce837603b21e4d0d448ccb25884ef0f69039305f309e82603267cee9f6a SHA512 506322c132f94e6a1e88cdbde6027a566387731fa6ad59934f95c3511f49d90eff2a3138363811be648b096407d418cd1f801df0bc35b1e464ef181e4076ada1
DIST jedi-0.18.1.gh.tar.gz 466884 BLAKE2B c2403b20447b27b1fb19c16d1131299154fcb767453116964b339bf7ef4a1ca20b6c3216c3fbd63c304dd2c0c02a67702d5228e1d847975b778597dc58b489d1 SHA512 c72dc4927fe44641ea57c61e68b3c74c3a3f70ddc2990454ba931026c288723e07263918ecbb4ecc6f79716d37e10a1b1448ae8cfc6d52465122b3d1e43bea25
+DIST jedi-0.18.2.gh.tar.gz 469286 BLAKE2B 6b65a231d092a6869b55c14a8254c4716695f46cdc9733f50607cf7bb8c864f319e2abfbe812bffc514c78cd92059fc29fa9cc0a38b1e14d6bc8bf3ad3596097 SHA512 1df24190c7d468f388e7175f4625670df81cd9a533c8bde12b1e0eaf982a173bdd001bbea6680144cc50ca263fa2b802da5d71de555f81717f4377c46826d0d1
DIST typeshed-ae9d4f4b21bb5e1239816c301da7b1ea904b44c3.tar.gz 602044 BLAKE2B 53298918a7e9a1163e76d4c70ad2a2117ee90b49329aa82d82b2aaaeaf000c971872f83ed283af6dc4be068b813876760c8b1b4acb4131865572a4aed3ea9230 SHA512 b3b9da66b6c6e03e0b262b3262df31215a5e080468ca9ebf4332ed53d715cd3956db7067fad3ec267042ff704f81ac665c703ef2fd0c5b445d440bd8e52bf1aa
EBUILD jedi-0.18.1-r1.ebuild 2303 BLAKE2B 2217d0354729fd739f5d808348117ffedb0d8db30c63d5125580939a642dbfd85ed83a5f2c217574c7f9aa2b880b3560a31230b27338e36f3fe55945aa8ac3dc SHA512 42c7745bdf085f8138e11d2da7039d18b184b38c7d1ef58b7af4faba9e8b96514a0a504b913d7d1f9ed0453aa12c30bc7845886d81dd3f94efa31648d4bc0a0b
+EBUILD jedi-0.18.2.ebuild 2212 BLAKE2B f0cf5e880152569f0e8fd9551e63ed061167b235c2aaf9e3a039894accc278162572a759f8878ce393bf4639c6c027f8c860ebd1b894245ec61396cf4e3d165c SHA512 2d4fae6b047d39acb675ab913ff8779305e3c20683973b4a42ff7842f6031f1754eb58dc5f3e4869fa632afdfe9432d8ccb3db9fe6f07df7669e3e02a98ddf05
MISC metadata.xml 401 BLAKE2B c540d55ee88ab5a7be9ec902059a766a754da42ba5c1836c990d0d64edfec91fa33e8a745b9a15ce4a97831259150e0298fe2a5ed4c21993be73d9fd7af3d865 SHA512 6af98463225428333ec509b334014bd307569ce852f640a1f1c1e18f7551185d8db9b7c80822012c14f3c6ca1cf79ff24f289df3cd42803759d012a1a73ac07c
diff --git a/dev-python/jedi/jedi-0.18.2.ebuild b/dev-python/jedi/jedi-0.18.2.ebuild
new file mode 100644
index 000000000000..a594ebeb1a8b
--- /dev/null
+++ b/dev-python/jedi/jedi-0.18.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+TYPESHED_P="typeshed-ae9d4f4b21bb5e1239816c301da7b1ea904b44c3"
+DJANGO_STUBS_P="django-stubs-fd057010f6cbf176f57d1099e82be46d39b99cb9"
+
+DESCRIPTION="Autocompletion library for Python"
+HOMEPAGE="
+ https://github.com/davidhalter/jedi/
+ https://pypi.org/project/jedi/
+"
+SRC_URI="
+ https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ https://github.com/davidhalter/typeshed/archive/${TYPESHED_P#typeshed-}.tar.gz
+ -> ${TYPESHED_P}.tar.gz
+ https://github.com/davidhalter/django-stubs/archive/${DJANGO_STUBS_P#django-stubs-}.tar.gz
+ -> ${DJANGO_STUBS_P/v/}.tar.gz
+"
+
+LICENSE="
+ MIT
+ test? ( Apache-2.0 )
+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ =dev-python/parso-0.8*[${PYTHON_USEDEP}]
+"
+
+# RDEPEND needed because of an import jedi inside conf.py
+distutils_enable_sphinx docs \
+ dev-python/parso \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # upstream includes these as submodules ...
+ rmdir "${S}"/jedi/third_party/{django-stubs,typeshed} || die
+ mv "${WORKDIR}/${DJANGO_STUBS_P/v/}" \
+ "${S}/jedi/third_party/django-stubs" || die
+ mv "${WORKDIR}/${TYPESHED_P}" \
+ "${S}/jedi/third_party/typeshed" || die
+
+ # don't run doctests, don't depend on colorama
+ sed -i "s:'docopt',:: ; s:'colorama',::" setup.py || die
+ sed -i "s: --doctest-modules::" pytest.ini || die
+
+ # test_complete_expanduser relies on $HOME not being empty
+ > "${HOME}"/somefile || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fragile
+ test/test_speed.py
+ # assumes pristine virtualenv
+ test/test_inference/test_imports.py::test_os_issues
+ )
+ [[ ${EPYTHON} != python3.8 ]] && EPYTEST_DESELECT+=(
+ # TODO
+ 'test/test_integration.py::test_completion[lambdas:112]'
+ )
+
+ # some plugin breaks case-insensitivity on completions
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # django and pytest tests are very version dependent
+ epytest -k "not django and not pytest"
+}