summaryrefslogtreecommitdiff
path: root/dev-python/jedi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-30 22:42:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-30 22:42:58 +0100
commit3b4199328e240d392ef1f03900219cb88bdafcff (patch)
tree06007a008d485a5e0a169f2807b68f456e9df1b3 /dev-python/jedi
parentaca0af8133e724b7edf0b5c6efe12c39077a3dc9 (diff)
gentoo auto-resync : 30:07:2023 - 22:42:58
Diffstat (limited to 'dev-python/jedi')
-rw-r--r--dev-python/jedi/Manifest2
-rw-r--r--dev-python/jedi/jedi-0.19.0.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/jedi/Manifest b/dev-python/jedi/Manifest
index e9baf780d7af..494cdbb40b20 100644
--- a/dev-python/jedi/Manifest
+++ b/dev-python/jedi/Manifest
@@ -1,5 +1,7 @@
DIST django-stubs-fd057010f6cbf176f57d1099e82be46d39b99cb9.tar.gz 183312 BLAKE2B a68f6139903f5001db994ee0d881f40ab74932e81c3e2c3a0c22dc56e6be681d0fb42ce837603b21e4d0d448ccb25884ef0f69039305f309e82603267cee9f6a SHA512 506322c132f94e6a1e88cdbde6027a566387731fa6ad59934f95c3511f49d90eff2a3138363811be648b096407d418cd1f801df0bc35b1e464ef181e4076ada1
DIST jedi-0.18.2.gh.tar.gz 469286 BLAKE2B 6b65a231d092a6869b55c14a8254c4716695f46cdc9733f50607cf7bb8c864f319e2abfbe812bffc514c78cd92059fc29fa9cc0a38b1e14d6bc8bf3ad3596097 SHA512 1df24190c7d468f388e7175f4625670df81cd9a533c8bde12b1e0eaf982a173bdd001bbea6680144cc50ca263fa2b802da5d71de555f81717f4377c46826d0d1
+DIST jedi-0.19.0.gh.tar.gz 472334 BLAKE2B 04e8fda32c2d0b0476d197c5686011f811d5c269cdb61b15d0bafa9e3aabed05deb44f98d2e3a25faf7bd130b3a9289d058ed06199fc760357d34c551ecc5ad0 SHA512 0db8c7859e55057afc0367455c2f3817d8f05a19b6fbdc163a74f07854562c9c29307c7f8ac92e0ce9349353ac148f728a25b3be4cc62dc35f3060bdb79b02c8
DIST typeshed-ae9d4f4b21bb5e1239816c301da7b1ea904b44c3.tar.gz 602044 BLAKE2B 53298918a7e9a1163e76d4c70ad2a2117ee90b49329aa82d82b2aaaeaf000c971872f83ed283af6dc4be068b813876760c8b1b4acb4131865572a4aed3ea9230 SHA512 b3b9da66b6c6e03e0b262b3262df31215a5e080468ca9ebf4332ed53d715cd3956db7067fad3ec267042ff704f81ac665c703ef2fd0c5b445d440bd8e52bf1aa
EBUILD jedi-0.18.2.ebuild 2211 BLAKE2B 6a8dbaf79e22c5253f571fabc273a85d53d0ce5ba0c7b30f26d4817ae3f835f9210ae24a360538fce9fcc676ce3221bd6fc805a2adbe5a1e59e53121413aba44 SHA512 d307c4f5dde81f6269634d1583fd195d0823fc71d75a8e726e4ce7976b6c85f7ec305919b23a6e8c1aad158eb456a5708608771c1e9c64217ea11db2ce8c141f
+EBUILD jedi-0.19.0.ebuild 1991 BLAKE2B 8ce299f129c4465902443a6641d4b66b7f132797bcc7f87b1ddfdead518ddd97067e2a9b1fa9e08009bc8b96f83fce5b6517b97b56088375fcf3ab9acf15bac4 SHA512 cbe96850e3ebd32f2726393d536c42ab0b2e492247a5e93ecdaa40e236e77e5044887c29e145b929ed82e167416904b4868a0a81226c38a693ad22d4b5a838cb
MISC metadata.xml 401 BLAKE2B c540d55ee88ab5a7be9ec902059a766a754da42ba5c1836c990d0d64edfec91fa33e8a745b9a15ce4a97831259150e0298fe2a5ed4c21993be73d9fd7af3d865 SHA512 6af98463225428333ec509b334014bd307569ce852f640a1f1c1e18f7551185d8db9b7c80822012c14f3c6ca1cf79ff24f289df3cd42803759d012a1a73ac07c
diff --git a/dev-python/jedi/jedi-0.19.0.ebuild b/dev-python/jedi/jedi-0.19.0.ebuild
new file mode 100644
index 000000000000..62299e208df7
--- /dev/null
+++ b/dev-python/jedi/jedi-0.19.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+TYPESHED_P="typeshed-ae9d4f4b21bb5e1239816c301da7b1ea904b44c3"
+DJANGO_STUBS_P="django-stubs-fd057010f6cbf176f57d1099e82be46d39b99cb9"
+
+DESCRIPTION="Autocompletion library for Python"
+HOMEPAGE="
+ https://github.com/davidhalter/jedi/
+ https://pypi.org/project/jedi/
+"
+SRC_URI="
+ https://github.com/davidhalter/jedi/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ https://github.com/davidhalter/typeshed/archive/${TYPESHED_P#typeshed-}.tar.gz
+ -> ${TYPESHED_P}.tar.gz
+ https://github.com/davidhalter/django-stubs/archive/${DJANGO_STUBS_P#django-stubs-}.tar.gz
+ -> ${DJANGO_STUBS_P/v/}.tar.gz
+"
+
+LICENSE="
+ MIT
+ test? ( Apache-2.0 )
+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/parso-0.9[${PYTHON_USEDEP}]
+ >=dev-python/parso-0.8.3[${PYTHON_USEDEP}]
+"
+
+# RDEPEND needed because of an import jedi inside conf.py
+distutils_enable_sphinx docs \
+ dev-python/parso \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # upstream includes these as submodules ...
+ rmdir "${S}"/jedi/third_party/{django-stubs,typeshed} || die
+ mv "${WORKDIR}/${DJANGO_STUBS_P/v/}" \
+ "${S}/jedi/third_party/django-stubs" || die
+ mv "${WORKDIR}/${TYPESHED_P}" \
+ "${S}/jedi/third_party/typeshed" || die
+
+ # test_complete_expanduser relies on $HOME not being empty
+ > "${HOME}"/somefile || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fragile
+ test/test_speed.py
+ # assumes pristine virtualenv
+ test/test_inference/test_imports.py::test_os_issues
+ )
+
+ # some plugin breaks case-insensitivity on completions
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # django and pytest tests are very version dependent
+ epytest -o addopts= -k "not django and not pytest"
+}