summaryrefslogtreecommitdiff
path: root/dev-python/jedi/jedi-0.17.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/jedi/jedi-0.17.2-r1.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/jedi/jedi-0.17.2-r1.ebuild')
-rw-r--r--dev-python/jedi/jedi-0.17.2-r1.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/dev-python/jedi/jedi-0.17.2-r1.ebuild b/dev-python/jedi/jedi-0.17.2-r1.ebuild
deleted file mode 100644
index d49d1ea8809d..000000000000
--- a/dev-python/jedi/jedi-0.17.2-r1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-TYPESHED_P="typeshed-jedi_v0.16.0"
-DJANGO_STUBS_P="django-stubs-v1.5.0"
-
-DESCRIPTION="Autocompletion library for Python"
-HOMEPAGE="https://github.com/davidhalter/jedi"
-SRC_URI="
- https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz
- https://github.com/davidhalter/typeshed/archive/${TYPESHED_P#typeshed-}.tar.gz
- -> ${TYPESHED_P}.tar.gz
- https://github.com/davidhalter/django-stubs/archive/${DJANGO_STUBS_P#django-stubs-}.tar.gz
- -> ${DJANGO_STUBS_P/v/}.tar.gz"
-
-LICENSE="MIT
- test? ( Apache-2.0 )"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="=dev-python/parso-0.7*[${PYTHON_USEDEP}]"
-
-distutils_enable_sphinx docs \
- dev-python/sphinx_rtd_theme
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # upstream includes these as submodules ...
- rmdir "${S}"/jedi/third_party/{django-stubs,typeshed} || die
- mv "${WORKDIR}/${DJANGO_STUBS_P/v/}" \
- "${S}/jedi/third_party/django-stubs" || die
- mv "${WORKDIR}/${TYPESHED_P}" \
- "${S}/jedi/third_party/typeshed" || die
-
- # don't run doctests, don't depend on colorama
- sed -i "s:'docopt',:: ; s:'colorama',::" setup.py || die
- sed -i "s: --doctest-modules::" pytest.ini || die
-
- # test_complete_expanduser relies on $HOME not being empty
- > "${HOME}"/somefile || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local deselect=(
- # TODO
- 'test/test_integration.py::test_completion[stdlib:197]'
- 'test/test_integration.py::test_completion[on_import:29]'
- # assume pristine virtualenv
- test/test_utils.py::TestSetupReadline::test_local_import
- test/test_inference/test_imports.py::test_os_issues
- # fragile
- test/test_speed.py
- )
- [[ ${EPYTHON} == python3.10 ]] && deselect+=(
- # new features increased the match count again
- test/test_utils.py::TestSetupReadline::test_import
-
- )
-
- # django and pytest tests are very version dependent
- epytest ${deselect[@]/#/--deselect } -k "not django and not pytest"
-}