summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-vcs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /dev-python/jaraco-vcs
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'dev-python/jaraco-vcs')
-rw-r--r--dev-python/jaraco-vcs/Manifest4
-rw-r--r--dev-python/jaraco-vcs/jaraco-vcs-2.3.0.ebuild43
-rw-r--r--dev-python/jaraco-vcs/jaraco-vcs-2.3.1.ebuild43
3 files changed, 90 insertions, 0 deletions
diff --git a/dev-python/jaraco-vcs/Manifest b/dev-python/jaraco-vcs/Manifest
index 895bee0f584d..1d0d77af11f7 100644
--- a/dev-python/jaraco-vcs/Manifest
+++ b/dev-python/jaraco-vcs/Manifest
@@ -1,3 +1,7 @@
DIST jaraco_vcs-2.2.0.tar.gz 16660 BLAKE2B 9d48f78839e0e13aa5a520a167144deadce0d607c0bb378370d930d0aa1d94fe5778206384f29a449499e73b3cafc716358417d41f3016115b347d686e557269 SHA512 a842db1dac4beca4273b4a3afaec804bfc89286ad6eba6f9f47cd2b4dab7e04d9d12136bf555108fdbfe133fe62c71935be990b79cb0801766cc565c21343339
+DIST jaraco_vcs-2.3.0.tar.gz 16855 BLAKE2B 993acc379515d51932311ff2009f85195198f1dd11da14ed07de98263e993a93d791275ddf6a29722ece03513109ece3e8bc1f84f884872723aaf4950629811f SHA512 08ba6792efc78088b49bd40f013f08d5cb8632a4cc649d81f89fcf76b802a012d3d5e6fc315fcc0862e35510b79461e1887efeb4f9cdfa2369ffb360ca849673
+DIST jaraco_vcs-2.3.1.tar.gz 16957 BLAKE2B eeabf6b99d85a708ef3e5b012ea793e5f1923e0630ce3072b0e47d07401b4f98927397037438a167535ad510b37e106dc3dd6c19a76bd20373e8ef4533289054 SHA512 b6591fd17b4323c10d1e762b8efce71e127396a4922c148458ac12214feff62219511b92723c822807f4344b169a88f814fe15e23dcf14bc85f88926554d5822
EBUILD jaraco-vcs-2.2.0.ebuild 930 BLAKE2B f1eb166e07a9c13f1c71da2c9d83fa55d5a7398601f70e821b3acd21c713cd746c5e8fee4ae65796c8cf667b18f78ef560a3bc18a59366dd0401b165e70cfd73 SHA512 584fe7307821d9c2eaf2c9b85e1623f3ed1ad00633bc82e94fcdcb9668058ae987c5212504739f3113946da3efa32578506edf5dd8c72def439cb6166bc5896e
+EBUILD jaraco-vcs-2.3.0.ebuild 1019 BLAKE2B 7bcc0c508c1754baee7e7bf69f11220d74fcac006ba8eea42dbd672b0dfb216905483b99cbdb1afb8d67e162de3402c15ebfe4145bfe07d17861a7d95afeca5c SHA512 2b0796a3c7e8c25bb878977dfa35007c6ea8f717c18308d4b1db8218f674ece8bb66bdd183a299e24d82184a46a3ebab2022ed7037cdd7f38357255f50589a6a
+EBUILD jaraco-vcs-2.3.1.ebuild 1019 BLAKE2B 7bcc0c508c1754baee7e7bf69f11220d74fcac006ba8eea42dbd672b0dfb216905483b99cbdb1afb8d67e162de3402c15ebfe4145bfe07d17861a7d95afeca5c SHA512 2b0796a3c7e8c25bb878977dfa35007c6ea8f717c18308d4b1db8218f674ece8bb66bdd183a299e24d82184a46a3ebab2022ed7037cdd7f38357255f50589a6a
MISC metadata.xml 373 BLAKE2B 19541f09d8e907f217862f2f355342807e56aef7dd2be1ee1539f8dc784ec58612425a76e1793d3ffd8e5e7da02d9e860dbb8321c78d500d38a930401911005f SHA512 06bcc51993cddf2a0c427491e08438ca8db90c643ad9cfbd9abbdff5b9301c19d60025a6bb3e8f00d3556938a9c3f40107842d6fbe88c75a9c171412de18345e
diff --git a/dev-python/jaraco-vcs/jaraco-vcs-2.3.0.ebuild b/dev-python/jaraco-vcs/jaraco-vcs-2.3.0.ebuild
new file mode 100644
index 000000000000..eb42076193c3
--- /dev/null
+++ b/dev-python/jaraco-vcs/jaraco-vcs-2.3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Facilities for working with VCS repositories"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.vcs/
+ https://pypi.org/project/jaraco.vcs/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/jaraco-versioning[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/tempora[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jaraco-path[${PYTHON_USEDEP}]
+ dev-python/pytest-home[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # assumes running inside the git repo
+ jaraco/vcs/__init__.py::jaraco.vcs
+)
diff --git a/dev-python/jaraco-vcs/jaraco-vcs-2.3.1.ebuild b/dev-python/jaraco-vcs/jaraco-vcs-2.3.1.ebuild
new file mode 100644
index 000000000000..eb42076193c3
--- /dev/null
+++ b/dev-python/jaraco-vcs/jaraco-vcs-2.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Facilities for working with VCS repositories"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.vcs/
+ https://pypi.org/project/jaraco.vcs/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/jaraco-versioning[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/tempora[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jaraco-path[${PYTHON_USEDEP}]
+ dev-python/pytest-home[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # assumes running inside the git repo
+ jaraco/vcs/__init__.py::jaraco.vcs
+)