summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-text
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-15 01:41:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-15 01:41:15 +0100
commite0fdb8199de0e7a9b7c72d7f38d2e3ddaecdacd0 (patch)
tree7a71d24a0bfba0874deeb5e8131d579dfb40e1d1 /dev-python/jaraco-text
parent7cffc3e7845d1a3ae331145c5e1226e314badf4a (diff)
gentoo auto-resync : 15:07:2022 - 01:41:14
Diffstat (limited to 'dev-python/jaraco-text')
-rw-r--r--dev-python/jaraco-text/Manifest2
-rw-r--r--dev-python/jaraco-text/jaraco-text-3.8.1.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/jaraco-text/Manifest b/dev-python/jaraco-text/Manifest
index 5fb982c07d50..d223ec29c21e 100644
--- a/dev-python/jaraco-text/Manifest
+++ b/dev-python/jaraco-text/Manifest
@@ -1,3 +1,5 @@
DIST jaraco.text-3.8.0.tar.gz 13078 BLAKE2B 0c081fea1bc20150347636c46b489d4c09ab0c553d44b9f68c4e2d7b3ca35574801a740d4b907f03956a6817ba0ecc07945809c1619248563bb29974b0448577 SHA512 3526f1371d8f2e7c79dff61941b1b4ead3d0f4b5144f0e22dbd098ec244b9ffddba4bbeaa0d817a80ff422fa5c7ae11d0959d3f56044d7c5f95d8c8a5de8ad2f
+DIST jaraco.text-3.8.1.tar.gz 14160 BLAKE2B 3f8af8881665a8eb9876ae3c76ccaa68f3c58f402e1761956235bda2089e6c5e72f7968ce7fd9dd7b8dc31a08228a715c8c715dc5a93e4453af1b94c2253bce6 SHA512 2dfdd2b3bfef7c0a38a633b810a63a4337ce79b0c871f08beb369bea04585ef1b9e53afa7cef0b54c172ca25eed068af92215526d2f5cee232ccf7e72c914cfa
EBUILD jaraco-text-3.8.0.ebuild 1726 BLAKE2B 9c4c1582b826e57babb5dbb7e6eec9d8749194b1839a40a543568f0945a691c2916a64ebb5af289c264f1afe7f3d17039148e14cd7fb0ccef361e12714bb8548 SHA512 05105d62a1a75541c4aac71b3fc55abd2969aa978151a0f6113c027138f88c65408328d54858b7bc690801050ace4ff1f8f9da2a02e6e0e452af083acf2641d5
+EBUILD jaraco-text-3.8.1.ebuild 1734 BLAKE2B 0bc14806e87d40f0b8b479404bb15e17a303ba3b63b7ba6af2543702e3a17f330660f47ac59b1de0be8aa65a35fe3b167bfe47ee9a62922d8f63d66d2d8af4c8 SHA512 7e7abd9bb5a873af6fde42547b0a01c32d138f9c922c811ecc602f1bbf9154295fe5348de15b1c8ba9675c729a6c1acc39fe7d6dbdd9bc31cf4a1b0cfb8a6d39
MISC metadata.xml 656 BLAKE2B 0a887f3b936ada76caabedd24bcfc8d1d53047705761370fdf5c2cbe204b4d7c8449813268e9a45b48409f713e038f5742db12029bb3974b703317e7c3eaa28c SHA512 c8dc08d4347fec9076d6c23899ccb6fadbeee43d64875d8ea727ce20c2c5429a2683d162d602b763ef740c8eeb213762b17b2c964132923a647b769e2372763c
diff --git a/dev-python/jaraco-text/jaraco-text-3.8.1.ebuild b/dev-python/jaraco-text/jaraco-text-3.8.1.ebuild
new file mode 100644
index 000000000000..0a28f2d6bd8d
--- /dev/null
+++ b/dev-python/jaraco-text/jaraco-text-3.8.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="Text utilities used by other projects by developer jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.text/
+ https://pypi.org/project/jaraco.text/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-python/jaraco-context-4.1.1-r1[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-functools-3.5.0-r1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_resources-5.4.0-r3[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-3.2" \
+ ">=dev-python/rst-linker-1.9"
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "jaraco.text"
+ version = "${PV}"
+ description = "Module for text manipulation"
+ EOF
+}
+
+python_install() {
+ distutils-r1_python_install
+ # rename to workaround a bug in pkg_resources
+ # https://bugs.gentoo.org/834522
+ mv "${D}$(python_get_sitedir)"/jaraco{_,.}text-${PV}.dist-info || die
+}