summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-text
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-15 12:27:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-15 12:27:33 +0100
commit868fd5dc8aab84930cfaa5252b8be06b35552765 (patch)
tree0c0cebf818c30c6f871f00ce1e7599775a7e561c /dev-python/jaraco-text
parentf7adcd4ee556b2c3a420239c13fb74113d791f6a (diff)
gentoo auto-resync : 15:07:2024 - 12:27:33
Diffstat (limited to 'dev-python/jaraco-text')
-rw-r--r--dev-python/jaraco-text/Manifest2
-rw-r--r--dev-python/jaraco-text/jaraco-text-3.14.0.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/jaraco-text/Manifest b/dev-python/jaraco-text/Manifest
index c3938129ec50..6cae471f25f2 100644
--- a/dev-python/jaraco-text/Manifest
+++ b/dev-python/jaraco-text/Manifest
@@ -1,3 +1,5 @@
DIST jaraco_text-3.12.1.tar.gz 16580 BLAKE2B 89f11877052e6b7cacbee4ae53ea140ce337a3a8f25657c558e3634378d20ac70206fd188f8492bdc725ebfec94c7f553ec61a9a3be97738918746fab79a9414 SHA512 4a459e497259de8dc37fbe92eec19973f5d1425f23212221885339a9c7b0f432301978c3c918f4cdd4e1cb3e50b465aad07634ab8cf40f86151d08b150d097e4
+DIST jaraco_text-3.14.0.tar.gz 16824 BLAKE2B 62a4db8fc6e7148d81dacaab08a3dd3478a74e9cb0377a3b9cbce538575542cd99b42f599af04fdfa62be06d3edb7a7f7f4b27883e91608e8d1033c655ee8304 SHA512 3557876c0ab2e1a54c8ce85663b45c9c143a88bb64a5d9c3e2354b2af229b25983b7977c576f83add1b5bae79cceebb01206c756a354eca24681a57a0ee14fb4
EBUILD jaraco-text-3.12.1.ebuild 1600 BLAKE2B 3b00ce7b3eff3ea84f5cb9354c718432e4be7d0d46fc3223d6935519c89ed5785ef5343ddeb5c92caab5b2d698fd1b456793e10bfa57cc85957cb4e59d9834a2 SHA512 bc5acd736d4da2f3707e40ac57d2ee7f2e1a82396b4b5d454e551693ffe46f40c8baf7e3a5693f08054cff290a61de3d490f01ef778cee51346a8a67261af7a0
+EBUILD jaraco-text-3.14.0.ebuild 1608 BLAKE2B fd42ecc1cf26da7f7714f1e335ebd7e7bbdf8b02da76c89af1173158384268938cf3bd714c8850f94442a0eace835fabb468e5a1a473b99e66229d9d599d134b SHA512 000a90f663cafccf5526c6cd82afa8e342dc5be619850d201d57951518ee30553545b65b0e0f7a0f4bc1f8f309d615a21d424042efc030b5815c3909b2d6953f
MISC metadata.xml 463 BLAKE2B d5103f7438fd4e08183a9e00ad91bc4d25d54a9885868760201a61531d9bd6f4710a019b7a2f17b00403eed20a41bc51ef74eeb70aca76c3c351458ae20c45ae SHA512 b508e2bd43f237a89e415a37d0debb7c980dea2191a5556108002e297e52356b43551a147e9121f98380ca22495a742a2ca9652916810a7c0bd4c0d47e9268e6
diff --git a/dev-python/jaraco-text/jaraco-text-3.14.0.ebuild b/dev-python/jaraco-text/jaraco-text-3.14.0.ebuild
new file mode 100644
index 000000000000..09e788276ec8
--- /dev/null
+++ b/dev-python/jaraco-text/jaraco-text-3.14.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Text utilities used by other projects by developer jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.text/
+ https://pypi.org/project/jaraco.text/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ >=dev-python/jaraco-context-4.1.1-r1[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-functools-3.5.0-r1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "jaraco.text"
+ version = "${PV}"
+ description = "Module for text manipulation"
+ EOF
+
+ # remove CLI tools, they have annoying deps, no entry points
+ # and since there are dashes in their names, they can't be imported
+ # anyway
+ rm jaraco/text/*-*.py || die
+}
+
+python_install() {
+ distutils-r1_python_install
+ # rename to workaround a bug in pkg_resources
+ # https://bugs.gentoo.org/834522
+ mv "${D}$(python_get_sitedir)"/jaraco{_,.}text-${PV}.dist-info || die
+}