summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-text
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-28 10:54:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-28 10:54:09 +0000
commit3e690338421a6b64f6f44aa03db7416d75e0633a (patch)
treecb3907b4dfbc040edc539fd00645e851b14084bb /dev-python/jaraco-text
parenta6f8a4117d60ec2919f9b312dcb0b7baa6c58ab9 (diff)
gentoo auto-resync : 28:11:2023 - 10:54:09
Diffstat (limited to 'dev-python/jaraco-text')
-rw-r--r--dev-python/jaraco-text/Manifest2
-rw-r--r--dev-python/jaraco-text/jaraco-text-3.12.0.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/jaraco-text/Manifest b/dev-python/jaraco-text/Manifest
index 24ff009a1621..6311129f68e0 100644
--- a/dev-python/jaraco-text/Manifest
+++ b/dev-python/jaraco-text/Manifest
@@ -1,3 +1,5 @@
DIST jaraco.text-3.11.1.tar.gz 16083 BLAKE2B f7268128209fbdc849a745595339f4dc9a097f3f4f8f0cdcb05ca3106ed5a45460126fbb2b7d9c3b01b63aa3f750175e8cd366034183b7d8804a1650fe493e4b SHA512 b4066589e9d4c9a2a82ae2b0825d34b22b93ee179d29c3666e9b978390121520afcb8fc5ffa6457022d2e8477f4cf2b76485d9896438ee46275326577609f201
+DIST jaraco.text-3.12.0.tar.gz 16329 BLAKE2B e1314b3121d5d75ac4a986a342c3290f5523bb45be8bf8e994ed87188712464e75a805498a7d846aea157aa8592fbca444842d1b70a21e0add49e89dfa743a7a SHA512 75068006c96dae3b8d21228f2ae21820939c68b1fb7e5db35bd0c1126a20399eb4d99c6bea15e88076599956c4b41104558cd32d860d8f4fd4e96aeeb22711c9
EBUILD jaraco-text-3.11.1-r1.ebuild 1620 BLAKE2B 215ee25262ab7197d201cbc0d5b6abc5a182cfb16fd4cf2c34006b4775d1fd780dd0e0527cf556215ef4fc2c21f4dee6d64a8f037469c8105e449227c929c7cd SHA512 f2154b0b5041b3b343672d327eb14ee8c7444d84ef09c376b8305144884971c9c1bd2788a09cfa620f307a3925872b0ac4eed8b94fd1caa75e4df0c5a8719629
+EBUILD jaraco-text-3.12.0.ebuild 1628 BLAKE2B 902ae697664d36d7b9a41946f0c3b3f12ee7ed52065003d235a671f56b824d56d334a116a3a39cfd34fb750c700a499dcc8d756c42dbac3e8260432d5903d643 SHA512 82fe78cd8a9bc91c9578676c71de82c73e7a7f1b6fd2ba4822a00fa651765d8c486b3c522fc01933d164ebb05c1bd6365cca3284b1387ef05b845289e5988a0a
MISC metadata.xml 463 BLAKE2B d5103f7438fd4e08183a9e00ad91bc4d25d54a9885868760201a61531d9bd6f4710a019b7a2f17b00403eed20a41bc51ef74eeb70aca76c3c351458ae20c45ae SHA512 b508e2bd43f237a89e415a37d0debb7c980dea2191a5556108002e297e52356b43551a147e9121f98380ca22495a742a2ca9652916810a7c0bd4c0d47e9268e6
diff --git a/dev-python/jaraco-text/jaraco-text-3.12.0.ebuild b/dev-python/jaraco-text/jaraco-text-3.12.0.ebuild
new file mode 100644
index 000000000000..c1747da85d28
--- /dev/null
+++ b/dev-python/jaraco-text/jaraco-text-3.12.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Text utilities used by other projects by developer jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.text/
+ https://pypi.org/project/jaraco.text/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ >=dev-python/jaraco-context-4.1.1-r1[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-functools-3.5.0-r1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "jaraco.text"
+ version = "${PV}"
+ description = "Module for text manipulation"
+ EOF
+
+ # remove CLI tools, they have annoying deps, no entry points
+ # and since there are dashes in their names, they can't be imported
+ # anyway
+ rm jaraco/text/*-*.py || die
+}
+
+python_install() {
+ distutils-r1_python_install
+ # rename to workaround a bug in pkg_resources
+ # https://bugs.gentoo.org/834522
+ mv "${D}$(python_get_sitedir)"/jaraco{_,.}text-${PV}.dist-info || die
+}