summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-text
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/jaraco-text
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/jaraco-text')
-rw-r--r--dev-python/jaraco-text/Manifest2
-rw-r--r--dev-python/jaraco-text/jaraco-text-3.8.0.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/jaraco-text/Manifest b/dev-python/jaraco-text/Manifest
index de3d8cabb794..ef6223d76119 100644
--- a/dev-python/jaraco-text/Manifest
+++ b/dev-python/jaraco-text/Manifest
@@ -1,3 +1,5 @@
DIST jaraco.text-3.7.0.tar.gz 12054 BLAKE2B 54528808695e2f1f04165e3de42d1715bb3e3ee1450ee8d8759814d209ba98c181d1746a916816dd50703e5a4e26ad7986f389619324ffbabaa89be90fd3908c SHA512 559dc5ed0f2c0b46dd0cbbc112ab01bbdb68bc12923cff8f745a5e233696ca9f50cef6dbf60116df5121f4761457574deebea142c2a23ca6c4664d7395b5607e
+DIST jaraco.text-3.8.0.tar.gz 13078 BLAKE2B 0c081fea1bc20150347636c46b489d4c09ab0c553d44b9f68c4e2d7b3ca35574801a740d4b907f03956a6817ba0ecc07945809c1619248563bb29974b0448577 SHA512 3526f1371d8f2e7c79dff61941b1b4ead3d0f4b5144f0e22dbd098ec244b9ffddba4bbeaa0d817a80ff422fa5c7ae11d0959d3f56044d7c5f95d8c8a5de8ad2f
EBUILD jaraco-text-3.7.0-r2.ebuild 1695 BLAKE2B 49d95eb0407a7e85bb8f2a7629698729d51a7d926988278c5db375cf211dbee981f689bb25efa3ac9100d7d1690e15181f08a3959cf42636374c5919c49cbca3 SHA512 44b751a72abad4e964136b504e4734da518fbd2854b9ea3c0b7be8fe5480e8b8564024cef91cd7b95f5a41a0e29b9d18a1a1d7f50a8dea26f274ab6547bc11ae
+EBUILD jaraco-text-3.8.0.ebuild 1734 BLAKE2B 0bc14806e87d40f0b8b479404bb15e17a303ba3b63b7ba6af2543702e3a17f330660f47ac59b1de0be8aa65a35fe3b167bfe47ee9a62922d8f63d66d2d8af4c8 SHA512 7e7abd9bb5a873af6fde42547b0a01c32d138f9c922c811ecc602f1bbf9154295fe5348de15b1c8ba9675c729a6c1acc39fe7d6dbdd9bc31cf4a1b0cfb8a6d39
MISC metadata.xml 656 BLAKE2B 0a887f3b936ada76caabedd24bcfc8d1d53047705761370fdf5c2cbe204b4d7c8449813268e9a45b48409f713e038f5742db12029bb3974b703317e7c3eaa28c SHA512 c8dc08d4347fec9076d6c23899ccb6fadbeee43d64875d8ea727ce20c2c5429a2683d162d602b763ef740c8eeb213762b17b2c964132923a647b769e2372763c
diff --git a/dev-python/jaraco-text/jaraco-text-3.8.0.ebuild b/dev-python/jaraco-text/jaraco-text-3.8.0.ebuild
new file mode 100644
index 000000000000..0a28f2d6bd8d
--- /dev/null
+++ b/dev-python/jaraco-text/jaraco-text-3.8.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="Text utilities used by other projects by developer jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.text/
+ https://pypi.org/project/jaraco.text/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-python/jaraco-context-4.1.1-r1[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-functools-3.5.0-r1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_resources-5.4.0-r3[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-3.2" \
+ ">=dev-python/rst-linker-1.9"
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "jaraco.text"
+ version = "${PV}"
+ description = "Module for text manipulation"
+ EOF
+}
+
+python_install() {
+ distutils-r1_python_install
+ # rename to workaround a bug in pkg_resources
+ # https://bugs.gentoo.org/834522
+ mv "${D}$(python_get_sitedir)"/jaraco{_,.}text-${PV}.dist-info || die
+}