summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-test
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-21 01:00:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-21 01:00:11 +0000
commitee93fbc2bb111cf895ae00cc1877c68f0eafaf2a (patch)
treef4cdf4b4814dfa35e701a066e3bc3c50f6afd7cf /dev-python/jaraco-test
parentdbd6eaafcce6a59fa9b3323124c38fa17aa88e26 (diff)
gentoo auto-resync : 21:03:2024 - 01:00:11
Diffstat (limited to 'dev-python/jaraco-test')
-rw-r--r--dev-python/jaraco-test/Manifest2
-rw-r--r--dev-python/jaraco-test/jaraco-test-5.4.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/jaraco-test/Manifest b/dev-python/jaraco-test/Manifest
index 8aced910784d..a1ad7e8d8715 100644
--- a/dev-python/jaraco-test/Manifest
+++ b/dev-python/jaraco-test/Manifest
@@ -1,3 +1,5 @@
DIST jaraco.test-5.3.0.tar.gz 8199 BLAKE2B bb44899e9d459350b7edff1a0212afada0765b250e7450c28e15da958632b33a17777d6db2b7ae9984772928003fbd368b6482889816198c971c77fd1f967bcd SHA512 31d2ea0557023c6996b786ee1b2a385ac8f22c2af66baab98c3a6b894bf1eaa7378a595d00bc46a537cc89fe87c9193733968fc8a586a58654b468b712d63728
+DIST jaraco.test-5.4.0.tar.gz 8838 BLAKE2B 3abdff298a61015363bda3e52d3b5226993169128386dbb620487dcf8b29926c9be0415a2a263ad311db04a591d446b9e6efaece2ab2bfbe7b2781ee2e6dcdd6 SHA512 ab260c3c5ef16e83e8be0821cb735941764c06bb414c3f913bf337b62267b177f3102f7a87241b182ef20760fdcce98f4f9c705335b0744b69f9a296d5215b1b
EBUILD jaraco-test-5.3.0.ebuild 926 BLAKE2B 4c47f2f786e8d58dfc2b3b330a09cdeda3a51918992629339fd6aeaaafa6aebcb7ec005b21c7701f3e5a3a8269b90f0096ff661b9895dc7254fd98b28dab1d7a SHA512 d17c83b8f4f47e4ab1a363fc0e98b14cd7a1215b26cf4984134449b5619703924c48592ebe48a2b9fe4c23823076ba9d5e029c96990ec454c047029ca5f1c3b4
+EBUILD jaraco-test-5.4.0.ebuild 1020 BLAKE2B 51252e3cdb0badf4937c4d18618b95378709c943a8e349c16419fb428f4443dd841640883effd91eec5f7b398d16fa207453d968a2cea20ead08c19c7b0f829b SHA512 3d2bb1f5eb8c789288f0e703a003dbd8f2eaf49d7263c0c4cb9ae6d1f85d1905dfb04289e0cd823f764cf2f355a7fc728bd71892bbf22d1859ed9f8953030cc3
MISC metadata.xml 397 BLAKE2B 24c07f0efc966e9d4445968ba639a5476a24a0885051e4eab17075ea9b7b6369fe9ed919ccdc0b51a1e667c8d327428caac2196c2a3e087d8b36176e7b4b2c81 SHA512 4fce74bc524dc018611c219b86b87b7643fe5d133309a00dd5ade217895165f85cfbe26b686c79fc4dd8b1e016b07c83c25afa1c015fc240ffa0ac75e4c17159
diff --git a/dev-python/jaraco-test/jaraco-test-5.4.0.ebuild b/dev-python/jaraco-test/jaraco-test-5.4.0.ebuild
new file mode 100644
index 000000000000..ad38014b1033
--- /dev/null
+++ b/dev-python/jaraco-test/jaraco-test-5.4.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Testing support by jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.test/
+ https://pypi.org/project/jaraco.test/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/jaraco-collections[${PYTHON_USEDEP}]
+ dev-python/jaraco-context[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # while technically these tests are skipped when Internet is
+ # not available (they test whether auto-skipping works), we don't
+ # want any Internet access whenever possible
+ local EPYTEST_DESELECT=(
+ tests/test_http.py::test_needs_internet
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m "not network"
+}