summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-test
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-31 02:18:46 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-31 02:18:46 +0000
commitd897af505afa85942967dd218e3005a4ad906e5a (patch)
treed4f9a7f725a474e5a863ef6371652e852076df6b /dev-python/jaraco-test
parentb449f73a7f391721e624420ba791536e3d6b17a8 (diff)
gentoo auto-resync : 31:12:2022 - 02:18:46
Diffstat (limited to 'dev-python/jaraco-test')
-rw-r--r--dev-python/jaraco-test/Manifest2
-rw-r--r--dev-python/jaraco-test/jaraco-test-5.2.0.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/jaraco-test/Manifest b/dev-python/jaraco-test/Manifest
index 69bbb092d8bb..9e5943d5140d 100644
--- a/dev-python/jaraco-test/Manifest
+++ b/dev-python/jaraco-test/Manifest
@@ -1,3 +1,5 @@
DIST jaraco.test-5.1.0.tar.gz 6700 BLAKE2B 69ac08ab7e1c8aeff45d25483f2bb2648ad57a5977dbff8aab844f114a15f054b782ad5b424d9baa805ab80fc7483362dc97320965ef0abe86573b1e7f40b97b SHA512 d1d93eab85068fcba94530df50da9221b7f574e58b2c4ed519c8c4dec7231aa982d588e29137418226f23e0f94bd98f47c0859cf14d7a58c1683ac8ccc24d900
+DIST jaraco.test-5.2.0.tar.gz 8000 BLAKE2B 21e0714537a9966cc285eb1458f313c354226903ee3da816d7a6620676716cf9c220f82963c8b8ea7ac7a1d641f174d5c72dcca43c68c62e4f929c411aa00d62 SHA512 25cd7d5defda6941569958ce61cf41b54555d54c7dc1e115de409d6da352f8e8c09b8671adbdfdc00cf6f1c60a0d43201680c40dbeda44bdcf11a0e64cb23751
EBUILD jaraco-test-5.1.0-r1.ebuild 814 BLAKE2B 485fa57bf60eaf93425b47fb479e2ec2a9c9408b57c8652f6a4e0fae706744a80270a7b366a640e6a0e2ea2dc391d0e5b48d2414a7ecea148d26f1570c17595d SHA512 125dd57f0fffaa8db952118c44b868f4db16d64cb93bcdc52e7356c3e96d5b15d2165adc69c22625aee32898fee93f5660618d5041239c93287771ba517bb5f3
+EBUILD jaraco-test-5.2.0.ebuild 629 BLAKE2B b7569aad037c8b84caa4f3898f8f31b1346b194e8810f87258801247b820abd11d4fe54b82bdcde6f1d3f9e4852e2a2b1113695cfe953aff93d499007c72583a SHA512 6e8cb2e1a5a757b24ac79ab815ef0d0a2b61606944554607b0c1dce1410d425e2a1280472f46c4e71c26fc0f37f59333d849055be60d8a3530c965b4b026494c
MISC metadata.xml 397 BLAKE2B 24c07f0efc966e9d4445968ba639a5476a24a0885051e4eab17075ea9b7b6369fe9ed919ccdc0b51a1e667c8d327428caac2196c2a3e087d8b36176e7b4b2c81 SHA512 4fce74bc524dc018611c219b86b87b7643fe5d133309a00dd5ade217895165f85cfbe26b686c79fc4dd8b1e016b07c83c25afa1c015fc240ffa0ac75e4c17159
diff --git a/dev-python/jaraco-test/jaraco-test-5.2.0.ebuild b/dev-python/jaraco-test/jaraco-test-5.2.0.ebuild
new file mode 100644
index 000000000000..8b5ed987f9b2
--- /dev/null
+++ b/dev-python/jaraco-test/jaraco-test-5.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="Testing support by jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.test/
+ https://pypi.org/project/jaraco.test/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+RDEPEND="
+ dev-python/jaraco-context[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest