summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-test
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-13 00:01:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-13 00:01:18 +0100
commita25cc082a26782e5d39ded4559c91ff11bc3c299 (patch)
tree6cd0802dd248058d540f1f5f472c5df98216f154 /dev-python/jaraco-test
parentd72a987a342949e200b5e9decbd71f246da53788 (diff)
gentoo auto-resync : 13:05:2024 - 00:01:18
Diffstat (limited to 'dev-python/jaraco-test')
-rw-r--r--dev-python/jaraco-test/Manifest2
-rw-r--r--dev-python/jaraco-test/jaraco-test-5.4.0.ebuild9
2 files changed, 9 insertions, 2 deletions
diff --git a/dev-python/jaraco-test/Manifest b/dev-python/jaraco-test/Manifest
index 5ef56bd599fd..cec0d3af85c4 100644
--- a/dev-python/jaraco-test/Manifest
+++ b/dev-python/jaraco-test/Manifest
@@ -1,3 +1,3 @@
DIST jaraco.test-5.4.0.tar.gz 8838 BLAKE2B 3abdff298a61015363bda3e52d3b5226993169128386dbb620487dcf8b29926c9be0415a2a263ad311db04a591d446b9e6efaece2ab2bfbe7b2781ee2e6dcdd6 SHA512 ab260c3c5ef16e83e8be0821cb735941764c06bb414c3f913bf337b62267b177f3102f7a87241b182ef20760fdcce98f4f9c705335b0744b69f9a296d5215b1b
-EBUILD jaraco-test-5.4.0.ebuild 1018 BLAKE2B a8c0b93f17937761b74217f8b8e2557c37c7aa772fd5eb4adc69775b77cbf7265c0e864061603c2272c85887181461fd77d8cca9b9841ec68760ae2e8fa6ce5f SHA512 483ffe8dde530887ebbe891bd7f8ce9d9573cc9dee8bd7ca1901932dc493443e33a56bc3dc68bab4a29f04d5f813b41d290495a75bc1e1e3be7553fecd1d05bf
+EBUILD jaraco-test-5.4.0.ebuild 1175 BLAKE2B 9e6a9ca10738d845da19c39bdd80af03dbd609442a6b9a93059b37c2b069cb4bf062c79675f8d581c41bb0d8f79ca550d64410c3cb752dacb94a30716afbb265 SHA512 f73089fb8ff98e20c80427428f204254378c8760bcefceac9c6ab6b388034a335e02ff446dd984c85bac01b70585e29fe77159c118d3b8766452d7a00b75f565
MISC metadata.xml 397 BLAKE2B 24c07f0efc966e9d4445968ba639a5476a24a0885051e4eab17075ea9b7b6369fe9ed919ccdc0b51a1e667c8d327428caac2196c2a3e087d8b36176e7b4b2c81 SHA512 4fce74bc524dc018611c219b86b87b7643fe5d133309a00dd5ade217895165f85cfbe26b686c79fc4dd8b1e016b07c83c25afa1c015fc240ffa0ac75e4c17159
diff --git a/dev-python/jaraco-test/jaraco-test-5.4.0.ebuild b/dev-python/jaraco-test/jaraco-test-5.4.0.ebuild
index 185131c7284f..005487247012 100644
--- a/dev-python/jaraco-test/jaraco-test-5.4.0.ebuild
+++ b/dev-python/jaraco-test/jaraco-test-5.4.0.ebuild
@@ -6,7 +6,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
PYPI_PN=${PN/-/.}
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 pypi
@@ -28,6 +28,13 @@ RDEPEND="
distutils_enable_tests pytest
+src_test() {
+ # workaround namespaces blocking test.support import (sigh!)
+ mv jaraco/test jaraco_test || die
+ rmdir jaraco || die
+ distutils-r1_src_test
+}
+
python_test() {
# while technically these tests are skipped when Internet is
# not available (they test whether auto-skipping works), we don't