summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-test
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/jaraco-test
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/jaraco-test')
-rw-r--r--dev-python/jaraco-test/Manifest3
-rw-r--r--dev-python/jaraco-test/jaraco-test-5.1.0.ebuild32
-rw-r--r--dev-python/jaraco-test/metadata.xml13
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/jaraco-test/Manifest b/dev-python/jaraco-test/Manifest
new file mode 100644
index 000000000000..202973253181
--- /dev/null
+++ b/dev-python/jaraco-test/Manifest
@@ -0,0 +1,3 @@
+DIST jaraco.test-5.1.0.tar.gz 6700 BLAKE2B 69ac08ab7e1c8aeff45d25483f2bb2648ad57a5977dbff8aab844f114a15f054b782ad5b424d9baa805ab80fc7483362dc97320965ef0abe86573b1e7f40b97b SHA512 d1d93eab85068fcba94530df50da9221b7f574e58b2c4ed519c8c4dec7231aa982d588e29137418226f23e0f94bd98f47c0859cf14d7a58c1683ac8ccc24d900
+EBUILD jaraco-test-5.1.0.ebuild 758 BLAKE2B 2c570885d3a1d085d127856c4fa21ff4997122516424b8f4d90ff484c39bc6ffffe3d7a71e38ece40d191c2c2c0f4f702e9046f16e27703792e2de90fed39f62 SHA512 e91394642e18bae7dd654321b3e95da2b54bc9a068d260d5c5adcb744783b56e2cacf66995168d254da920aeef696abbd546ad75502e8efb384152d8fba21cfd
+MISC metadata.xml 397 BLAKE2B 24c07f0efc966e9d4445968ba639a5476a24a0885051e4eab17075ea9b7b6369fe9ed919ccdc0b51a1e667c8d327428caac2196c2a3e087d8b36176e7b4b2c81 SHA512 4fce74bc524dc018611c219b86b87b7643fe5d133309a00dd5ade217895165f85cfbe26b686c79fc4dd8b1e016b07c83c25afa1c015fc240ffa0ac75e4c17159
diff --git a/dev-python/jaraco-test/jaraco-test-5.1.0.ebuild b/dev-python/jaraco-test/jaraco-test-5.1.0.ebuild
new file mode 100644
index 000000000000..17f5cf9d9c60
--- /dev/null
+++ b/dev-python/jaraco-test/jaraco-test-5.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="Testing support by jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.test/
+ https://pypi.org/project/jaraco.test/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+RDEPEND="
+ dev-python/jaraco-collections[${PYTHON_USEDEP}]
+ dev-python/jaraco-context[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/jaraco-test/metadata.xml b/dev-python/jaraco-test/metadata.xml
new file mode 100644
index 000000000000..4e41c7489006
--- /dev/null
+++ b/dev-python/jaraco-test/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">jaraco.test</remote-id>
+ <remote-id type="github">jaraco/jaraco.test</remote-id>
+ </upstream>
+</pkgmetadata>