summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-path
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/jaraco-path
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/jaraco-path')
-rw-r--r--dev-python/jaraco-path/Manifest2
-rw-r--r--dev-python/jaraco-path/jaraco-path-3.4.0.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/jaraco-path/Manifest b/dev-python/jaraco-path/Manifest
index 8ba51e25ff7d..0175c9c6584d 100644
--- a/dev-python/jaraco-path/Manifest
+++ b/dev-python/jaraco-path/Manifest
@@ -1,3 +1,5 @@
DIST jaraco.path-3.3.1.tar.gz 13287 BLAKE2B 8a803269fc02cc85391b4b1e1f2ee2a94c039d433b505aeb4aa0fcbb23731b802f236cd2de80dbb8b9e59297312892a085632f41234d3e1bb7d4bd04f62e00ba SHA512 00dac02fdc6df469f8661d552b16a8ee6150d86a7df9459264377a03e96fd94608f9782ad4cc2b2df67c64a10f8af26ed650b0bac0b1e59607d429abdbe64309
+DIST jaraco.path-3.4.0.tar.gz 9574 BLAKE2B 41c7b65be0f7f8ae93b2137f1527145ac91acde2a2d4e338cd68e35f7e5233e6a8dcfe9a0c07f36ae9cd2a00946031eb6b692cfaf1a299bf7a451f25b39cc8cc SHA512 00a853bffdde4a931938b1d193898c039e253018f06ca9d102ee8e07f797b4c9dac33eb50243f714e3f3e151b6ce2fed7d47e1b82ab18d3e8715525b57040a6a
EBUILD jaraco-path-3.3.1.ebuild 907 BLAKE2B 5b0c3f38b6ef122b0dacab1e9e2f3c8225d8ad4725f9f1cc47994612cd5ed15be913a14b5d3eee9afa1b50ba3f86ec8643dfb3bb79a272783f46a9d10cf56efb SHA512 daf4a17353ed63e92399ca866d7242aecd8166910ba080fbc63510829ba56612ca8934a5494e609c9b6b428b0ce30ad35c1a0474fb5c7e965cbfae310af29f4a
+EBUILD jaraco-path-3.4.0.ebuild 802 BLAKE2B 068a5bbee615bac95665ef3af0351c00ac10127f842fa811e831d17dcaa90baa96f15c55393146cc7783ed9839895341ca88b1ac5ac4bb2f7d59a5e70a298665 SHA512 e62d3fe864a0b5a16e9ec75ddf1010fd24a286dfdce722dbf597255ab0f809b47d30277ad9896ab60807c08ca9b9a2b19d57189aa97e76976246c8c9bf538887
MISC metadata.xml 397 BLAKE2B 899056eaa6d393d9c624e20ff93a644bd93f39505f701a085f22d4216154a3c1b19bb879bcbe45f077fba7d91ad5e34617283b10f535305b322c580712df10fc SHA512 104c1a8d8a2613ed4355b6537ce0733b36e915d98ad69204d2a7763dd6e7bbdf74c2cc2e66f34000426e04e79f19a84ca1d8a57e504c62adaa4386f372d34dda
diff --git a/dev-python/jaraco-path/jaraco-path-3.4.0.ebuild b/dev-python/jaraco-path/jaraco-path-3.4.0.ebuild
new file mode 100644
index 000000000000..e69564f41dd6
--- /dev/null
+++ b/dev-python/jaraco-path/jaraco-path-3.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P="${P/-/.}"
+DESCRIPTION="Miscellaneous path functions"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.path/
+ https://pypi.org/project/jaraco.path/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-8.2" \
+ ">=dev-python/rst-linker-1.9"
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests
+}