summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-path
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-22 12:26:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-22 12:26:19 +0100
commit628f24076811218385404d76a4a19a6687865493 (patch)
treee0578e763c8b7fd0a49dfcc2f2056f57c503e9a0 /dev-python/jaraco-path
parentbad9bf87b08d293eb79ebe14d1882e77da2b0ced (diff)
gentoo auto-resync : 22:08:2024 - 12:26:19
Diffstat (limited to 'dev-python/jaraco-path')
-rw-r--r--dev-python/jaraco-path/Manifest2
-rw-r--r--dev-python/jaraco-path/jaraco-path-3.7.1.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/jaraco-path/Manifest b/dev-python/jaraco-path/Manifest
index ea0bf74a60dc..e2b33688d9c1 100644
--- a/dev-python/jaraco-path/Manifest
+++ b/dev-python/jaraco-path/Manifest
@@ -1,3 +1,5 @@
DIST jaraco.path-3.7.0.tar.gz 11039 BLAKE2B d861cf9af9723d0dd59dff61242c7a5e7de439d0156e4fcc024c30c5cde2773ca0b501527fbade2cae84cc236f74d0e242179a4f51775dbde92cc0c9bed5b267 SHA512 22eba78273da9b354153bb45b2d62d9ba35466f78ad2bf728f4c284d19572443e7267c39008b3fd43b975c9dc258cddf3a3287adddd243e1031d182e6562072a
+DIST jaraco_path-3.7.1.tar.gz 11771 BLAKE2B 25ba1ff90514984be0885c0507ebe554372f4fa32aadda1a1bda8bde1781d60e81726fa899e863bf0d34ec49a79c57052b2b5b4035cd2655cdbb513df54da626 SHA512 aa002c649b4d0d4dbfc7bd3fe25b4ef71ca3c92d200029c282453002c75d3c642630b4ba4bfd0355a6311c72407fc874b3a092daa94ed99824f129119dd464d0
EBUILD jaraco-path-3.7.0.ebuild 642 BLAKE2B 05f33123d663e99677c3d5f64d03d2233104dc31542fedff520f81397c8cd07a3d47c886b19f54ab92fc2a6a71b1842852c4c5903277cf9a91f29713d915179a SHA512 d71e2c723eecae1e6e1466da24908409cae3028d71069cb7c3c7a7cbe9a1274a394c15e7459e0591eb4d24cd75c1eb897a929f668c6d8a9f6aa23173b9d13482
+EBUILD jaraco-path-3.7.1.ebuild 630 BLAKE2B 10d589ac8016d051734abf7d2ebbb328a1cf0191d5d2b0f50586c7eae206132386358bb6c1962021da2b06fc03588691d0060ff36494a248227cca1b6f6fe145 SHA512 aedb472dbdb87b02a0058a366d85a6aa0a013a35e357bd0d114ec9e32c35c37caf551731b380a36b321df7f8d111de94a0bca543e191ba7c4beed9ffc229d288
MISC metadata.xml 397 BLAKE2B 899056eaa6d393d9c624e20ff93a644bd93f39505f701a085f22d4216154a3c1b19bb879bcbe45f077fba7d91ad5e34617283b10f535305b322c580712df10fc SHA512 104c1a8d8a2613ed4355b6537ce0733b36e915d98ad69204d2a7763dd6e7bbdf74c2cc2e66f34000426e04e79f19a84ca1d8a57e504c62adaa4386f372d34dda
diff --git a/dev-python/jaraco-path/jaraco-path-3.7.1.ebuild b/dev-python/jaraco-path/jaraco-path-3.7.1.ebuild
new file mode 100644
index 000000000000..1240e7bad9a4
--- /dev/null
+++ b/dev-python/jaraco-path/jaraco-path-3.7.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Miscellaneous path functions"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.path/
+ https://pypi.org/project/jaraco.path/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests
+}