summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-path
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-24 06:30:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-24 06:30:58 +0000
commit17e417b73cb3e25edbc6541bd107bc9c593d66bd (patch)
tree866f98b73f846149d0c9e7e5a1cf0527b7c54e08 /dev-python/jaraco-path
parent338095605b6c9c82690f77f27a32490c9a57bdcb (diff)
gentoo auto-resync : 24:12:2024 - 06:30:57
Diffstat (limited to 'dev-python/jaraco-path')
-rw-r--r--dev-python/jaraco-path/Manifest2
-rw-r--r--dev-python/jaraco-path/jaraco-path-3.7.2.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/jaraco-path/Manifest b/dev-python/jaraco-path/Manifest
index a89d440979f0..23eda978185d 100644
--- a/dev-python/jaraco-path/Manifest
+++ b/dev-python/jaraco-path/Manifest
@@ -1,3 +1,5 @@
DIST jaraco_path-3.7.1.tar.gz 11771 BLAKE2B 25ba1ff90514984be0885c0507ebe554372f4fa32aadda1a1bda8bde1781d60e81726fa899e863bf0d34ec49a79c57052b2b5b4035cd2655cdbb513df54da626 SHA512 aa002c649b4d0d4dbfc7bd3fe25b4ef71ca3c92d200029c282453002c75d3c642630b4ba4bfd0355a6311c72407fc874b3a092daa94ed99824f129119dd464d0
+DIST jaraco_path-3.7.2.tar.gz 12360 BLAKE2B 0e0a70e0af49db7e4ce9b54825beb057214277dd57e62c48f0ff2388ff2d489fe82d8773f7544464a64f0e83a9b95c8f794a91de2e6000360f0ebfee2693b03d SHA512 7869308504601368ef94c414e4d0c19d6115dccbb0d50b5287a15d3d31948c93ccfd01db71c95d534f670fdf61b2e2c00deb873ee1e81b7f6bc1bdf0d3a1f9a9
EBUILD jaraco-path-3.7.1.ebuild 616 BLAKE2B db353c5e9cb29d1fed78b1159e27d8ed8ae1948d5019f2ae00d13863e588d219f66c6e71b584a4e28945bc3dfa057a32c9b0a8cc8cda9afe4cebfcfb683683dd SHA512 50dd4db750156a5fa47a877394d05b40fe91b637ffbb31cb378db1bf67a4d1cb1829605783f521e5bb2795faaeb314372a7953c3067763df945128947bd9c381
+EBUILD jaraco-path-3.7.2.ebuild 667 BLAKE2B 46e5fe6ed06593bfbbbad63f60a444aa9398971675ecf1eb2180856a5895035cd9b3de27f75d40c94431c263f4486efd43dd368de1f8e9ca72662939d4900e35 SHA512 a49655a003ef9ade8de36a8750d315e843880233b2e60113ffd8ece5f1dc1b8902215bab16e128c4d396871a0816c335bc7c95b375c07e7c2633a3417866db1d
MISC metadata.xml 397 BLAKE2B 899056eaa6d393d9c624e20ff93a644bd93f39505f701a085f22d4216154a3c1b19bb879bcbe45f077fba7d91ad5e34617283b10f535305b322c580712df10fc SHA512 104c1a8d8a2613ed4355b6537ce0733b36e915d98ad69204d2a7763dd6e7bbdf74c2cc2e66f34000426e04e79f19a84ca1d8a57e504c62adaa4386f372d34dda
diff --git a/dev-python/jaraco-path/jaraco-path-3.7.2.ebuild b/dev-python/jaraco-path/jaraco-path-3.7.2.ebuild
new file mode 100644
index 000000000000..97281217d16a
--- /dev/null
+++ b/dev-python/jaraco-path/jaraco-path-3.7.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Miscellaneous path functions"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.path/
+ https://pypi.org/project/jaraco.path/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests
+}