summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-path/jaraco-path-3.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/jaraco-path/jaraco-path-3.3.1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/jaraco-path/jaraco-path-3.3.1.ebuild')
-rw-r--r--dev-python/jaraco-path/jaraco-path-3.3.1.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/jaraco-path/jaraco-path-3.3.1.ebuild b/dev-python/jaraco-path/jaraco-path-3.3.1.ebuild
deleted file mode 100644
index cde818faceaf..000000000000
--- a/dev-python/jaraco-path/jaraco-path-3.3.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-MY_P="${P/-/.}"
-DESCRIPTION="Miscellaneous path functions"
-HOMEPAGE="https://github.com/jaraco/jaraco.path/"
-SRC_URI="mirror://pypi/${PN::1}/${PN/-/.}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
-"
-
-distutils_enable_sphinx docs \
- ">=dev-python/jaraco-packaging-8.2" \
- ">=dev-python/rst-linker-1.9"
-distutils_enable_tests pytest
-
-src_prepare() {
- # use the py3.7+ built-in
- sed -i -e '/singledispatch/d' setup.cfg || die
- sed -i -e 's:from singledispatch:from functools:' jaraco/path.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- epytest tests
-}