summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-logging
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/jaraco-logging
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/jaraco-logging')
-rw-r--r--dev-python/jaraco-logging/Manifest6
-rw-r--r--dev-python/jaraco-logging/jaraco-logging-1.3.1.ebuild43
-rw-r--r--dev-python/jaraco-logging/jaraco-logging-1.5.ebuild36
-rw-r--r--dev-python/jaraco-logging/metadata.xml18
4 files changed, 103 insertions, 0 deletions
diff --git a/dev-python/jaraco-logging/Manifest b/dev-python/jaraco-logging/Manifest
new file mode 100644
index 000000000000..7e197f3f0266
--- /dev/null
+++ b/dev-python/jaraco-logging/Manifest
@@ -0,0 +1,6 @@
+DIST jaraco.logging-1.3.1.tar.gz 4589 SHA256 e80e43a7b0d94bda2faacc1b996d5cc8bc6dcf20205048d18f4889f35e956580 SHA512 aaa2b29551a13358887e0747acb47ca2a6611ce1bfb08259bc70c7908929c4d2c45eefd7738e808b7b2404d723425efd69f9cb9601e0fb0c08f611bcf744ceae WHIRLPOOL 150101a7fa0b50a0130802638bd73124543c1836c27a96deb21be4eb6966028d58e4cabc6513a7149d08273a728ac1e46a27f78b6a139e304b16f14d2227abf3
+DIST jaraco.logging-1.5.tar.gz 5707 SHA256 05c8922640cd22e7c6cb71068ef494a227b61ae8a0cd43b28ab1fa08ef4f7cd3 SHA512 18f267bd0c764f38ff5223d4fd6e08d7d9fa568691db285155d7b955c71439474fd84edd61b20d57f6eac77394d4b3ddf9b35d8e6ba08a2db5dd4b2ada6e0d68 WHIRLPOOL 03e32aaf52030c8635f59627a91330de004fb564b0d330e11122ebe7bb05e467c66f83f248424b1308ab7aecfcef428b90c05cab896fff10c3e7e83087031096
+EBUILD jaraco-logging-1.3.1.ebuild 1049 SHA256 72a8b5e9e27b02fc0788dd9d12f3bb785b448d7853a100d5c6e4a9ff58034cc9 SHA512 d6594e11324ddca1a0815e011b3f28fe5e4121eeac88b104ff3835d832434d4a072e6a8fa09c18e49dfa1218d3cc152a53a660b97676942c4042dc5ae28c4291 WHIRLPOOL a3009ea8bc58280d5c93a9117b31bd346194e613f21716e9df8e17e54ef9b1979fddb21979cc41509b2b090281380400479fd0feff293dc227694ed995183d58
+EBUILD jaraco-logging-1.5.ebuild 858 SHA256 95c600a318e7ef38dfe1cf22a35717ba2fa60553eef64ae95d457adc0345b0c9 SHA512 72c358214ae4e6938551a57b808ca2b9c4f7f5c2cb184a53715882b80b5d6721765ea5ad7d0962076e0aeb66f082f61a26498f882f00de5740f21abc97663464 WHIRLPOOL 357149c9c31edb4e43d0af35ae07eaaa859b9b32d041535541482dc2e46d2871d8696e476b269be7fcfa3f289ff524261729e0c5de78af8c820eda959a81efe0
+MISC ChangeLog 946 SHA256 11174bc50d6ad0d3c769ee789a2063a9a55a3988855e25744c048a9615aeaf44 SHA512 5ef5e06eedd3a7fb9868948d4f33ca5e1296835eea3d01f67554e59e7fe3077bb77daf53de0f11907c8d5916d7179ce59a5baf3762173901b5b32f9333fb2411 WHIRLPOOL ee8884e85675166504bef078ac1686fed64e8772b1573bc8ffdaf372bc6f6cf8abbd38a6d1c1496d6fa213a4ab55b33da312560fc9bfd6fb77dacfcfc7832106
+MISC metadata.xml 653 SHA256 51695d82468fa057d1b7c1544160947dcaa779e55bf51e026487789176e93b20 SHA512 0b1186c769705f4f5d7ae8efe471f5e85d790ca13a276e6e4968b330f8c4872d01f5ea529909b7c4af2dabee7cd7ca1067552b5d649dff7505b338c24a3d480d WHIRLPOOL a539321a2d92dcef6b360230b93bd594e7a0e45055d3104ab2abd3d4710d6b0c3b68ea46aeb07b03ee5e18d11fc51d79dd2638698b23893c87d284becb3e8047
diff --git a/dev-python/jaraco-logging/jaraco-logging-1.3.1.ebuild b/dev-python/jaraco-logging/jaraco-logging-1.3.1.ebuild
new file mode 100644
index 000000000000..818e606076d6
--- /dev/null
+++ b/dev-python/jaraco-logging/jaraco-logging-1.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Additional facilities to supplement Python's stdlib logging module"
+HOMEPAGE="https://github.com/jaraco/jaraco.logging"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/tempora[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+ if use test && has_version "${CATEGORY}/${PN}"; then
+ die "Ensure $PN is not already installed or the test suite will fail"
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/jaraco-logging/jaraco-logging-1.5.ebuild b/dev-python/jaraco-logging/jaraco-logging-1.5.ebuild
new file mode 100644
index 000000000000..77544c7b4847
--- /dev/null
+++ b/dev-python/jaraco-logging/jaraco-logging-1.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Additional facilities to supplement Python's stdlib logging module"
+HOMEPAGE="https://github.com/jaraco/jaraco.logging"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/tempora[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/jaraco-logging/metadata.xml b/dev-python/jaraco-logging/metadata.xml
new file mode 100644
index 000000000000..06a11fe2096c
--- /dev/null
+++ b/dev-python/jaraco-logging/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sautier.louis@gmail.com</email>
+ <name>Louis Sautier</name>
+ <description>Proxied maintainer; set to assignee in all bugs</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">jaraco.logging</remote-id>
+ <remote-id type="github">jaraco/jaraco.logging</remote-id>
+ <bugs-to>https://github.com/jaraco/jaraco.logging/issues</bugs-to>
+ </upstream>
+</pkgmetadata>