summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-logging/jaraco-logging-3.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-29 22:47:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-29 22:47:16 +0100
commit8993ea73a9714d22178ba6ada8c04be83cd71ec7 (patch)
treeeec3cc3c457b3e760f6ca631fd51e0c004705e88 /dev-python/jaraco-logging/jaraco-logging-3.1.2.ebuild
parentae838334efa4ecfd172331e8f5ae4eea8c5dd876 (diff)
gentoo auto-resync : 29:08:2022 - 22:47:16
Diffstat (limited to 'dev-python/jaraco-logging/jaraco-logging-3.1.2.ebuild')
-rw-r--r--dev-python/jaraco-logging/jaraco-logging-3.1.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/jaraco-logging/jaraco-logging-3.1.2.ebuild b/dev-python/jaraco-logging/jaraco-logging-3.1.2.ebuild
new file mode 100644
index 000000000000..7c8eaa3c8628
--- /dev/null
+++ b/dev-python/jaraco-logging/jaraco-logging-3.1.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P="${P/-/.}"
+DESCRIPTION="Additional facilities to supplement Python's stdlib logging module"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.logging/
+ https://pypi.org/project/jaraco.logging/
+"
+SRC_URI="
+ https://github.com/jaraco/jaraco.logging/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/tempora[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ # create a pkgutil-style __init__.py in order to fix pytest's
+ # determination of package paths
+ cat > jaraco/__init__.py <<-EOF || die
+ __path__ = __import__("pkgutil").extend_path(__path__, __name__)
+ EOF
+ epytest --doctest-modules
+}