summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-context
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-21 12:26:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-21 12:26:06 +0100
commitbad9bf87b08d293eb79ebe14d1882e77da2b0ced (patch)
tree2e95088a05ca299b8369979d4b47f0f846657be7 /dev-python/jaraco-context
parentc431a44e3cfa102e5ef2c9d6bbac48e28c9b15cb (diff)
gentoo auto-resync : 21:08:2024 - 12:26:06
Diffstat (limited to 'dev-python/jaraco-context')
-rw-r--r--dev-python/jaraco-context/Manifest2
-rw-r--r--dev-python/jaraco-context/jaraco-context-6.0.1.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/jaraco-context/Manifest b/dev-python/jaraco-context/Manifest
index f6c0966f7f66..cfbdfd58c491 100644
--- a/dev-python/jaraco-context/Manifest
+++ b/dev-python/jaraco-context/Manifest
@@ -1,5 +1,7 @@
DIST jaraco.context-5.3.0.tar.gz 13345 BLAKE2B d2f429335ea80a6b50ea9574adc45c25c0fc78e8ebb5edde218bcbbe7a2b27ae6b5c17453e71904240d0d873ebef36f7c7aeda4424d3fea2dd9aaf01af6fb4c5 SHA512 f63bf272c45ff5c43499621651b78841259040ac98d67c9db75fadebb1c497c1156e05f23bf7c91df3e91f1e070acb9f7dc665e7b242ba7b1ac1cf99a619494d
DIST jaraco_context-6.0.0.tar.gz 14118 BLAKE2B 96901d173426e8bad5755c0e21ba789daf4217a7ed94efb81fdb3daf2d9a13f5875a17fa20a5193bb6a7a7c772b2b77e3b85a465039bdefa6231075a45133fda SHA512 a831ee8b732fc2b40e7de81d390fb5869317a127e5999a1c4f00f3ab81e04d4021733816e813c1ddbc1370540aca6205353c7a024f60d6f0dc59545abe505fa6
+DIST jaraco_context-6.0.1.tar.gz 13912 BLAKE2B e249916d41e936c4f261e5e4330f3d6b26b159772a1284521168313f41ef296ca82930e46837ae8ea7c895f7471bc039d5b42a8d4eceb0718056ff4b82d79cba SHA512 5711f581a616a18f7b7dbac65550255c7eecfae39df04b675817b16fbc5d61b833617d853c40f0b910c0ba5d144baf4c4b2add155c9b91001209b27da594a801
EBUILD jaraco-context-5.3.0.ebuild 1429 BLAKE2B 396b966d07a2b522424df1ca6ec231f6182da7488c5c537bc2ffc25942f55d1e016570e74a611c097ba319125630b46d4d510e59d4dc1fc1bf46af6e5ec5c243 SHA512 e5294b488f6d74c3766ae22e7401c2c49c21357f5b6ae358b30f45a76d7466cab1511343f602f80eab60feb1f88970651293130571b54f0a3f5a40e5a72a6379
EBUILD jaraco-context-6.0.0.ebuild 1508 BLAKE2B ae0d12d198eff46e483ffeb08c2816ae629d92cfc52792292a9eea669973e772681dc518375391fe85bba6d23c0f9269a985849e87009edf5ff5e1316eda4157 SHA512 b8fcbd9448bbe15bb4e7fb66203310fee555a1c0ddc391c79d577c80537e102f57c73813ca448ae5f0901b1a49c09f8d7a335583aac005ec6350c691a175f869
+EBUILD jaraco-context-6.0.1.ebuild 1508 BLAKE2B ae0d12d198eff46e483ffeb08c2816ae629d92cfc52792292a9eea669973e772681dc518375391fe85bba6d23c0f9269a985849e87009edf5ff5e1316eda4157 SHA512 b8fcbd9448bbe15bb4e7fb66203310fee555a1c0ddc391c79d577c80537e102f57c73813ca448ae5f0901b1a49c09f8d7a335583aac005ec6350c691a175f869
MISC metadata.xml 403 BLAKE2B 32344da5308b2bd5eef6ac6efc6299869f4f82ab67b51a23666eef697a803bcc94993ed67f3047e82ba5500d1b0c49ec1f9b32112855c21aa4b3015c09fa0144 SHA512 13dec82eb1581116d8800e60c99c328aa1bb409fec83044fa5e02838008e4bf5d81bc1defeb59bc353ff4032600bdc9213559bdb745fd6571f53e9edd9dd6737
diff --git a/dev-python/jaraco-context/jaraco-context-6.0.1.ebuild b/dev-python/jaraco-context/jaraco-context-6.0.1.ebuild
new file mode 100644
index 000000000000..bb3bb1f1507b
--- /dev/null
+++ b/dev-python/jaraco-context/jaraco-context-6.0.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Context managers by jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.context/
+ https://pypi.org/project/jaraco.context/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/backports-tarfile[${PYTHON_USEDEP}]
+ ' 3.10 3.11)
+"
+BDEPEND="
+ test? (
+ dev-python/portend[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ jaraco/context/__init__.py::jaraco.context.repo_context
+)
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "jaraco.context"
+ version = "${PV}"
+ description = "Context managers by jaraco"
+ EOF
+}
+
+python_install() {
+ distutils-r1_python_install
+ # rename to workaround a bug in pkg_resources
+ # https://bugs.gentoo.org/834522
+ mv "${D}$(python_get_sitedir)"/jaraco{_,.}context-${PV}.dist-info || die
+}