summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-collections
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-15 01:41:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-15 01:41:15 +0100
commite0fdb8199de0e7a9b7c72d7f38d2e3ddaecdacd0 (patch)
tree7a71d24a0bfba0874deeb5e8131d579dfb40e1d1 /dev-python/jaraco-collections
parent7cffc3e7845d1a3ae331145c5e1226e314badf4a (diff)
gentoo auto-resync : 15:07:2022 - 01:41:14
Diffstat (limited to 'dev-python/jaraco-collections')
-rw-r--r--dev-python/jaraco-collections/Manifest2
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-3.5.2.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/jaraco-collections/Manifest b/dev-python/jaraco-collections/Manifest
index 08743f55ff49..1b6f7e35d6d2 100644
--- a/dev-python/jaraco-collections/Manifest
+++ b/dev-python/jaraco-collections/Manifest
@@ -1,3 +1,5 @@
DIST jaraco.collections-3.5.1.tar.gz 15053 BLAKE2B afba813636464b6776f244eab31a0cd86418410f313e171cff1c8ac64e5d902f4a6c2f88d87c61d55292baa338aee45866d3a459c5b5b73fd4e751278b869316 SHA512 2918be537296ca81e5f78a3966a47451dc9dc2d233d997c3f01461c489b44051c497dab55496f85883ac1b91a28850a9d77ff154a3f5e074da1ed07f3259c246
+DIST jaraco.collections-3.5.2.tar.gz 16038 BLAKE2B 3f7f48f4c65e44aba621dd894a84711473ff42e37be8067e356cd6ca0f8740c667cb282bddad4315ddd7c8922c316c57b40984455f0af4bc8bbf4304a12a6779 SHA512 9567ee44fbc5010cc81ee24de792e53b5a225759b5f7d2e7dd932b0cae38e2035fddb5bd3dee5dc08fea9c61e2bf9087418cd192d81c72760f1e0d95a7b3788c
EBUILD jaraco-collections-3.5.1-r1.ebuild 830 BLAKE2B ed63ed5db17077393886ff83d189fd99293486799371ae4bb22a2f9c0b5697b4c8c1fb2ac3a3bf2137299f703492b268487712ef460ea3b3da1a069dbb8e54f2 SHA512 16e92d64d3b62c250fe557aaa3961026be6c8c19e72e372cb02fe7f542976a94a05d653ea5eef01d51dd15e4523388c5aee96c6de3f87da27671312dbe541529
+EBUILD jaraco-collections-3.5.2.ebuild 835 BLAKE2B 1e89ea527e5990cd4d6cad442afd8ba567a673f1bae7f2ea2f172030d51f2ffd05a2fc6e6357c90ea41261d1c891d142144a6d5dba11d065c015b5d2716d2c01 SHA512 7b2cd8eaeca4ad9c0a029d6ef55f1ebd512fb471095329da9e3d9b48ce57004ff563cd7a8c609193c4f1224564e4c143831a1e59f878aa063dadc48fdf2a0c3d
MISC metadata.xml 684 BLAKE2B 2da0cbb4ee979b83d045c4c402ff420db27d1a4176c7009bf56027b9b3a7df9395e67f881dce945849870955998e65dcd13c4e77926a8e2e7d1084b475a71ddc SHA512 30743b4d3616dc141a9ce814262304d21ac20475fa70414679dd5f028dcf83021c4cf9b39b3817957f5feb623076f94df1e7a951b0ab6cf57cf635b7eaf3ef8e
diff --git a/dev-python/jaraco-collections/jaraco-collections-3.5.2.ebuild b/dev-python/jaraco-collections/jaraco-collections-3.5.2.ebuild
new file mode 100644
index 000000000000..2d4ec2a0c605
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-3.5.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="https://github.com/jaraco/jaraco.collections"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ '>=dev-python/jaraco-packaging-3.2' \
+ '>=dev-python/rst-linker-1.9'
+distutils_enable_tests pytest