summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-collections
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-29 16:46:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-29 16:46:44 +0100
commitae838334efa4ecfd172331e8f5ae4eea8c5dd876 (patch)
tree4ca49a7102c3db20c7b54b7c9af988b0bc68e2ff /dev-python/jaraco-collections
parentd3fc35858ba4bc0c8038a8c536246b00fe648358 (diff)
gentoo auto-resync : 29:08:2022 - 16:46:43
Diffstat (limited to 'dev-python/jaraco-collections')
-rw-r--r--dev-python/jaraco-collections/Manifest2
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-3.5.2.ebuild15
2 files changed, 9 insertions, 8 deletions
diff --git a/dev-python/jaraco-collections/Manifest b/dev-python/jaraco-collections/Manifest
index 833229cc354a..89bfeef57381 100644
--- a/dev-python/jaraco-collections/Manifest
+++ b/dev-python/jaraco-collections/Manifest
@@ -1,3 +1,3 @@
DIST jaraco.collections-3.5.2.tar.gz 16038 BLAKE2B 3f7f48f4c65e44aba621dd894a84711473ff42e37be8067e356cd6ca0f8740c667cb282bddad4315ddd7c8922c316c57b40984455f0af4bc8bbf4304a12a6779 SHA512 9567ee44fbc5010cc81ee24de792e53b5a225759b5f7d2e7dd932b0cae38e2035fddb5bd3dee5dc08fea9c61e2bf9087418cd192d81c72760f1e0d95a7b3788c
-EBUILD jaraco-collections-3.5.2.ebuild 830 BLAKE2B ed63ed5db17077393886ff83d189fd99293486799371ae4bb22a2f9c0b5697b4c8c1fb2ac3a3bf2137299f703492b268487712ef460ea3b3da1a069dbb8e54f2 SHA512 16e92d64d3b62c250fe557aaa3961026be6c8c19e72e372cb02fe7f542976a94a05d653ea5eef01d51dd15e4523388c5aee96c6de3f87da27671312dbe541529
+EBUILD jaraco-collections-3.5.2.ebuild 761 BLAKE2B fbf8528d0c07553bd051c791058182bdbe868a241cc8bb3f406b4eddcb038b8a53c8915cedafc0f30e6ef70d6dfe80011a2da365997993773e081aac8cf00238 SHA512 9d10d3bbabf0ba24072f5dc371230d348232145f0be3899c11c9d899225b0faadbb865f953e2209975edae388e4a5c041454407a52693ff4fae43f12470bd4a8
MISC metadata.xml 684 BLAKE2B 2da0cbb4ee979b83d045c4c402ff420db27d1a4176c7009bf56027b9b3a7df9395e67f881dce945849870955998e65dcd13c4e77926a8e2e7d1084b475a71ddc SHA512 30743b4d3616dc141a9ce814262304d21ac20475fa70414679dd5f028dcf83021c4cf9b39b3817957f5feb623076f94df1e7a951b0ab6cf57cf635b7eaf3ef8e
diff --git a/dev-python/jaraco-collections/jaraco-collections-3.5.2.ebuild b/dev-python/jaraco-collections/jaraco-collections-3.5.2.ebuild
index 3962c5c51519..c05bf6e60547 100644
--- a/dev-python/jaraco-collections/jaraco-collections-3.5.2.ebuild
+++ b/dev-python/jaraco-collections/jaraco-collections-3.5.2.ebuild
@@ -5,13 +5,17 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
inherit distutils-r1
-MY_PN="${PN/-/.}"
+MY_P=${P/-/.}
DESCRIPTION="Models and classes to supplement the stdlib collections module"
-HOMEPAGE="https://github.com/jaraco/jaraco.collections"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.collections/
+ https://pypi.org/project/jaraco.collections/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
LICENSE="MIT"
SLOT="0"
@@ -25,7 +29,4 @@ BDEPEND="
>=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
"
-distutils_enable_sphinx docs \
- '>=dev-python/jaraco-packaging-3.2' \
- '>=dev-python/rst-linker-1.9'
distutils_enable_tests pytest