summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-collections
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/jaraco-collections
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/jaraco-collections')
-rw-r--r--dev-python/jaraco-collections/Manifest6
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-1.4.1.ebuild58
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-1.5.ebuild58
-rw-r--r--dev-python/jaraco-collections/metadata.xml18
4 files changed, 140 insertions, 0 deletions
diff --git a/dev-python/jaraco-collections/Manifest b/dev-python/jaraco-collections/Manifest
new file mode 100644
index 000000000000..c1855dfaf914
--- /dev/null
+++ b/dev-python/jaraco-collections/Manifest
@@ -0,0 +1,6 @@
+DIST jaraco.collections-1.4.1.tar.gz 10456 SHA256 43d0221be38fa0d8da339a149829800c8c3f843f379c09f3f8f1d99125110936 SHA512 1f9eca787efb427a73b5f03e144a2a95e5740580e21e9857a376d76dd35f39066c3a06056eaf78f72de2f97e4fc70805467fcc516f989ba4785e3f3d9354a538 WHIRLPOOL c37a851f1ab041554c1d9a54565e5671350bc750d31d1569a4415c5c215557739145b3a4992546d715a013695ef86cb788c47b4eb72940a29fdc17a9300399bb
+DIST jaraco.collections-1.5.tar.gz 10615 SHA256 7af6aedcf1601eca23d4411727caa201c0fdb80d2ec40f63d5f0942529f971d6 SHA512 7e2d3849d26422d687cfeb560f8096fb099a9c7b99b3061a06f9ad7037c3805b577754f62e5d5ead3f6f89bcd7dbf574df2844aa3c28928941ea2c99d50fc161 WHIRLPOOL 91a5c6c09d8b46231a409abea40e43a80a165a17e4f23be05d5341446630cf31d94880f37bbba0cd8c9cc1cb27fc6b698cd18d07e9342f1cec0fc2453ad88378
+EBUILD jaraco-collections-1.4.1.ebuild 1404 SHA256 bf0d82902c890bb0ca2313dee866fec7353ca81a6cf9eeb3b2c924bbc4c2502c SHA512 898ee4f6f72bbc91a723ddd3176a56b33b50f951d46eeb4cba8a82d750a5c647463ed95708266ebf02c29194fdb89c2b702ea2fcfa427d50952c96ccc1274669 WHIRLPOOL b23a420e0ae90299db341b1e37e7b51131d3093fa7d3a469f363b190a347c2148614ba902e4053d692183db808a410c8c631746ca76cf3332a204cd496041b4b
+EBUILD jaraco-collections-1.5.ebuild 1402 SHA256 8fc677e127b4dde79b77399c9b03811a6fb6b28c3c29f58a5b26c15fb47d5852 SHA512 a48e9c9a8918ce2734bf0d2ad37e9ef85353bb502a057e3f3ce63d97ef0e9871fd086c36219452788c9bbcb29e4e0c90aa4094c4cca11360bc645e81c7c30fdd WHIRLPOOL 7674b00caa927dd1e24b364f4da12d2842c052ed19aef8502e8856c5d89cce947a1adc640b829dad55785cfc7012915f4442ed0bca221dee5b963b3a121beed4
+MISC ChangeLog 2284 SHA256 67b5f76444b374fb0c0f70ad11bd6537a90b1910fd37d576dd290f2f3af3fa0a SHA512 371acdfba2c806cc58c76fcd356b5d7d37bf4e64963f5a09a1d05942bcb778a68a188e2b522c501b2c8c2dc835647b0173174d53ebd803e94131a4e2d54d5f90 WHIRLPOOL 0474be4670e6f4c87329294b78b208b34f307b4821e805eb3b4ca402264d12e02b09c804d72b0015a9c03a21df04f17d9e3e0fe234a250595ef6a93777cbea67
+MISC metadata.xml 682 SHA256 265fd252d28faba25541fafecfb6226027798ef8a80a9d7c3f3a976db5f3c0f7 SHA512 3b642f903fdc07a9ddba157b15b9cbcb3141f7a7b5bd74101b360a9052ca213a765c48266acbe296e8119900d311aaa4dd8d54f7b6f5e05ea2041145ce455c30 WHIRLPOOL 313316f15c376e8b789dc2295abaf7a02d8aafca770c14c5b68b08b4b8ce9869408cfe33f3cc1ab3a52329e8c9482ae1d9ef21bf91510b2ecab03834b77635cf
diff --git a/dev-python/jaraco-collections/jaraco-collections-1.4.1.ebuild b/dev-python/jaraco-collections/jaraco-collections-1.4.1.ebuild
new file mode 100644
index 000000000000..d4d9d45a02f9
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-1.4.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="https://github.com/jaraco/jaraco.collections"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+PDEPEND="dev-python/jaraco-text[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/rst-linker[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+ if use test && ! has_version "dev-python/jaraco-text"; then
+ die "Ensure dev-python/jaraco-text is installed or the" \
+ "test suite will fail"
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/jaraco-collections/jaraco-collections-1.5.ebuild b/dev-python/jaraco-collections/jaraco-collections-1.5.ebuild
new file mode 100644
index 000000000000..708280d2b630
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-1.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="https://github.com/jaraco/jaraco.collections"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+PDEPEND="dev-python/jaraco-text[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/rst-linker[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+ if use test && ! has_version "dev-python/jaraco-text"; then
+ die "Ensure dev-python/jaraco-text is installed or the" \
+ "test suite will fail"
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/jaraco-collections/metadata.xml b/dev-python/jaraco-collections/metadata.xml
new file mode 100644
index 000000000000..349dba02c653
--- /dev/null
+++ b/dev-python/jaraco-collections/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sautier.louis@gmail.com</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">jaraco.collections</remote-id>
+ <remote-id type="github">jaraco/jaraco.collections</remote-id>
+ <bugs-to>https://github.com/jaraco/jaraco.collections/issues</bugs-to>
+ <changelog>https://github.com/jaraco/jaraco.collections/blob/master/CHANGES.rst</changelog>
+ </upstream>
+</pkgmetadata>