summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-collections
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-23 18:45:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-23 18:45:51 +0000
commit3bd958e646e508a3e80f5fb28f44384eed671f5d (patch)
tree59c64eff7f35adeaabe15243171164094a9c23e1 /dev-python/jaraco-collections
parentc8c3804588db08dae281504dd79ef71741cd8dc3 (diff)
gentoo auto-resync : 23:03:2023 - 18:45:51
Diffstat (limited to 'dev-python/jaraco-collections')
-rw-r--r--dev-python/jaraco-collections/Manifest2
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-3.9.0.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/jaraco-collections/Manifest b/dev-python/jaraco-collections/Manifest
index 52067275414b..5c15de143222 100644
--- a/dev-python/jaraco-collections/Manifest
+++ b/dev-python/jaraco-collections/Manifest
@@ -1,3 +1,5 @@
DIST jaraco.collections-3.8.0.tar.gz 17021 BLAKE2B d1439d2ac8e1c62a87f85775d58a1ea30abfb9eeae2d04c00eaaca9452cd3d46c668841073ee41913a52afa519ecbbddba321ec06584c8cab29dd736f4337219 SHA512 3d20c07d616e82c8c2699f2a5e7a0c42e8a4e5314535d4521a2e3457db510cd24019b23128682ac60c34b47fc4b5232ba0fd2e463c199aef6f6eb6d6ee4347ac
+DIST jaraco.collections-3.9.0.tar.gz 17407 BLAKE2B d5d266675a7a6ab69c1ac23c911fee639d05ef25c0d5f942695b02f8f45b4e6399628e13743beb570f61b1b2e400e28a34080599125e4ab8c59fa9d9c81172f1 SHA512 cac756866dffee2a7b41d4cc3a957e56bd7353454c0a819e94d7b5102bde624a759e84e74eccd6df475b1753f8730f72ac4dd2fc464085a387c879a0e2ac1891
EBUILD jaraco-collections-3.8.0.ebuild 736 BLAKE2B fc2f1acd286b09c44671a22e9bc729fc60c7923dc1fcfd4c7da6a4d384bf09a1f2c2e7fe6d221ac81f069c10d1e17c4be3461dbaa3385cdbab1043d459265bf6 SHA512 2a48ae9a9a8141f88cdfcd7f0f7d1ad5f999c4a9476817cdbb4fb5e1a01f6bf5c3180b47246908937f42a3010ce342310678cc98403e61f787bf632198f2d9bc
+EBUILD jaraco-collections-3.9.0.ebuild 742 BLAKE2B 0461329753fd7531a0efaeca5507b45d5dbc27bca238ccb53160ae520cccba5ba7edc4988f067fd8cee9be7976dc97b1794dd896aa5f8ccbfe0e182d9778007c SHA512 7edd27fa21d330f695e24708587912286071c88f5e136656b291b323aa94377342cfae95e6ff214dd0644e47c3cbb0fa7946213eab7f81c0193f114b7d2c07b6
MISC metadata.xml 578 BLAKE2B c6ad7ecaee92099645bcbd75ed9eff9da2a83268e8a7f828b2dbaf5414228f26b40f09fa37fd156d128742b111cfcacb3e177970b217d4de890ca7262275b26f SHA512 b2602fb629500021bd8fad159ddfcdc76a11f15fe2a51d0d25d5d687ae09170f6cc8438c252e8cb2792ca43bec7be65e249a799582f17c882639e30a9222a0ec
diff --git a/dev-python/jaraco-collections/jaraco-collections-3.9.0.ebuild b/dev-python/jaraco-collections/jaraco-collections-3.9.0.ebuild
new file mode 100644
index 000000000000..9ece9dcf694e
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-3.9.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.collections/
+ https://pypi.org/project/jaraco.collections/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest