summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-classes/jaraco-classes-3.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-python/jaraco-classes/jaraco-classes-3.1.0.ebuild
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-python/jaraco-classes/jaraco-classes-3.1.0.ebuild')
-rw-r--r--dev-python/jaraco-classes/jaraco-classes-3.1.0.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/jaraco-classes/jaraco-classes-3.1.0.ebuild b/dev-python/jaraco-classes/jaraco-classes-3.1.0.ebuild
deleted file mode 100644
index 8b8c724c4ef1..000000000000
--- a/dev-python/jaraco-classes/jaraco-classes-3.1.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# Tests fail with pypy
-PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Classes used by other projects by developer jaraco"
-HOMEPAGE="https://github.com/jaraco/jaraco.classes"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86 ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/namespace-jaraco-2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-distutils_enable_sphinx docs \
- ">=dev-python/jaraco-packaging-3.2" \
- ">=dev-python/rst-linker-1.9"
-
-python_prepare_all() {
- # avoid a setuptools_scm dependency
- sed -i "s:use_scm_version=True:version='${PV}':" setup.py || die
- sed -r -i "s:setuptools_scm[[:space:]]*([><=]{1,2}[[:space:]]*[0-9.a-zA-Z]+)[[:space:]]*::" \
- setup.cfg || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # Avoid ImportMismatchError, override pytest options to skip flake8
- pytest -vv "${BUILD_DIR}"/lib --override-ini="addopts=--doctest-modules" \
- || die "tests failed with ${EPYTHON}"
-}
-
-# https://wiki.gentoo.org/wiki/Project:Python/Namespace_packages#File_collisions_between_pkgutil-style_packages
-python_install() {
- rm "${BUILD_DIR}"/lib/jaraco/__init__.py || die
- # note: eclass may default to --skip-build in the future
- distutils-r1_python_install --skip-build
-}