summaryrefslogtreecommitdiff
path: root/dev-python/itypes/itypes-1.2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/itypes/itypes-1.2.0-r1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/itypes/itypes-1.2.0-r1.ebuild')
-rw-r--r--dev-python/itypes/itypes-1.2.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/itypes/itypes-1.2.0-r1.ebuild b/dev-python/itypes/itypes-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..99a0098c43c9
--- /dev/null
+++ b/dev-python/itypes/itypes-1.2.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="basic immutable container types for python"
+HOMEPAGE="https://github.com/PavanTatikonda/itypes/"
+SRC_URI="
+ https://github.com/PavanTatikonda/itypes/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests.py
+}