summaryrefslogtreecommitdiff
path: root/dev-python/itsdangerous/itsdangerous-2.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-17 12:04:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-17 12:04:28 +0100
commit97bacba3ead078e5db8b87ab651a3ffa7d82f60f (patch)
treea769244c0cdbaa4ae87951809f61da3a3f9df7a4 /dev-python/itsdangerous/itsdangerous-2.2.0.ebuild
parentb92911550490e2da121ec4b02d3cf60a2d31a17d (diff)
gentoo auto-resync : 17:04:2024 - 12:04:27
Diffstat (limited to 'dev-python/itsdangerous/itsdangerous-2.2.0.ebuild')
-rw-r--r--dev-python/itsdangerous/itsdangerous-2.2.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/itsdangerous/itsdangerous-2.2.0.ebuild b/dev-python/itsdangerous/itsdangerous-2.2.0.ebuild
new file mode 100644
index 000000000000..69483573c260
--- /dev/null
+++ b/dev-python/itsdangerous/itsdangerous-2.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Various helpers to pass trusted data to untrusted environments and back"
+HOMEPAGE="
+ https://palletsprojects.com/p/itsdangerous/
+ https://github.com/pallets/itsdangerous/
+ https://pypi.org/project/itsdangerous/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest