summaryrefslogtreecommitdiff
path: root/dev-python/isort
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-python/isort
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-python/isort')
-rw-r--r--dev-python/isort/Manifest4
-rw-r--r--dev-python/isort/isort-5.10.0.ebuild59
-rw-r--r--dev-python/isort/isort-5.10.1.ebuild59
3 files changed, 122 insertions, 0 deletions
diff --git a/dev-python/isort/Manifest b/dev-python/isort/Manifest
index b0e230d98e69..09b806203565 100644
--- a/dev-python/isort/Manifest
+++ b/dev-python/isort/Manifest
@@ -1,3 +1,7 @@
+DIST isort-5.10.0.gh.tar.gz 728239 BLAKE2B 6a206cdd4ebceb29f8c76f1c08b3217da1d76b56bbfbf177175d08f502884ae1f0700dc1443c92c28d68d257cb6468e2210d35a2003680303aa2ae9eaefe3ce3 SHA512 e8de97d6714ad626974e601a676b35a324b306a9f6033fd5cdd4cf5a5caf29cbc3238dca8cbf38e749866776f01aa58026159f53a4181f6637daf93181726ad2
+DIST isort-5.10.1.gh.tar.gz 728462 BLAKE2B 5b892b9849293e8730e6d89592bace62009a8589d185b4d3a5bafded605ccd46fd0f2986fbad5cf1d72321d030e3193a111ab7e6114c6b4a7a67696f546b3a14 SHA512 545c1844bacc1d2d9e87e60b03b30a846ee1ebbfe2a229c3e018a2e1cc6e9a04a3691f1b2e7ec8575806f2341bc1af15eb64904b4eabd786d6b9b289cea5ce2a
DIST isort-5.9.3.gh.tar.gz 729342 BLAKE2B f40f046c5706ea4fd6daf7dc8eaccaca35e7de3e77bc17fa73681d12c42f7d2a3b19a909384e6b2e2486679a9f9895c2fa944faace4bbc3d0cfd0ec7aff85edd SHA512 96aa9c8bb58c95a41f562d3f0e1cf6e9c0c4158486bca24dfe2293fc86c7c6b74e3e6a84ed755d965b692b1f06d98cdc8ed69080775f8acd9186ac3ae6401570
+EBUILD isort-5.10.0.ebuild 1359 BLAKE2B 43e9e0b7d1a0b5d9161523b5ff9f2e4eb24c60aa3d55913990f2fc9056b6cefae8f18c4bbff452c0e15b50fe3a29f36809af17272a390b3c2843e2f2f00b5a68 SHA512 b1df42f6e5afc339760ba7fb0fe1ca166a0596af0185e14cb28e45009d13f2e49f8ff4bc210973c3919d8d74334e80b026d12350a4a7ee09225a9a4d3c30a4a1
+EBUILD isort-5.10.1.ebuild 1359 BLAKE2B 43e9e0b7d1a0b5d9161523b5ff9f2e4eb24c60aa3d55913990f2fc9056b6cefae8f18c4bbff452c0e15b50fe3a29f36809af17272a390b3c2843e2f2f00b5a68 SHA512 b1df42f6e5afc339760ba7fb0fe1ca166a0596af0185e14cb28e45009d13f2e49f8ff4bc210973c3919d8d74334e80b026d12350a4a7ee09225a9a4d3c30a4a1
EBUILD isort-5.9.3.ebuild 1352 BLAKE2B d3a6bc9feda66134ff8abdd5ff29a818a5994d03e5807f785d7c56a14ef6cd7f709e701196cdb96ff9a9d3824aba856a587912ca66a543524aed9eddf2e399c7 SHA512 ab5fe6b94bcb8bcf195989f817169a7f5eec23b15117caf05312f91f2fb1306d4355903ddb736eab40b869d9ff1a9156284c4c5be17ea3ad46f84370d550b491
MISC metadata.xml 574 BLAKE2B db8aac55351f15190d9b71508268f26b12a781b3b4f0f6836a30efc954b46b71da496129a9641655db483730435b44a5c5283132521dc3cc93279c57735a1ba4 SHA512 c8116bf66155ffeb7ac8d68822559e18252210dae604b4984aa5e6a3fb7161d785cbd235dc6f656513b5bab326f6e579489245bcef9d0a5dfadc34d7477758fb
diff --git a/dev-python/isort/isort-5.10.0.ebuild b/dev-python/isort/isort-5.10.0.ebuild
new file mode 100644
index 000000000000..b47f36b80ae6
--- /dev/null
+++ b/dev-python/isort/isort-5.10.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A python utility/library to sort imports"
+HOMEPAGE="https://pypi.org/project/isort/"
+SRC_URI="
+ https://github.com/PyCQA/isort/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/toml[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/natsort[${PYTHON_USEDEP}]
+ dev-python/pylama[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unbundle toml
+ sed -i -e 's:from ._vendored ::' isort/settings.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # Some tests run the "isort" command
+ distutils_install_for_testing
+ # Install necessary plugins
+ local p
+ for p in example*/; do
+ pushd "${p}" >/dev/null || die
+ distutils_install_for_testing
+ popd >/dev/null || die
+ done
+
+ local EPYTEST_IGNORE=(
+ # Excluded from upstream's test script
+ tests/unit/test_deprecated_finders.py
+ )
+ epytest tests/unit
+}
diff --git a/dev-python/isort/isort-5.10.1.ebuild b/dev-python/isort/isort-5.10.1.ebuild
new file mode 100644
index 000000000000..b47f36b80ae6
--- /dev/null
+++ b/dev-python/isort/isort-5.10.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A python utility/library to sort imports"
+HOMEPAGE="https://pypi.org/project/isort/"
+SRC_URI="
+ https://github.com/PyCQA/isort/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/toml[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/natsort[${PYTHON_USEDEP}]
+ dev-python/pylama[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unbundle toml
+ sed -i -e 's:from ._vendored ::' isort/settings.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # Some tests run the "isort" command
+ distutils_install_for_testing
+ # Install necessary plugins
+ local p
+ for p in example*/; do
+ pushd "${p}" >/dev/null || die
+ distutils_install_for_testing
+ popd >/dev/null || die
+ done
+
+ local EPYTEST_IGNORE=(
+ # Excluded from upstream's test script
+ tests/unit/test_deprecated_finders.py
+ )
+ epytest tests/unit
+}