summaryrefslogtreecommitdiff
path: root/dev-python/isort
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
commitb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (patch)
tree911928b566777494d08ebe2c16cb64f15af71901 /dev-python/isort
parent61f10f985e19dfe20a4d9552902625edd5b6eabb (diff)
gentoo resync : 24.06.2021
Diffstat (limited to 'dev-python/isort')
-rw-r--r--dev-python/isort/Manifest2
-rw-r--r--dev-python/isort/isort-5.9.1.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/isort/Manifest b/dev-python/isort/Manifest
index 167f9e1efbf1..3dec5952dbdb 100644
--- a/dev-python/isort/Manifest
+++ b/dev-python/isort/Manifest
@@ -1,3 +1,5 @@
DIST isort-5.8.0.tar.gz 167927 BLAKE2B 59b9ee4e63e231026e25833ef8bc4a782ad7b30622d1f6b61fe177fbf0f8663ca953f68cf168abb407d3cb90fe98e29540ec3a8933a5df2ca7ba3e938ba4282f SHA512 ffeee045b5328fa410673464b2ca22d9cd1ba8dd34eff9a430b93e9ce72033100e32e3373308438bcb82b8eb7deea1f2087091e111b1204e35791958ca6944c4
+DIST isort-5.9.1.gh.tar.gz 727733 BLAKE2B dc207ac24b586eb5c4c2bd546c0f2ab336c901563e3f2c92d917cf81bc94634c23a20dfe787e65c41fd3aec835d3fdc96721ed579c282b4cb0719afa7f50f9a3 SHA512 e48e08835a71271ab01e52e2c44ecef475aa270ab7242aff4f9ce82bcd5bc8354e2d8a717ccf995172102809198f6dfc9786d8c64e33afc9ae9a4e981ac51feb
EBUILD isort-5.8.0.ebuild 1609 BLAKE2B c248dd41fd9e90985afedf5ef572abfa0fa46775af0162881518aeb1f9b999334063aeab7f2364eabe10108169833e1037bb25e084c61006c3fb866f664d3d3e SHA512 3cce76276c44cf58ad9a6301618fe43f5765df0fb3961634841171ca09764fc4066a1462b2dd46dbab8d54f77ff43cbf893980755a43894ac149175c92e52a40
+EBUILD isort-5.9.1.ebuild 1326 BLAKE2B ab2ac289c96e4adac0fe28667a2126860fa3b70a73324ecfa81fe5b1cff3c2f03f3effacf0d243b3a9bd72d277ba9c4dc79fbe0630f41ed29b80264d54f1394b SHA512 3e6ef128dad16b901c002720b01906ce7a3b95607a609e089c9019b589999a781017ae6808cd78b51d16133046b404cda5c3614e9cc35cfa27370d69f3f505e0
MISC metadata.xml 573 BLAKE2B 2c70619aaf4f917f377e17b73d59656d6e0254bb0aa6c4a01159bd46b5e2e24e22b8ca04ab88ad71c9d4979ea3b484f5efec05e6ce3b40093e010108ef2a80d8 SHA512 4c06a138d3d06e1f9dbf570e6c59819de182d8453c46a5dbdabcfed424501aeba89fed659d19a6e329c33c0307790ef5c1b81d2ee5d7475c102c2bd689255259
diff --git a/dev-python/isort/isort-5.9.1.ebuild b/dev-python/isort/isort-5.9.1.ebuild
new file mode 100644
index 000000000000..a551d25dd85e
--- /dev/null
+++ b/dev-python/isort/isort-5.9.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python utility/library to sort imports"
+HOMEPAGE="https://pypi.org/project/isort/"
+SRC_URI="
+ https://github.com/PyCQA/isort/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~x86"
+
+RDEPEND="
+ dev-python/toml[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/natsort[${PYTHON_USEDEP}]
+ dev-python/pylama[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unbundle toml
+ sed -i -e 's:from ._vendored ::' isort/settings.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # Some tests run the "isort" command
+ distutils_install_for_testing
+ # Install necessary plugins
+ local p
+ for p in example*/; do
+ pushd "${p}" >/dev/null || die
+ distutils_install_for_testing
+ popd >/dev/null || die
+ done
+
+ local deselect=(
+ # Excluded from upstream's test script
+ tests/unit/test_deprecated_finders.py
+ )
+ epytest tests/unit ${deselect[@]/#/--deselect }
+}