summaryrefslogtreecommitdiff
path: root/dev-python/isort
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/isort
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/isort')
-rw-r--r--dev-python/isort/Manifest2
-rw-r--r--dev-python/isort/isort-5.10.1-r1.ebuild (renamed from dev-python/isort/isort-5.10.1.ebuild)16
2 files changed, 11 insertions, 7 deletions
diff --git a/dev-python/isort/Manifest b/dev-python/isort/Manifest
index bdf523f7a068..86e55e3e9ca1 100644
--- a/dev-python/isort/Manifest
+++ b/dev-python/isort/Manifest
@@ -1,3 +1,3 @@
DIST isort-5.10.1.gh.tar.gz 728462 BLAKE2B 5b892b9849293e8730e6d89592bace62009a8589d185b4d3a5bafded605ccd46fd0f2986fbad5cf1d72321d030e3193a111ab7e6114c6b4a7a67696f546b3a14 SHA512 545c1844bacc1d2d9e87e60b03b30a846ee1ebbfe2a229c3e018a2e1cc6e9a04a3691f1b2e7ec8575806f2341bc1af15eb64904b4eabd786d6b9b289cea5ce2a
-EBUILD isort-5.10.1.ebuild 1437 BLAKE2B 18eec2d5ebf8bb1f53c5351dbc9188ad558084465853b3994bf6604273f8eb65872c28fbe7e6a4abcc9d9074b41503bd4c8b641a80f4decf5ea2c8cdb2a5abc1 SHA512 14f2a1cbfc19bf242d2eb26dbdba919bc12417b7277c1fe8da748455a8bc628b345ab3595149d98f0ff3caddd3b7d6b419bee04a7d79f8be04d942616686bbe9
+EBUILD isort-5.10.1-r1.ebuild 1547 BLAKE2B 898481403efea0b54c6dab92d6a40d53f4bedccfe415672b37199925f31ec0484ab8c43eb1f07172ea26314429369de647c3f6ed892bf3e1e8e866f0e9ae58d1 SHA512 10007a4dd6ada0418de5bb830b3b90c5cc7316c342dee3b725a52e901ba3d1fc6a736abe1737c300933a136217633a98a38e6d96be761a52c85e6b9da626cc42
MISC metadata.xml 574 BLAKE2B db8aac55351f15190d9b71508268f26b12a781b3b4f0f6836a30efc954b46b71da496129a9641655db483730435b44a5c5283132521dc3cc93279c57735a1ba4 SHA512 c8116bf66155ffeb7ac8d68822559e18252210dae604b4984aa5e6a3fb7161d785cbd235dc6f656513b5bab326f6e579489245bcef9d0a5dfadc34d7477758fb
diff --git a/dev-python/isort/isort-5.10.1.ebuild b/dev-python/isort/isort-5.10.1-r1.ebuild
index 6ccbdc080667..3ce357892d29 100644
--- a/dev-python/isort/isort-5.10.1.ebuild
+++ b/dev-python/isort/isort-5.10.1-r1.ebuild
@@ -3,8 +3,9 @@
EAPI=8
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+DISTUTILS_USE_PEP517=poetry
PYTHON_COMPAT=( python3_{8..10} )
+
inherit distutils-r1
DESCRIPTION="A python utility/library to sort imports"
@@ -36,22 +37,25 @@ distutils_enable_tests pytest
src_prepare() {
# unbundle toml
sed -i -e 's:from ._vendored ::' isort/settings.py || die
+ rm -r isort/_vendored || die
+ # remove upper bounds from example plugin deps
+ # (already removed upstream)
+ sed -i -e 's:\^:>=:' example*/pyproject.toml || die
distutils-r1_src_prepare
}
python_test() {
- # Some tests run the "isort" command
- distutils_install_for_testing
+ cp -a "${BUILD_DIR}"/{install,test} || die
+ local -x PATH=${BUILD_DIR}/test/usr/bin:${PATH}
+
# Install necessary plugins
local p
for p in example*/; do
pushd "${p}" >/dev/null || die
- distutils_install_for_testing
+ distutils_pep517_install "${BUILD_DIR}"/test
popd >/dev/null || die
done
- # remove examples leaked into BUILD_DIR
- rm "${BUILD_DIR}"/lib/example* || die
local EPYTEST_IGNORE=(
# Excluded from upstream's test script