summaryrefslogtreecommitdiff
path: root/dev-python/isodate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/isodate
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/isodate')
-rw-r--r--dev-python/isodate/Manifest5
-rw-r--r--dev-python/isodate/isodate-0.5.4.ebuild23
-rw-r--r--dev-python/isodate/isodate-0.6.0.ebuild25
-rw-r--r--dev-python/isodate/metadata.xml24
4 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/isodate/Manifest b/dev-python/isodate/Manifest
new file mode 100644
index 000000000000..20b6c57adfc0
--- /dev/null
+++ b/dev-python/isodate/Manifest
@@ -0,0 +1,5 @@
+DIST isodate-0.5.4.tar.gz 27691 BLAKE2B 91c05cab9a9d7313a4a98bf6843c4a6baceae86e2f030c684d0b7046d6df9e446124fa7704fe2c4689f2ab10da6c3ae96922809742cb4efcfb04a50f48bfc610 SHA512 ef5fd27ffa61ad10abf499723c452fd8fd6c2f08a0d5aca6ead88857e5d159f50a3d01769b9fe0aed59a57b0f89a70b359135b0d7c5e6a75d023daa824e5d80a
+DIST isodate-0.6.0.tar.gz 28480 BLAKE2B a7499c736b67193ac73026df7a7c9d9bd5b743a5d556fe5e8ba0a62e8a5238d64afb88547a27e4bcbe706483e3e1e97eecd437e4e1c730c20652cff5926502fc SHA512 e977748e13ee2c94ab47bfc47113d152280e9acff6f70e773de73717392148dd2c111a7db2d9fa3679d37936c6ed9a23dc526cb00bd601df45459b6a244f9f7d
+EBUILD isodate-0.5.4.ebuild 630 BLAKE2B 5f12ca373da3e06151745d616e2f9d589a2ecdb11839b57c1e077eb529d500be49f449c7f76ac302d464a14448bbd7b8905f5d05d32af240fac7ad70bced044a SHA512 0b1daddb8937b7ab8184b9fd806e9ed1eaf30275c7ed4526247c74f89df6a92c180b26d92c5ac15902d0b11ea276682dbe28d0f589d37e1bb77ac17dc373ff54
+EBUILD isodate-0.6.0.ebuild 712 BLAKE2B fc0b6f218182bf18144ae37680ba21aa3c36d004651e2bc7acb542724f817df1d6823056fb0762ab59bb706f1e9320c4d9a1ef0c5d61a1189e3b74b3b4fc84ad SHA512 e6dfcbad31eccb258de5d0e6f5de9dce1abe51593d57ed58360f309b22c9c697f7e301c8ff0d1967369a703721103c301d4d6ad0e309b762a836bfc8e8ac569f
+MISC metadata.xml 1120 BLAKE2B 9889dda56ccb8afebcf88184839aef3527090675f9a51444185c2d22f2eb89eae009b3138edb3a03c3d024b7a6d0ec586bad08480f869a030303a736c3a00dab SHA512 c9213c9a90a27f29d51584edc4537055a82962f9153cbd68fcf8868409be2af625f754c1b8c9e1f5d00ddf6696809a118fa33a742f5e241ba6a4141937f60dce
diff --git a/dev-python/isodate/isodate-0.5.4.ebuild b/dev-python/isodate/isodate-0.5.4.ebuild
new file mode 100644
index 000000000000..882a6521c5bb
--- /dev/null
+++ b/dev-python/isodate/isodate-0.5.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="ISO 8601 date/time/duration parser and formatter"
+HOMEPAGE="https://pypi.org/project/isodate/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} -m unittest discover -v -s "${BUILD_DIR}/lib" || die "Testing failed with ${EPYTHON}"
+}
diff --git a/dev-python/isodate/isodate-0.6.0.ebuild b/dev-python/isodate/isodate-0.6.0.ebuild
new file mode 100644
index 000000000000..a098d7cb995c
--- /dev/null
+++ b/dev-python/isodate/isodate-0.6.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="ISO 8601 date/time/duration parser and formatter"
+HOMEPAGE="https://pypi.org/project/isodate/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_test() {
+ ${EPYTHON} -m unittest discover -v -s "${BUILD_DIR}/lib" || die "Testing failed with ${EPYTHON}"
+}
diff --git a/dev-python/isodate/metadata.xml b/dev-python/isodate/metadata.xml
new file mode 100644
index 000000000000..40a9ac204fa7
--- /dev/null
+++ b/dev-python/isodate/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ This module implements ISO 8601 date, time and duration
+ parsing. The implementation follows ISO8601:2004 standard, and
+ implements only date/time representations mentioned in the standard. If
+ something is not mentioned there, then it is treated as non existent,
+ and not as an allowed option.
+ As this module maps ISO 8601 dates/times to standard Python data types,
+ like date, time, datetime and timedelta, it is not possible to convert
+ all possible ISO 8601 dates/times. For instance, dates before 0001-01-01
+ are not allowed by the Python date and datetime classes. Additionally
+ fractional seconds are limited to microseconds. That means if the parser
+ finds for instance nanoseconds it will round it to microseconds.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">isodate</remote-id>
+ </upstream>
+</pkgmetadata>