summaryrefslogtreecommitdiff
path: root/dev-python/isodate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/isodate
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/isodate')
-rw-r--r--dev-python/isodate/Manifest5
-rw-r--r--dev-python/isodate/isodate-0.5.4.ebuild23
-rw-r--r--dev-python/isodate/metadata.xml24
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/isodate/Manifest b/dev-python/isodate/Manifest
new file mode 100644
index 000000000000..b89034d51a30
--- /dev/null
+++ b/dev-python/isodate/Manifest
@@ -0,0 +1,5 @@
+DIST isodate-0.5.4.tar.gz 27691 SHA256 42105c41d037246dc1987e36d96f3752ffd5c0c24834dd12e4fdbe1e79544e31 SHA512 ef5fd27ffa61ad10abf499723c452fd8fd6c2f08a0d5aca6ead88857e5d159f50a3d01769b9fe0aed59a57b0f89a70b359135b0d7c5e6a75d023daa824e5d80a WHIRLPOOL 3f26621513740bb6c4bd42a97d6cb56d631ce8f48f056d679edc1e1c0b57b1349a69aecd79704efe2d7f9195d54ec704e1f96b3da90dea52704999893fe2e3d3
+EBUILD isodate-0.5.4.ebuild 633 SHA256 b53d1df1c109a7187b4c727399e61a40b52398e857ac07e00c2e0fc22611bfff SHA512 314d9415b495594e6070ce9622b814f53daff4a726ad5d98c2ebfdf09610dc22e96b362f252889ebf4d4defcb55993d7d38b3667ffe36fc6d33282eb6288d7c3 WHIRLPOOL 59858fd98951c66703177176ab7942387878e84b409adb0494eaedf2d7b93e707790a2eaab216367ae8966a6467d56e879ad54540640fa008f2dee2b79f91c71
+MISC ChangeLog 3143 SHA256 466fbae75723d72508fad881535759788cc973c6c86741c73d7f517ff55e2aa6 SHA512 ddd1c32eedc490f22a29b24f0c4984ffb38c70417ff5b4d5132651560f9c2109fee1d4fb826ed945df309d1551a4affd5e2492b330518bfe738f38a9869ecab5 WHIRLPOOL 4fd4071c1fefcd967b18daff5c3301bb0cc9e750b8156a77aafe12282b85b61cd0689ea0b735dcf3ee63921d162b7705bf5e32408ec8a4f9dc73784b37829077
+MISC ChangeLog-2015 4703 SHA256 d9ae3ec92f64891194f0618835b00ebe0bc49c00de6171eeef5ee9c6a32a90dc SHA512 6e6a872028a6d94a0f6a68e99e2949c64f8d7c4d1299f45cd96ad6de4f48789731d8f29b1c127f589fbb3663aa44de87b50f1086e0b280446c7549ca9602068d WHIRLPOOL a3a2f475e65a8eb08d89d45c2cf4bc17355da0cc77519918f4710c5e653c1d96b6d78dbaa077e78b6eab7bc6ceab42c7478e5708a9fb7e3ab2274cdf45d6bfbb
+MISC metadata.xml 1120 SHA256 3faf13ce75c2382a10896e3059db6ba0d31ec867cd71c06ed889e93fa5db9b9f SHA512 c9213c9a90a27f29d51584edc4537055a82962f9153cbd68fcf8868409be2af625f754c1b8c9e1f5d00ddf6696809a118fa33a742f5e241ba6a4141937f60dce WHIRLPOOL fc633d1e0f7046485fb619a54377dc77e90225d9380fc4abc32f8a5bf1901acaa511d392cd57a2d9bd2bef2792c31ce8c506d8e11e7c51ebceca772e7e6d6c61
diff --git a/dev-python/isodate/isodate-0.5.4.ebuild b/dev-python/isodate/isodate-0.5.4.ebuild
new file mode 100644
index 000000000000..333e8597362a
--- /dev/null
+++ b/dev-python/isodate/isodate-0.5.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="ISO 8601 date/time/duration parser and formatter"
+HOMEPAGE="https://pypi.python.org/pypi/isodate"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} -m unittest discover -v -s "${BUILD_DIR}/lib" || die "Testing failed with ${EPYTHON}"
+}
diff --git a/dev-python/isodate/metadata.xml b/dev-python/isodate/metadata.xml
new file mode 100644
index 000000000000..40a9ac204fa7
--- /dev/null
+++ b/dev-python/isodate/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ This module implements ISO 8601 date, time and duration
+ parsing. The implementation follows ISO8601:2004 standard, and
+ implements only date/time representations mentioned in the standard. If
+ something is not mentioned there, then it is treated as non existent,
+ and not as an allowed option.
+ As this module maps ISO 8601 dates/times to standard Python data types,
+ like date, time, datetime and timedelta, it is not possible to convert
+ all possible ISO 8601 dates/times. For instance, dates before 0001-01-01
+ are not allowed by the Python date and datetime classes. Additionally
+ fractional seconds are limited to microseconds. That means if the parser
+ finds for instance nanoseconds it will round it to microseconds.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">isodate</remote-id>
+ </upstream>
+</pkgmetadata>