summaryrefslogtreecommitdiff
path: root/dev-python/irc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/irc
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/irc')
-rw-r--r--dev-python/irc/Manifest5
-rw-r--r--dev-python/irc/irc-15.0.6.ebuild63
-rw-r--r--dev-python/irc/irc-16.3.ebuild64
-rw-r--r--dev-python/irc/metadata.xml18
4 files changed, 0 insertions, 150 deletions
diff --git a/dev-python/irc/Manifest b/dev-python/irc/Manifest
deleted file mode 100644
index c5bb9b9a1d50..000000000000
--- a/dev-python/irc/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-DIST irc-15.0.6.tar.gz 81996 BLAKE2B b5d329b70404a92d4f69cc3fef2be374b0a1e98e04588b7f2f7f7c241dc3d72122f813b67e48522b7779dfdf90478db6ff10cda3c66b621f7c4a099142d533f0 SHA512 48240eb496a3c88310f02cf092b8e19e4aa8d8dc165a9a8a39c313490a69ecc29ac67db297436df5e86e7253e2481bd19bc0429ea9cc359089a5cd6179125c0f
-DIST irc-16.3.tar.gz 87067 BLAKE2B 61d8b9cc20390a3eb918e5593a167b28f37154ee05cb4d7a72f8901509d3345e8d6bee9c17b66aa6c71fad4608a9f98eb3848190f82eac7db6f2013227979c25 SHA512 84b5a56a441cdf22396c10b81c115cb2e297ac082785e9baf0bc73d655034be1ff3f553d44412f066ab4b74530faddb66a9cc2f511a332e87fe49af0b6e68e5b
-EBUILD irc-15.0.6.ebuild 1597 BLAKE2B 67909f9c9f586c6ed63850ceb6df56aeae9404ab65ad5702a561667c6e624c5157ee46a90a8975e27ef28bdf39ce24f78d8e15d96fb0cb3d2dd13626ea0a5a7b SHA512 df65de77ef9fdb42bfd560212e5c9e86fb1d6febb58e4691a1a8ac3392b424709e81614b22c301f775b40e7682cb938012f4d98298ffad6e1dd62c1600af9ecb
-EBUILD irc-16.3.ebuild 1673 BLAKE2B 0014550f5a8b72e1cf7782fe6b70b2e4db0af21088d58c92ce19543f1ee794f6bd9f70f9232fa52e63c38cdbfa8fb57615dc79d60b0d4d4dd8dacf3e47347da4 SHA512 7ee09f6a0300504c0c074180465101eeca8902281e23a59168062ba2b8debe85f7ff717b9458d60c532cceee4c41d05e3a0e1f2be5adf9ea38a6eff3d87a692c
-MISC metadata.xml 690 BLAKE2B 5bee1fd162cf7a46ee59a40c945991887fe187d09b647907a2e05b80dbd9327d039d40986b5b5549e27f8729153880a234ea50c9601e171b5cfa13de295d6ba8 SHA512 1aadd270ebeedd1ffaea3f62bb804e48f94f822ac6f4d8502753259c098c7b18a5a94d0643f35eab2df47ef3537d513e37bbb9d04b619cf88580a4d5a463095d
diff --git a/dev-python/irc/irc-15.0.6.ebuild b/dev-python/irc/irc-15.0.6.ebuild
deleted file mode 100644
index b84a0821d677..000000000000
--- a/dev-python/irc/irc-15.0.6.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit distutils-r1
-
-DESCRIPTION="IRC client framework written in Python"
-HOMEPAGE="https://github.com/jaraco/irc"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc examples test"
-
-RDEPEND="
- dev-python/jaraco-collections[${PYTHON_USEDEP}]
- >=dev-python/jaraco-functools-1.5[${PYTHON_USEDEP}]
- >=dev-python/jaraco-itertools-1.8[${PYTHON_USEDEP}]
- dev-python/jaraco-logging[${PYTHON_USEDEP}]
- dev-python/jaraco-stream[${PYTHON_USEDEP}]
- dev-python/jaraco-text[${PYTHON_USEDEP}]
- dev-python/more-itertools[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/tempora-1.6[${PYTHON_USEDEP}]
-"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- )
- doc? (
- dev-python/rst-linker[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
-"
-
-python_compile_all() {
- if use doc; then
- cd docs || die
- sphinx-build . _build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- py.test || die "Tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- if use examples; then
- insinto "/usr/share/doc/${PF}"
- docompress -x "/usr/share/doc/${PF}/scripts"
- doins -r scripts
- fi
- distutils-r1_python_install_all
-}
diff --git a/dev-python/irc/irc-16.3.ebuild b/dev-python/irc/irc-16.3.ebuild
deleted file mode 100644
index 98fedd35523f..000000000000
--- a/dev-python/irc/irc-16.3.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
-
-inherit distutils-r1
-
-DESCRIPTION="IRC client framework written in Python"
-HOMEPAGE="https://github.com/jaraco/irc"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc examples test"
-
-RDEPEND="
- >=dev-python/jaraco-functools-1.5[${PYTHON_USEDEP}]
- >=dev-python/jaraco-itertools-1.8[${PYTHON_USEDEP}]
- >=dev-python/tempora-1.6[${PYTHON_USEDEP}]
- dev-python/jaraco-collections[${PYTHON_USEDEP}]
- dev-python/jaraco-logging[${PYTHON_USEDEP}]
- dev-python/jaraco-stream[${PYTHON_USEDEP}]
- dev-python/jaraco-text[${PYTHON_USEDEP}]
- dev-python/more-itertools[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
- )
- doc? (
- >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
- >=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
-"
-
-python_compile_all() {
- if use doc; then
- cd docs || die
- sphinx-build . _build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- # Override pytest options to skip flake8
- py.test --override-ini="addopts=--doctest-modules" \
- || die "Tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/scripts"
- dodoc -r scripts
- fi
- distutils-r1_python_install_all
-}
diff --git a/dev-python/irc/metadata.xml b/dev-python/irc/metadata.xml
deleted file mode 100644
index ed4ab5f0cd27..000000000000
--- a/dev-python/irc/metadata.xml
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>sbraz@gentoo.org</email>
- <name>Louis Sautier</name>
- </maintainer>
- <longdescription>
- This project includes an event-driven IRC client framework written in Python,
- as well as an object-oriented wrapper class and some example programs.
- </longdescription>
- <upstream>
- <remote-id type="pypi">irc</remote-id>
- <remote-id type="github">jaraco/irc</remote-id>
- <bugs-to>https://github.com/jaraco/irc/issues</bugs-to>
- <changelog>https://github.com/jaraco/irc/blob/master/CHANGES.rst</changelog>
- </upstream>
-</pkgmetadata>