summaryrefslogtreecommitdiff
path: root/dev-python/ipywidgets
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-05-06 12:56:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-05-06 12:56:33 +0100
commit2b9bf8ddf02fa6c068d582794340e48fad5e55be (patch)
tree94e5e799096d433aec23d95d7f639067bbf741cc /dev-python/ipywidgets
parent9a0e466823bee57eb01cc2c6cd2f3d89d8849c55 (diff)
gentoo auto-resync : 06:05:2025 - 12:56:33HEADmaster
Diffstat (limited to 'dev-python/ipywidgets')
-rw-r--r--dev-python/ipywidgets/Manifest2
-rw-r--r--dev-python/ipywidgets/ipywidgets-8.1.7.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/ipywidgets/Manifest b/dev-python/ipywidgets/Manifest
index 1cce24f7edf5..802c515f83d1 100644
--- a/dev-python/ipywidgets/Manifest
+++ b/dev-python/ipywidgets/Manifest
@@ -1,3 +1,5 @@
DIST ipywidgets-8.1.6.tar.gz 116764 BLAKE2B 74e3b82cfdbeec3da00acf1fc55f4351975f431e7b62fabaa9871d9240880aec77c28e67d79cc17ca01e3f979ee6a7a4be1f1fe22be4a5d72c8d118af8e43ce5 SHA512 4997cf17a99dad022e3f625a1392db3f6edd82e829c0aa6eeb140a8554f8ba5e53a6ba745d70a117ab25577a085d3fe103b4cec022a24618b862b89e508ebe71
+DIST ipywidgets-8.1.7.tar.gz 116721 BLAKE2B 425557d840d4ddb904d22b0680a7e4ad6156adc3e129f0a95b0e8d2c55de0055b53bba213e40452af11da061d51878c03257fe38adaa3e6f7d102bbbe14033e0 SHA512 8085be87f0c2f2c334e9965d21e16c71009b260216e84ff1e5faaa81a5b9f0709a28150a8eac52bed7aeed4a3dc87b0d0632ae4ff62b15512be521b2e5be22aa
EBUILD ipywidgets-8.1.6.ebuild 1306 BLAKE2B 85d572b8af5476c121c47cc108c86b8b0eca8413236c3325a7f4a3b9e224d042cf4e022b9192fc9f9ed454f8b5423db279794d147ac0157a05d1001e7f54ae25 SHA512 7e8ccb7491fd53b1ded786720d3f7b7219778e37886dd1c87c61b71c45a8e628b8d980f3fb1b28be70a13b19b636823d0226f32b7ba96225516765c7e3677c9e
+EBUILD ipywidgets-8.1.7.ebuild 1305 BLAKE2B b81ed2c6eba4873324886490c533fb942ddeec69b0aff0713de48e08bc5a43717fe0fb997589b5308783536ca107e185293a170330ab75c73ae75afb9279015a SHA512 515bc949b3084de6104641fbd5481aa3070fd6fad239fea9cff11522a6464175b0f3e4e552c3d5bc2af5f351b1aaf91bdba33617e34b859af40b0838f3efffda
MISC metadata.xml 537 BLAKE2B 1f3b91be328b958870a72b5ce438c3e5bf67efd072b59dcb5ae77a9b89334e726af4fe8771221a7b728905cef4175cf7e0a49b11c651a7c0520b5cb032085985 SHA512 cb8092ea7a06e309a26abb78f5ddfd4a91f416e15374d2b59fb5086a64cc13f3dd408e18caa6719d12b1f18f762469a72a1027b2a047db626c51d22a5f304e54
diff --git a/dev-python/ipywidgets/ipywidgets-8.1.7.ebuild b/dev-python/ipywidgets/ipywidgets-8.1.7.ebuild
new file mode 100644
index 000000000000..12a521d819fe
--- /dev/null
+++ b/dev-python/ipywidgets/ipywidgets-8.1.7.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3_11 python3_{11..13} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="
+ https://ipywidgets.readthedocs.io/
+ https://github.com/jupyter-widgets/ipywidgets/
+ https://pypi.org/project/ipywidgets/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/comm-0.1.3[${PYTHON_USEDEP}]
+ >=dev-python/ipython-genutils-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/widgetsnbextension-4.0.14[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab-widgets-3.0.15[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/ipython-6.1.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ case ${EPYTHON} in
+ pypy3*)
+ EPYTEST_DESELECT+=(
+ # https://github.com/pypy/pypy/issues/4892
+ ipywidgets/widgets/tests/test_interaction.py::test_interact_noinspect
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}