summaryrefslogtreecommitdiff
path: root/dev-python/ipywidgets/ipywidgets-7.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/ipywidgets/ipywidgets-7.0.0.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/ipywidgets/ipywidgets-7.0.0.ebuild')
-rw-r--r--dev-python/ipywidgets/ipywidgets-7.0.0.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/ipywidgets/ipywidgets-7.0.0.ebuild b/dev-python/ipywidgets/ipywidgets-7.0.0.ebuild
deleted file mode 100644
index 108a75b21277..000000000000
--- a/dev-python/ipywidgets/ipywidgets-7.0.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="IPython HTML widgets for Jupyter"
-HOMEPAGE="https://ipywidgets.readthedocs.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- >=dev-python/ipykernel-4.5.1[${PYTHON_USEDEP}]
- >=dev-python/nbformat-4.2.0[${PYTHON_USEDEP}]
- >=dev-python/traitlets-4.3.1[${PYTHON_USEDEP}]
- >=dev-python/widgetsnbextension-3.0.0[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? (
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2*')
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- nosetests --with-coverage --cover-package=ipywidgets ipywidgets || die
-}