summaryrefslogtreecommitdiff
path: root/dev-python/ipywidgets
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-22 00:06:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-22 00:06:25 +0100
commit236e75597883501f8700d9ba1a5c8276f578a17f (patch)
tree6b441a1dfa3a82840e3aa74678cc90c5294a4bca /dev-python/ipywidgets
parentbfd63d5b0e96ad32e0d0a8fe15512b6a9ac6fc9e (diff)
gentoo auto-resync : 22:05:2024 - 00:06:25HEADmaster
Diffstat (limited to 'dev-python/ipywidgets')
-rw-r--r--dev-python/ipywidgets/Manifest1
-rw-r--r--dev-python/ipywidgets/ipywidgets-8.1.2-r1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/ipywidgets/Manifest b/dev-python/ipywidgets/Manifest
index 743c3d3c0b53..6c5db45fcba8 100644
--- a/dev-python/ipywidgets/Manifest
+++ b/dev-python/ipywidgets/Manifest
@@ -1,3 +1,4 @@
DIST ipywidgets-8.1.2.tar.gz 116492 BLAKE2B 0fc8283b332447cd3659d39d4564e2e794678169c7bc156660f3478251c4df23de1719e4fcf9651b9766506edf359bdfc803b1450520a3cbce290b39bd95bd3c SHA512 59ddc92bb9b18b6cd36b1499465e700ce9b11010e2d51cdf0a820b36efecbea1facab42ced2f61de312319f4fd4e672bb27b248d40ee0088f3b58acfd102ab61
+EBUILD ipywidgets-8.1.2-r1.ebuild 1186 BLAKE2B 9095730ef6a0363147fe93d5d37098e2cf729ed104be509162a39cdf8e428ab1247161d57cc54d53b6508dc19dcec4daf3ad414ee8ea16b888e1544123df1602 SHA512 78e9da4a08d3c57b884d3d54cef7738e4725d47e1592fa754032499c9a51c7c1c47a44f088083dcadf2983531300cd6c9e39a11b6db8d2c9aa2ba3f266a22be4
EBUILD ipywidgets-8.1.2.ebuild 1383 BLAKE2B 5dbb579631c4b7fada8a97ac0e333e30b9e255374be0615064dd74153cca62f1265c430c091511aba937fdf28754781838230e4b52dd638176ff878d318f9a48 SHA512 bc55d8828f27bac1e13f5c5c6c564fcbea801d6226ba0c0fad6a3ede88462c433e4c20bb162845623c467f177065b303a3dc537e8c7183b2fe29078b8904dba1
MISC metadata.xml 537 BLAKE2B 1f3b91be328b958870a72b5ce438c3e5bf67efd072b59dcb5ae77a9b89334e726af4fe8771221a7b728905cef4175cf7e0a49b11c651a7c0520b5cb032085985 SHA512 cb8092ea7a06e309a26abb78f5ddfd4a91f416e15374d2b59fb5086a64cc13f3dd408e18caa6719d12b1f18f762469a72a1027b2a047db626c51d22a5f304e54
diff --git a/dev-python/ipywidgets/ipywidgets-8.1.2-r1.ebuild b/dev-python/ipywidgets/ipywidgets-8.1.2-r1.ebuild
new file mode 100644
index 000000000000..9ffe275d3894
--- /dev/null
+++ b/dev-python/ipywidgets/ipywidgets-8.1.2-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="
+ https://ipywidgets.readthedocs.io/
+ https://github.com/jupyter-widgets/ipywidgets/
+ https://pypi.org/project/ipywidgets/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/comm-0.1.3[${PYTHON_USEDEP}]
+ >=dev-python/ipython_genutils-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/widgetsnbextension-4.0.10[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab_widgets-3.0.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/ipython-6.1.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # https://github.com/pypy/pypy/issues/4892
+ ipywidgets/widgets/tests/test_interaction.py::test_interact_noinspect
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}