summaryrefslogtreecommitdiff
path: root/dev-python/ipython_genutils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/ipython_genutils
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/ipython_genutils')
-rw-r--r--dev-python/ipython_genutils/Manifest3
-rw-r--r--dev-python/ipython_genutils/ipython_genutils-0.2.0.ebuild28
-rw-r--r--dev-python/ipython_genutils/metadata.xml18
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/ipython_genutils/Manifest b/dev-python/ipython_genutils/Manifest
new file mode 100644
index 000000000000..453afe6107ca
--- /dev/null
+++ b/dev-python/ipython_genutils/Manifest
@@ -0,0 +1,3 @@
+DIST ipython_genutils-0.2.0.tar.gz 22208 BLAKE2B 1a898e11cec26787f530f72e2d2a79e7834664e0f6be6a27ddd426bc2d0b3f39ee46e9ea10ad03e01a08054873c9752007038e863d7dd9e501613a68e40e1635 SHA512 0e5a9f8be17d98dfb74ec77d1360ee79276a13fe1914e6d31e8740f06375ed1671c49356a77f118495f50823b8384c1e2c5b6fae73965e3d4249c831b9a2b095
+EBUILD ipython_genutils-0.2.0.ebuild 621 BLAKE2B 2c53473c21f32df1c6f8d7ceed91886b0aa4f4ccb7b317946aabe9f085bbda309954754e2d959933f178c72288524f8fc86468c7202498bbf164509799aa49e8 SHA512 d192e908205f10020e35d91bf5baab7e7d0214aa6f5457051970956ade0f36e881343efd2d05ef0d6422fe4f3114014aac306a93271762fce47f9db4606057c3
+MISC metadata.xml 729 BLAKE2B 91bb45e44e2ccd4686308049920a2a9bc9a0334af7b2cec5365c35d3462782c9f1c95b5496d364ac1b92bf1514102b4e5d6755ff8beabdf5887f0262cdbca889 SHA512 13724fe12d5a5053947c38bec58984747985fee21954ff33072c954bf6e9bb53c4b9d23dad194c4cc6b1151ae83d1f8f53c9f91368a370aa51f84c7ced0178fe
diff --git a/dev-python/ipython_genutils/ipython_genutils-0.2.0.ebuild b/dev-python/ipython_genutils/ipython_genutils-0.2.0.ebuild
new file mode 100644
index 000000000000..b1cc5f7d33ae
--- /dev/null
+++ b/dev-python/ipython_genutils/ipython_genutils-0.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Vestigial utilities from IPython"
+HOMEPAGE="https://github.com/ipython/ipython_genutils"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc ppc64 x86"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ nosetests --with-coverage --cover-package=ipython_genutils ipython_genutils || die
+}
diff --git a/dev-python/ipython_genutils/metadata.xml b/dev-python/ipython_genutils/metadata.xml
new file mode 100644
index 000000000000..c9deb0b0985a
--- /dev/null
+++ b/dev-python/ipython_genutils/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>
+ This package contains some common utilities shared by Jupyter and
+ IPython projects during The Big Split. As soon as possible, those
+ packages will remove their dependency on this, and this repo will
+ go away. No packages outside IPython/Jupyter should depend on it.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">ipython_genutils</remote-id>
+ <remote-id type="github">ipython/ipython_genutils</remote-id>
+ </upstream>
+</pkgmetadata>