summaryrefslogtreecommitdiff
path: root/dev-python/ipython_genutils/ipython_genutils-0.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/ipython_genutils/ipython_genutils-0.2.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/ipython_genutils/ipython_genutils-0.2.0.ebuild')
-rw-r--r--dev-python/ipython_genutils/ipython_genutils-0.2.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/ipython_genutils/ipython_genutils-0.2.0.ebuild b/dev-python/ipython_genutils/ipython_genutils-0.2.0.ebuild
new file mode 100644
index 000000000000..b8767f4bff24
--- /dev/null
+++ b/dev-python/ipython_genutils/ipython_genutils-0.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Vestigial utilities from IPython"
+HOMEPAGE="https://github.com/ipython/ipython_genutils"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ nosetests --with-coverage --cover-package=ipython_genutils ipython_genutils || die
+}