summaryrefslogtreecommitdiff
path: root/dev-python/ipython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-16 22:53:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-16 22:53:04 +0000
commitb7a94956953b9eb949dbf7a2b05fff47558c99a8 (patch)
tree8be377afc87efdc085be771666f6cfe8d359ac09 /dev-python/ipython
parentaa594b97fdb2ee6d9a745eea19c9fdf7d9d07700 (diff)
gentoo auto-resync : 16:11:2023 - 22:53:04
Diffstat (limited to 'dev-python/ipython')
-rw-r--r--dev-python/ipython/Manifest2
-rw-r--r--dev-python/ipython/ipython-8.17.2.ebuild67
2 files changed, 45 insertions, 24 deletions
diff --git a/dev-python/ipython/Manifest b/dev-python/ipython/Manifest
index fcdc8d39b685..584acfc85ff7 100644
--- a/dev-python/ipython/Manifest
+++ b/dev-python/ipython/Manifest
@@ -2,5 +2,5 @@ AUX 2.1.0-substitute-files.patch 1017 BLAKE2B 70577eb950a18345804a2a4b750bd233dc
DIST ipython-8.16.1.tar.gz 5485037 BLAKE2B c5429b1df9906681f9792d7bc3005a3a41f7d89f7d6c104f9826902134179f7149de0747a50f31c53d277a135d0fedd0952aa23fce3650f026ac3c1733287ecb SHA512 0feb4c14e8e7f34829cd8b6c43c91c9bb5b6c85ae60173951db4354296474945268fb8d3caedcfae8457783e6d27a6dc33b6291bf2d9a691526fc44199724887
DIST ipython-8.17.2.tar.gz 5486488 BLAKE2B 7af4b4964527de8e74247ce05e9b1c8ab9a16e8784e0e07129859d01ffef0a976c8de7661821b131c125a8d1c2ac29d09d8e81a741f7180219a0c429530391cd SHA512 87039da43cb942c78238c4c69a2e2e7d6d1757a9ce8aac5f1bcd30a112a38f1b4f51672749ed469945844070eec661c6bb2f137405336f71d6adc1f5d26a11e2
EBUILD ipython-8.16.1.ebuild 4426 BLAKE2B 88a70404cb184318ac2fcd65dae0c66aaab9b349257831ed8be6f0c20f184b38c1fd573b8360f493356d3e1fbc179565916bde8d58da7e8b6ff7fe80d8a6d909 SHA512 49ab14dcd53bab6ab3b49f87c84f779a402d8cce2678deef08fd3e32fd07e08c4890216ec4df1a0d4a0f8c5ed61c055ef72100867e7e27cf12317eeadd200900
-EBUILD ipython-8.17.2.ebuild 4432 BLAKE2B 578ac7f2596815fbae00f43b1d0311d5fcca1f58e5e32ab5993a0fb7839dac71ff4ed9cd693f083090763eedeb19bec991d66a29b4bb6d5f70c71f8cb829abbf SHA512 85dcbeb5fde9b219d833a23ff0c7c9a8c2a835185f9062274193588dbcb02ec0e77fc570c943b0b0668bb9257230ee398a0f6da182301947ad7263d288211e97
+EBUILD ipython-8.17.2.ebuild 4928 BLAKE2B f08aefcd5cdb9c1519ad263b1618f3dde2f896ec0f5ff9918f620390972120d493d74e05e32b9b9b94aac6e7d1826993ac79b52d6af50838077b4a590cc5ed5e SHA512 ad68d18724908483dd79a415e814643887167433a66681c64b560d7ed1412de8a54f74b3e99d6d59b60096c1570cc1f43e55b04ff7e88bf8c5efc516c456045d
MISC metadata.xml 2802 BLAKE2B 2fb6773ad4ef10d531f978e3ed40f6d99cf1586ec6d7cf2bf7e60fd5d640d082a0946651e0a066993320ffeaace3426066ca24c325926b62125ae91816707128 SHA512 965c3e36e05475d9454af8219b84e080d4c83d775f8a7e20a4951a82246d672c46fd3cb1fff5f8664d0ce8e8fcb846de6f15abc4575db3a6b7d87209194bcecc
diff --git a/dev-python/ipython/ipython-8.17.2.ebuild b/dev-python/ipython/ipython-8.17.2.ebuild
index 5dfde618be12..c9fc67b54133 100644
--- a/dev-python/ipython/ipython-8.17.2.ebuild
+++ b/dev-python/ipython/ipython-8.17.2.ebuild
@@ -4,8 +4,9 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-PYTHON_REQ_USE='readline,sqlite,threads(+)'
+PYTHON_FULL=( python3_{10..12} )
+PYTHON_COMPAT=( "${PYTHON_FULL[@]}" pypy3 )
+PYTHON_REQ_USE='readline(+),sqlite,threads(+)'
inherit distutils-r1 optfeature pypi virtualx
@@ -40,20 +41,24 @@ RDEPEND="
BDEPEND="
test? (
app-text/dvipng[truetype]
- >=dev-python/ipykernel-5.1.0[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/matplotlib-inline[${PYTHON_USEDEP}]
- dev-python/nbformat[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/ipykernel-5.1.0[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ ' "${PYTHON_FULL[@]}")
>=dev-python/numpy-1.22[${PYTHON_USEDEP}]
+ dev-python/matplotlib-inline[${PYTHON_USEDEP}]
dev-python/pickleshare[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/testpath[${PYTHON_USEDEP}]
)
doc? (
- >=dev-python/ipykernel-5.1.0[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- >=dev-python/sphinx-2[${PYTHON_USEDEP}]
- dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/ipykernel-5.1.0[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-2[${PYTHON_USEDEP}]
+ dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]
+ ' "${PYTHON_FULL[@]}")
)
"
@@ -61,23 +66,29 @@ distutils_enable_tests pytest
RDEPEND+="
nbconvert? (
- dev-python/nbconvert[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ ' "${PYTHON_FULL[@]}")
)
"
PDEPEND="
- notebook? (
- dev-python/notebook[${PYTHON_USEDEP}]
- dev-python/ipywidgets[${PYTHON_USEDEP}]
- dev-python/widgetsnbextension[${PYTHON_USEDEP}]
- )
- qt5? ( dev-python/qtconsole[${PYTHON_USEDEP}] )
- smp? (
- >=dev-python/ipykernel-5.1.0[${PYTHON_USEDEP}]
- >=dev-python/ipyparallel-6.2.3[${PYTHON_USEDEP}]
- )
+ $(python_gen_cond_dep '
+ notebook? (
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ dev-python/widgetsnbextension[${PYTHON_USEDEP}]
+ )
+ qt5? ( dev-python/qtconsole[${PYTHON_USEDEP}] )
+ smp? (
+ >=dev-python/ipykernel-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/ipyparallel-6.2.3[${PYTHON_USEDEP}]
+ )
+ ' "${PYTHON_FULL[@]}")
"
-PATCHES=( "${FILESDIR}"/2.1.0-substitute-files.patch )
+PATCHES=(
+ "${FILESDIR}"/2.1.0-substitute-files.patch
+)
python_prepare_all() {
# Remove out of date insource files
@@ -97,7 +108,7 @@ python_prepare_all() {
}
python_compile_all() {
- if use doc; then
+ if use doc && has "${EPYTHON/./_}" "${PYTHON_FULL[@]}"; then
emake -C docs html_noapi
HTML_DOCS=( docs/build/html/. )
fi
@@ -115,6 +126,16 @@ python_test() {
IPython/core/tests/test_oinspect.py::test_render_signature_long
IPython/terminal/tests/test_shortcuts.py::test_modify_shortcut_with_filters
)
+
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # https://github.com/numpy/numpy/issues/25164
+ IPython/lib/tests/test_display.py::TestAudioDataWithoutNumpy
+ )
+ ;;
+ esac
+
# nonfatal implied by virtx
nonfatal epytest || die "Tests failed with ${EPYTHON}"
}