summaryrefslogtreecommitdiff
path: root/dev-python/ipyparallel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/ipyparallel
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/ipyparallel')
-rw-r--r--dev-python/ipyparallel/Manifest3
-rw-r--r--dev-python/ipyparallel/ipyparallel-8.1.0-r1.ebuild87
-rw-r--r--dev-python/ipyparallel/ipyparallel-8.1.0.ebuild2
3 files changed, 90 insertions, 2 deletions
diff --git a/dev-python/ipyparallel/Manifest b/dev-python/ipyparallel/Manifest
index 3c8759283432..ab30e5377ceb 100644
--- a/dev-python/ipyparallel/Manifest
+++ b/dev-python/ipyparallel/Manifest
@@ -4,5 +4,6 @@ DIST ipyparallel-7.1.0.tar.gz 4029033 BLAKE2B badf4bdad0dca0898e62abee3e5a48b064
DIST ipyparallel-8.1.0.tar.gz 9365732 BLAKE2B 847931de17f61b537a6350358a1fcc8e629b843e1216fcc0f60333f7baf42b0739f864bd1a02daefb839b90cfb4c65b6101de3271e89d529dd8493513b686ced SHA512 21e1d3d9e04c7567889e923ff0f1b140251518efd331dd2180a42142eedbb4c92eaeafce17bf2287e1d36ef4e5951f2f50021d9b9a96c266e4e94e1a3ac34347
EBUILD ipyparallel-6.3.0-r1.ebuild 2305 BLAKE2B 80b0818f788962604a564ce9c74068b27c8740e59b84405c297f314e65d7d459f6e638885570babbff88d861f5e48e8353c6ce30f4ae698f5213dd285104f0af SHA512 c6e4d5005fb46c79f5a19f00bfa60cafd8e57ce98f5083aa2d975710ec05678fe8319f66722dfe065d27bba4ae38984da0f5cfb51ce64c5d21671bce35226c19
EBUILD ipyparallel-7.1.0.ebuild 2913 BLAKE2B 409329a470efa0b9e6996925ff3d57084c1aeede7fcf9e588d7d7131633a83db3528d701a31d1cd3b39cc45ad7f2c89d41e775c91eade506e34a0bf99d9609e0 SHA512 4baf3ffad4747bd01ecfd498b4ac30dfc33765c8f441ec5016fe3985de2671c1e0cedc9a180554690e4ee5e4587f4f20b9fdc14b3f508320967e83fc0ecd97cf
-EBUILD ipyparallel-8.1.0.ebuild 2921 BLAKE2B 8297842abcb5af7aacd29686ce038ebdbffa4b0531ce55eb0141a43a48dac569bc410ce47a94c1aea3e7a53a97d0ba86ff471851d52691569a24480bf2e830fb SHA512 01a3eeaa41346319191c1873f537a6a2912fb7538d51f5371698786fb2340a41b97cabfd9228350a37bffd57ba035629a64be7d06bdaeeb1cfb3eb3e51a0d17f
+EBUILD ipyparallel-8.1.0-r1.ebuild 2905 BLAKE2B fb09e21f1c56e504b74b9b8e1466e5e6479309109f16c91c793e76dcb1510dd7c9ca740d06a5fa8a64fba12bc5b231e7b6c1ed6b3116a0b434499fa38dc2629b SHA512 0d4ada694b73281704ce9675d6729b211fb308aeac41d5bc88b67fe266dd912c1c5c5b02c86e514f54f72c95bc867af32a2937bb81389bc45bad019396320d98
+EBUILD ipyparallel-8.1.0.ebuild 2921 BLAKE2B 43a62f3289899d1eed402d15a6393a8be916cebfd459e30ca98d7a37015dad7e8de44a0b309de2a18af8a9f20e08c343a740294406890c742ce8228d937bca3e SHA512 3bb9008ce9355d4282b196b67d8fe0fa5aa70850bd7b1e2ab6bc256893ab8947617e0fdfb784d772d1cb4a2b2c86b1b63c184f940393107f93be383228f7fbdb
MISC metadata.xml 531 BLAKE2B 92dd755dd3036f653f24eda893979487b8d5bbf3c369f3f10c3fc2e69ad6aef03cb6eca295bcb8c6f89f0838780c20132bfd2a33bb38b56b227e97258447c2e0 SHA512 fcd131d18b012d1511468777dd72e07ed28a514419923911082229c0256b9003d9afe2048b6c339cb5c94307026b52bc4e9b6781d45660178d18385d71af8f21
diff --git a/dev-python/ipyparallel/ipyparallel-8.1.0-r1.ebuild b/dev-python/ipyparallel/ipyparallel-8.1.0-r1.ebuild
new file mode 100644
index 000000000000..4786e43c2d39
--- /dev/null
+++ b/dev-python/ipyparallel/ipyparallel-8.1.0-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Interactive Parallel Computing with IPython"
+HOMEPAGE="https://ipyparallel.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/entrypoints[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-18[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.3[${PYTHON_USEDEP}]
+ >=dev-python/ipython-4[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ dev-python/jupyter_server[${PYTHON_USEDEP}]
+ >=dev-python/ipykernel-4.4[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ >=www-servers/tornado-5.1[${PYTHON_USEDEP}]
+ "
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/ipython[test]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-tornado[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+ "
+
+# TODO: package myst_parser
+# distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-7.1.0-test-timeouts.patch
+)
+
+python_test() {
+ local deselect=(
+ # we don't run a mongo instance for tests
+ ipyparallel/tests/test_mongodb.py::TestMongoBackend
+ # TODO
+ ipyparallel/tests/test_util.py::test_disambiguate_ip
+ ipyparallel/tests/test_view.py::TestView::test_temp_flags
+ ipyparallel/tests/test_view.py::TestView::test_unicode_apply_arg
+ ipyparallel/tests/test_view.py::TestView::test_unicode_apply_result
+ ipyparallel/tests/test_view.py::TestView::test_unicode_execute
+ ipyparallel/tests/test_view.py::TestView::test_sync_imports_quiet
+ # Gets upset that a timeout _doesn't_ occur, presumably because
+ # we're cranking up too many test timeouts. Oh well.
+ # bug #823458#c3
+ ipyparallel/tests/test_asyncresult.py::AsyncResultTest::test_wait_for_send
+ # We could patch the timeout for these too but they're going to be inherently
+ # fragile anyway based on what they do.
+ ipyparallel/tests/test_client.py::TestClient::test_activate
+ ipyparallel/tests/test_client.py::TestClient::test_lazy_all_targets
+ ipyparallel/tests/test_client.py::TestClient::test_wait_for_engines
+ )
+ [[ ${EPYTHON} == python3.10 ]] && deselect+=(
+ # failing due to irrelevant warnings
+ ipyparallel/tests/test_client.py::TestClient::test_local_ip_true_doesnt_trigger_warning
+ ipyparallel/tests/test_client.py::TestClient::test_warning_on_hostname_match
+ )
+ epytest ${deselect[@]/#/--deselect }
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # move /usr/etc stuff to /etc
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}
+
+pkg_postinst() {
+ optfeature "Jupyter Notebook integration" dev-python/notebook
+}
diff --git a/dev-python/ipyparallel/ipyparallel-8.1.0.ebuild b/dev-python/ipyparallel/ipyparallel-8.1.0.ebuild
index 773096505343..a417de29a11a 100644
--- a/dev-python/ipyparallel/ipyparallel-8.1.0.ebuild
+++ b/dev-python/ipyparallel/ipyparallel-8.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8