summaryrefslogtreecommitdiff
path: root/dev-python/ipyparallel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
commiteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (patch)
treece35c6d01b5ff5de95c3a20fef853b9a6518ad2e /dev-python/ipyparallel
parentb7ebc951da8800f711142f69d9d958bde67a112d (diff)
gentoo resync : 04.05.2019
Diffstat (limited to 'dev-python/ipyparallel')
-rw-r--r--dev-python/ipyparallel/Manifest3
-rw-r--r--dev-python/ipyparallel/files/ipyparallel-6.2.3-disable-broken-test.patch28
-rw-r--r--dev-python/ipyparallel/ipyparallel-6.2.3.ebuild76
3 files changed, 107 insertions, 0 deletions
diff --git a/dev-python/ipyparallel/Manifest b/dev-python/ipyparallel/Manifest
index 282ff8b35917..b80cda175dfe 100644
--- a/dev-python/ipyparallel/Manifest
+++ b/dev-python/ipyparallel/Manifest
@@ -1,3 +1,6 @@
+AUX ipyparallel-6.2.3-disable-broken-test.patch 1063 BLAKE2B a80674390818474fba63c0b86c822eab8238713b96b2d6713478909da57bc4ee1c5bd1fa5da9fd7baff8d84b3ffd313540ed8287bd1c19dbeb61dd69bfe53dbb SHA512 c45c51b5c3fc1512d6bbd7bd557a91de50a1ae172ad465bc4f5482d6036f287ad17cad20406fbd51d8740eabe11a50584040c362c32f1770db69f4cbd9984681
DIST ipyparallel-6.0.2.tar.gz 2366627 BLAKE2B 333d6043c1e3635a37ebd464a5eb6bd0d21d0815abf106f8a7dd138128790d89ccb856dd981c281ce023cded589e6352fd6cd48efab61c8955abfbfea157eb35 SHA512 2dab781eac81bb3c2d4eedff9689448ed8d4317b47a1e8110a0b16147f986428f6fefe13acd12ee8604ec7775aee46a5f62c7d6a676bda7f8d3d39d95d90f28d
+DIST ipyparallel-6.2.3.tar.gz 2371030 BLAKE2B 73f96bbed280def33ae243e592ecf2e298afe92287cf3a7edb966859c38c6dcb1f1a43082ab83907aa00e06d571f4b750df28e6885a1c2d1fd1489fd4472a7fc SHA512 ddf479a7776c2ca9fd37aa5b7dd402c136ce62a479333f5f56dce413649f9b928daed56c173ad5325268eaa58667d611257b20c8269899cc06ae2829f973b4c1
EBUILD ipyparallel-6.0.2-r1.ebuild 1690 BLAKE2B 4a1d86d18d2a3f800224c3056ab3eb3f58b5388e844ab32404542e3c9d754e8371ab770d4fe3ce91c050977b17d1657ddde5371f72cebab40f4fcdab04b70378 SHA512 b94806139d4e20ca891e0676ccdc1ce49b255d05f4f62b78e1146e254371e5cfec0893426ebeea6dd6d192e7c2a39e7cab0ec599df968a27b3370fbcffc9b9de
+EBUILD ipyparallel-6.2.3.ebuild 2043 BLAKE2B ca5b085c54baa2cdef6ba1ce6ed9f2edf3e62c12efb0d4ca61ab9a348b8881fa90f25ca76abd43b43e09fd3b169de61a1990cc3bc326663e31def13b1a494dfb SHA512 4141f329d3cce6c88f14297c01910d837e989c86edb8e772c8acf4dd8e1a3cd7a558bfdae50e34c70560e10c357fe0252b90d5a7d7a491c558aa567ab63fc5b0
MISC metadata.xml 541 BLAKE2B 1864cc5953409eb51527e721ab298f8296453190f32fbd620da058a2907ffb3778ac1f6723b1f50cd86a27d967d62d882cc5d0cba2709f653b0bd7328288f69e SHA512 47be22e2e5c3d43e92a6e9fcdcfe936ac7690499b850920196fca218b326f708d2350ec23f3084b58d0c9630f8dba06b90414a2e325811467034ef9f35a07a9a
diff --git a/dev-python/ipyparallel/files/ipyparallel-6.2.3-disable-broken-test.patch b/dev-python/ipyparallel/files/ipyparallel-6.2.3-disable-broken-test.patch
new file mode 100644
index 000000000000..b578cd7f73e1
--- /dev/null
+++ b/dev-python/ipyparallel/files/ipyparallel-6.2.3-disable-broken-test.patch
@@ -0,0 +1,28 @@
+diff --git a/ipyparallel/tests/test_util.py b/ipyparallel/tests/test_util.py
+index 06fde46..e685a88 100644
+--- a/ipyparallel/tests/test_util.py
++++ b/ipyparallel/tests/test_util.py
+@@ -3,7 +3,8 @@ from ipyparallel import util
+ from jupyter_client.localinterfaces import localhost, public_ips
+
+
+-def test_disambiguate_ip():
++# This test is broken in gentoo's testing environment
++def xtest_disambiguate_ip():
+ # garbage in, garbage out
+ public_ip = public_ips()[0]
+ assert util.disambiguate_ip_address('garbage') == 'garbage'
+diff --git a/ipyparallel/tests/test_view.py b/ipyparallel/tests/test_view.py
+index 45cb669..dd335b1 100644
+--- a/ipyparallel/tests/test_view.py
++++ b/ipyparallel/tests/test_view.py
+@@ -823,7 +823,8 @@ class TestView(ClusterTestCase):
+ assert view.apply_sync(find_ipython)
+
+ @skip_without('cloudpickle')
+- def test_use_cloudpickle(self):
++ # Broken on Gentoo
++ def xtest_use_cloudpickle(self):
+ view = self.client[:]
+ view['_a'] = 'engine'
+ sys.modules['__main__']._a = 'client'
diff --git a/dev-python/ipyparallel/ipyparallel-6.2.3.ebuild b/dev-python/ipyparallel/ipyparallel-6.2.3.ebuild
new file mode 100644
index 000000000000..2a43f855e588
--- /dev/null
+++ b/dev-python/ipyparallel/ipyparallel-6.2.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Interactive Parallel Computing with IPython"
+HOMEPAGE="https://ipyparallel.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+# About tests and tornado
+# Upstreams claims to work fine with tornado 5, and it's indeed possible to
+# launch a cluster with tornado 5 installed, but tests definitely don't run with
+# tornado 5 installed. Upstreams CI runs with tornado 4. This is why we limit
+# ourselves to <tornado-5 when running tests.
+
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '<dev-python/ipython-6[${PYTHON_USEDEP}]' 'python2_7')
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/ipython[test]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ <www-servers/tornado-5
+ )
+ "
+
+PATCHES=(
+ "${FILESDIR}/${PN}-6.2.3-disable-broken-test.patch"
+)
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/build/html/. )
+ fi
+}
+
+python_test() {
+ pytest -vs ipyparallel/tests || die
+}
+
+pkg_postinst() {
+ optfeature "Jupyter Notebook integration" dev-python/notebook
+}