summaryrefslogtreecommitdiff
path: root/dev-python/ipyparallel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /dev-python/ipyparallel
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'dev-python/ipyparallel')
-rw-r--r--dev-python/ipyparallel/Manifest1
-rw-r--r--dev-python/ipyparallel/ipyparallel-6.3.0-r1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/ipyparallel/Manifest b/dev-python/ipyparallel/Manifest
index 42975162e585..36dc01351b12 100644
--- a/dev-python/ipyparallel/Manifest
+++ b/dev-python/ipyparallel/Manifest
@@ -1,3 +1,4 @@
DIST ipyparallel-6.3.0.tar.gz 2380153 BLAKE2B b8312102e1d2b5fc963491ebe8530e2fd73e9f941f7912fbc72a8db51e7255f5cac95a853d15a57e384926ab1aff27f2a3ad13cc45130a8b612be5dc623538ab SHA512 fe621854b9cc3e5f88aeca2b06b63bb689dd2feee0da451a0a90800d8832f4b44b23bb9a15033029cc33179276f31e982a10fc7540e6d13b04f15d96c348a295
+EBUILD ipyparallel-6.3.0-r1.ebuild 1721 BLAKE2B 377255a22842e61abef1707ba54024bbabcc24af9d943af69c5697dbd7ed870ab743cf89503d051a3febd505334ac47cca54cd1ca713f193203415df1daa836a SHA512 7690b53d225b82108c0115d1ac32147aebaa58dad62d2e7d957dbdd3a48432c2dee032a745959375dc7cbbbf543e82ac1d3f2d14e4b4cc8a53753db44568f2d8
EBUILD ipyparallel-6.3.0.ebuild 1718 BLAKE2B e67a1bf4043f42fe6e60611ee1c6bd1bbfbd56074f5328992ee01e7649b9d415dd173b15779af2fd331cb9368c4fb5c1130efbda2060edbcea303818b1d90d95 SHA512 bc731e2069ea2533eacc3967eaf705148ccd809d8c0d8746296c11097184361ee72c2d351a7b08b13077c2155037a169cde49cc70e7316a868881077556292a8
MISC metadata.xml 505 BLAKE2B 3dc8a7d01f8d67619f064ced47674ad386c81e625d46b820a7949dcba68755ecc69d29166880d80ba8951bd5226d6a380fdb0545287c527a133c3645b6f2bee5 SHA512 d86601139ae4a5d2aaf7d69fdfd609450f12d03775276bb0b459728712a15803d7c3a6ec3eb73ca7a0802e4333809f2eff8f9ebc2dd2a2c22947262b78c3dea6
diff --git a/dev-python/ipyparallel/ipyparallel-6.3.0-r1.ebuild b/dev-python/ipyparallel/ipyparallel-6.3.0-r1.ebuild
new file mode 100644
index 000000000000..f478bc55e983
--- /dev/null
+++ b/dev-python/ipyparallel/ipyparallel-6.3.0-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="threads(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Interactive Parallel Computing with IPython"
+HOMEPAGE="https://ipyparallel.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+# About tests and tornado
+# Upstreams claims to work fine with tornado 5, and it's indeed possible to
+# launch a cluster with tornado 5 installed, but tests definitely don't run with
+# tornado 5 installed. Upstreams CI runs with tornado 4. This is why we limit
+# ourselves to <tornado-5 when running tests.
+
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ "
+BDEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/ipython[test]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+ "
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+src_prepare() {
+ # TODO: investigate
+ sed -e 's:test_unicode:_&:' \
+ -e 's:test_temp_flags:_&:' \
+ -i ipyparallel/tests/test_view.py || die
+
+ distutils-r1_src_prepare
+}
+
+pkg_postinst() {
+ optfeature "Jupyter Notebook integration" dev-python/notebook
+}