summaryrefslogtreecommitdiff
path: root/dev-python/ipyparallel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-06 00:30:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-06 00:30:33 +0100
commit9323524b4d44f4ec3dc923bd8e9ea04bdde8a067 (patch)
tree8ca7b8c58d4e70389d5d4672ebd86cb475cf9f80 /dev-python/ipyparallel
parent8c11cf748cc296d6338a189106a8cc9e3a1e0948 (diff)
gentoo auto-resync : 06:04:2024 - 00:30:33
Diffstat (limited to 'dev-python/ipyparallel')
-rw-r--r--dev-python/ipyparallel/Manifest2
-rw-r--r--dev-python/ipyparallel/ipyparallel-8.8.0.ebuild86
2 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/ipyparallel/Manifest b/dev-python/ipyparallel/Manifest
index 5772869763b9..e9f8f7837e1b 100644
--- a/dev-python/ipyparallel/Manifest
+++ b/dev-python/ipyparallel/Manifest
@@ -1,4 +1,6 @@
AUX ipyparallel-7.1.0-test-timeouts.patch 2067 BLAKE2B 577b33b730f110775dbd61fe02d06834fe3c4eb3c730d6df16730bbc877402e9f4756b74691bb977c3892ff981d374a4d1b439bf2b682e76c496ce8502f26583 SHA512 2d0f9fb4966be06299b40cd2ad974b4f94cfedea84fcee38b900ce4596b15cd3963068fc374aa1c0e54765b92d68c5233965fd2d3696bba5474da24917d1f009
DIST ipyparallel-8.7.0.tar.gz 6798726 BLAKE2B 2f948ab19883e9364cab82227ad9918010f144ccf8d9899c54e4a3a9df99bd42faf6001ba837e6c7bfb25738c6ad25f766396b76ba7fa5097d84f385d69dbc68 SHA512 96b9a3c1435dcb609c81856e5fc2763265a14610483e9d6c1a0b1fe5f7d6981d42d8f0d7b0c245cdf1fec10d4a832854dc745ca02ce90623734216dc858bb322
+DIST ipyparallel-8.8.0.tar.gz 6800541 BLAKE2B ae40aa60eec2c07bb1ecce696df9f8429293e1602bced8e6220e6a93b780b44131a4fcbd01c921952cae9945fc509f6084570b96ce0c3da7ce4f0cc1d853db1b SHA512 9b0a03e1f581acbe56e3b51331d9fb97c422469e1d93348e6403d7c95a985f1f5a2a390645222fc4b60c0027ba168933679662561adb618d19ae7d680a2bb680
EBUILD ipyparallel-8.7.0.ebuild 2493 BLAKE2B 9d25d3a9c9aa8edec5677174ebcaa01d1b1b9831c5277d79871c0cc484fb415f84ec9d991936bd13481491d8b2737a5dee9a4e6fe767f4ed7924278f33ecf63e SHA512 89871d8d21ec8682e3d8784754e2df588d70dea9cc24b8561fcc8999c3a16e60b815af313aa02c06b1f3b347108b1fabb4044025c706a7e2a101585019f312f8
+EBUILD ipyparallel-8.8.0.ebuild 2506 BLAKE2B 8fe6f6ee7ba4b111de10a66ea1b93dd7d931e0f96108be55d05e09b4885353a65e8086bfeeb3afd97e45a2de089ae58fab8376fd3f91ee02103ddae549393fcd SHA512 f03a92b41d3f712f8387b7353419dc897e2a4baede7cfea999f7e87e2e7607afef9dee53dfdae49d8c62c1acdb680f57ca3556c2146b6b1b6ae12ef7665b53c8
MISC metadata.xml 531 BLAKE2B 92dd755dd3036f653f24eda893979487b8d5bbf3c369f3f10c3fc2e69ad6aef03cb6eca295bcb8c6f89f0838780c20132bfd2a33bb38b56b227e97258447c2e0 SHA512 fcd131d18b012d1511468777dd72e07ed28a514419923911082229c0256b9003d9afe2048b6c339cb5c94307026b52bc4e9b6781d45660178d18385d71af8f21
diff --git a/dev-python/ipyparallel/ipyparallel-8.8.0.ebuild b/dev-python/ipyparallel/ipyparallel-8.8.0.ebuild
new file mode 100644
index 000000000000..86168fffc4d2
--- /dev/null
+++ b/dev-python/ipyparallel/ipyparallel-8.8.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Interactive Parallel Computing with IPython"
+HOMEPAGE="
+ https://ipyparallel.readthedocs.io/
+ https://github.com/ipython/ipyparallel/
+ https://pypi.org/project/ipyparallel/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/entrypoints[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-18[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.3[${PYTHON_USEDEP}]
+ >=dev-python/ipython-4[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-client-5[${PYTHON_USEDEP}]
+ dev-python/jupyter-server[${PYTHON_USEDEP}]
+ >=dev-python/ipykernel-4.4[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ >=dev-python/tornado-5.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/flit-core[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-tornado[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+"
+
+# TODO: package myst_parser
+# distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-7.1.0-test-timeouts.patch
+)
+
+src_configure() {
+ export IPP_DISABLE_JS=1
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # we don't run a mongo instance for tests
+ ipyparallel/tests/test_mongodb.py::TestMongoBackend
+ # TODO
+ ipyparallel/tests/test_util.py::test_disambiguate_ip
+ # Gets upset that a timeout _doesn't_ occur, presumably because
+ # we're cranking up too many test timeouts. Oh well.
+ # bug #823458#c3
+ ipyparallel/tests/test_asyncresult.py::AsyncResultTest::test_wait_for_send
+ # We could patch the timeout for these too but they're going to be inherently
+ # fragile anyway based on what they do.
+ ipyparallel/tests/test_client.py::TestClient::test_activate
+ ipyparallel/tests/test_client.py::TestClient::test_lazy_all_targets
+ ipyparallel/tests/test_client.py::TestClient::test_wait_for_engines
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -p tornado
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # move /usr/etc stuff to /etc
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}
+
+pkg_postinst() {
+ optfeature "Jupyter Notebook integration" dev-python/notebook
+}