summaryrefslogtreecommitdiff
path: root/dev-python/ipykernel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-28 07:12:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-28 07:12:54 +0000
commit63a01a3024a6fa402d123768cd38f1cabe13adf6 (patch)
tree439fe2938e6178658c16e1109f895390a4786cbd /dev-python/ipykernel
parent5e9fc028c5219fddb410ed4e213b54cf4618a563 (diff)
gentoo auto-resync : 28:03:2024 - 07:12:54
Diffstat (limited to 'dev-python/ipykernel')
-rw-r--r--dev-python/ipykernel/Manifest2
-rw-r--r--dev-python/ipykernel/ipykernel-6.29.4.ebuild80
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/ipykernel/Manifest b/dev-python/ipykernel/Manifest
index 6f6e57dd4916..d99a539036e9 100644
--- a/dev-python/ipykernel/Manifest
+++ b/dev-python/ipykernel/Manifest
@@ -1,3 +1,5 @@
DIST ipykernel-6.29.3.tar.gz 162794 BLAKE2B 3f0dcd1805d736f3657949cad45d8cacc57b6bdd4d950507eedb12aaae9e5f769174e8be45cd648d13b842b144bab237afa8da187b94f91a699602e795fb2418 SHA512 8726b37341a810318ec9c1585649288b40c3ac6875c82f5752da245ccd74125f5cb1557ca27a8187a8f668943a527345e9311d015b9e4e3095a4e07195a7d5b8
+DIST ipykernel-6.29.4.tar.gz 162958 BLAKE2B 887d33b433f5fba70273e4020a79bb511bd076fe536c04ebc5f7e838637ff120889789783f9a3a41b4669b0b51d44401215ed3feac413382b953edf9d1b6cb48 SHA512 488d43c1c9f416281b23ba0f31311c7327ef97034d6cf1776392c0f7b193f52f1434e81ae0c45759a0b15354ef9d178c3fc835c6be4408880209e41b91e5602b
EBUILD ipykernel-6.29.3.ebuild 2302 BLAKE2B f20123b1e3324f0461c8c3dcb771a5845611a294c84945c3f224dad47c9e7b6e16102bc19fd8e24c4c4e7afa3c836b76c065919303995a55e67826db798a0333 SHA512 1c2654429b1f354d71cb8bb32898e832b0e513ff614f4829fe6ddb595a1e794b01754a4cf536828bf104010cedb9b035976c86ac7c4ee9e444be7b6d5cb2145d
+EBUILD ipykernel-6.29.4.ebuild 2351 BLAKE2B f0dc0aa3370ef19a53f1ec756e9bba6170b05dada87529d1e21f72c506bb664d1e7f640e46724f678a3b9468d73a78da6b88013096c98a1bb3302e36fb22ee0f SHA512 27c5babacdf79b4cfdfcb86798673b2faa35bdb663d6611f24264cd90f70f5e1287ffd210299fe35a2a613d51b72fe247e87f23db5722e61fc403b6a8bc804b5
MISC metadata.xml 527 BLAKE2B 4a24cb9d5b801bf94c71c47d0c90b04bc249fb41a794c7b688a5762f08545d1fcfe9e4976aa4f583ecb456458b5f6dfc394349633959444584c0abad0da4be42 SHA512 ed9f0ef12ec5de67a646783243555f1737604a84c78c57b9f7c65137cec8cbc396991411501927f92bd393daad2238c27363ecc9c115031450231c2a4fb2cbb9
diff --git a/dev-python/ipykernel/ipykernel-6.29.4.ebuild b/dev-python/ipykernel/ipykernel-6.29.4.ebuild
new file mode 100644
index 000000000000..90d6f878ac72
--- /dev/null
+++ b/dev-python/ipykernel/ipykernel-6.29.4.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi virtualx
+
+DESCRIPTION="IPython Kernel for Jupyter"
+HOMEPAGE="
+ https://github.com/ipython/ipykernel/
+ https://pypi.org/project/ipykernel/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/comm-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/ipython-7.23.1[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-client-8[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-core-4.12[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-inline-0.1[${PYTHON_USEDEP}]
+ dev-python/nest-asyncio[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-24[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.1[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.4.0[${PYTHON_USEDEP}]
+"
+# RDEPEND seems specifically needed in BDEPEND, at least jupyter
+# bug #816486
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.23.5[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/ipyparallel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # debugpy is actually optional
+ sed -i -e '/debugpy/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ # Use python3 in kernel.json configuration, bug #784764
+ sed -i -e '/python3.[0-9]\+/s//python3/' \
+ "${BUILD_DIR}/install${EPREFIX}/usr/share/jupyter/kernels/python3/kernel.json" || die
+}
+
+src_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_debugger.py::test_attach_debug
+ tests/test_debugger.py::test_breakpoint_in_cell_with_leading_empty_lines
+ tests/test_debugger.py::test_rich_inspect_at_breakpoint
+ tests/test_debugger.py::test_rich_inspect_not_at_breakpoint
+ tests/test_debugger.py::test_set_breakpoints
+ tests/test_debugger.py::test_stop_on_breakpoint
+ tests/test_debugger.py::test_copy_to_globals
+ # hangs?
+ tests/test_eventloop.py::test_tk_loop
+ # doesn't like pyside2?
+ tests/test_eventloop.py::test_qt_enable_gui
+ )
+
+ virtx distutils-r1_src_test
+}