summaryrefslogtreecommitdiff
path: root/dev-python/ipykernel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-28 22:49:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-28 22:49:38 +0000
commit33f4c0828f4961b9d7acfbe27f8f795cf7fb8ba7 (patch)
treebc63e2cf852ee4be3f99e45dc2a409b6d54ddd77 /dev-python/ipykernel
parentb35600c999baee29d87c2748f7207ce79ca87067 (diff)
gentoo auto-resync : 28:11:2023 - 22:49:38
Diffstat (limited to 'dev-python/ipykernel')
-rw-r--r--dev-python/ipykernel/Manifest2
-rw-r--r--dev-python/ipykernel/ipykernel-6.27.1.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/ipykernel/Manifest b/dev-python/ipykernel/Manifest
index 67acee71d6ab..77b614f03778 100644
--- a/dev-python/ipykernel/Manifest
+++ b/dev-python/ipykernel/Manifest
@@ -1,5 +1,7 @@
DIST ipykernel-6.26.0.tar.gz 157526 BLAKE2B 8ba5cf820cf03d7735a4dbcb613925b9f9f83d949e065d61f546f3b8ded17accdfdcb4d72718fa644f2233f0397afe8f77437fed1d219710ecac6c9db523e08e SHA512 8199f59ac0147e3b21a07f28d64bf73311ccbf6b48b060979a520ac798a058496e659d08a7b41b1321b4be7092e09fe793d80fb061fc2706b46aa17e93e142f8
DIST ipykernel-6.27.0.tar.gz 157721 BLAKE2B ea34d02f57f67d720fb744f8bd7fd9a191ec2c104aafca2741eb50b4a28519e609efc465e73dbd2aad5ce1c0e383ea33115f13171deee70825d734a42f38c852 SHA512 13c9c1c2083def67b3fa5e93b03d77a40b14d2505a07386554e03f896e9ca961c54ab6b7d51fbe05bd684f1acf651196a2b0f804ded23461eac5b6500b829c45
+DIST ipykernel-6.27.1.tar.gz 157828 BLAKE2B d81c241d55a6b45098bd38805dd8db2dd10c13bd290102f96011fc134b54925218da03ee6bdddd2de137089017e157cd6806ce3884279d3bc00684a357b60c7a SHA512 c4ee96c934e66a1d27d680bb43adb88affb49e605310d4d619cd42b0a294d82ad7884a110998eb3004be4f010d847968694b4c8327efa26976062249895132c6
EBUILD ipykernel-6.26.0.ebuild 2280 BLAKE2B b29feaeef6a70361a1367f78bea2ead027faa479dbf7261cb21ac2bf12d997730a471cb5b7f31cecc3cca4fed77a882f57f8103a1c0e418e4941c51540c2b57e SHA512 3eb4ff78bef76b740b5b0c45ecee84626c3c68103594a8d2b4b6c6bd8cef87deb76edb8c3a8186a62904b878808e9b37d68ce7c281f76379a73c71276aa0b0dd
EBUILD ipykernel-6.27.0.ebuild 2288 BLAKE2B 62ff89f8b7847cc9ffd12391c421f9e718722e9183a69da90f2faaa1b77de21833a52ca04bf47cec9d054db369e1f5cac9cafdc046cff59ca0242a1a0295d53c SHA512 f6fd390b8bb37763e312e70b5906af95436f82b418717710cf2431e4a05381702b2d230bc34c6dea93941c255d8ae28647377585d84be8310f02f0e6a8b80003
+EBUILD ipykernel-6.27.1.ebuild 2288 BLAKE2B 62ff89f8b7847cc9ffd12391c421f9e718722e9183a69da90f2faaa1b77de21833a52ca04bf47cec9d054db369e1f5cac9cafdc046cff59ca0242a1a0295d53c SHA512 f6fd390b8bb37763e312e70b5906af95436f82b418717710cf2431e4a05381702b2d230bc34c6dea93941c255d8ae28647377585d84be8310f02f0e6a8b80003
MISC metadata.xml 527 BLAKE2B 4a24cb9d5b801bf94c71c47d0c90b04bc249fb41a794c7b688a5762f08545d1fcfe9e4976aa4f583ecb456458b5f6dfc394349633959444584c0abad0da4be42 SHA512 ed9f0ef12ec5de67a646783243555f1737604a84c78c57b9f7c65137cec8cbc396991411501927f92bd393daad2238c27363ecc9c115031450231c2a4fb2cbb9
diff --git a/dev-python/ipykernel/ipykernel-6.27.1.ebuild b/dev-python/ipykernel/ipykernel-6.27.1.ebuild
new file mode 100644
index 000000000000..5c20d40e3a48
--- /dev/null
+++ b/dev-python/ipykernel/ipykernel-6.27.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi virtualx
+
+DESCRIPTION="IPython Kernel for Jupyter"
+HOMEPAGE="
+ https://github.com/ipython/ipykernel/
+ https://pypi.org/project/ipykernel/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/comm-0.1.1[${PYTHON_USEDEP}]
+ !elibc_Darwin? (
+ $(python_gen_cond_dep '
+ >=dev-python/debugpy-1.6.5[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+ >=dev-python/ipython-7.23.1[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-client-8[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-core-4.12[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-inline-0.1[${PYTHON_USEDEP}]
+ dev-python/nest-asyncio[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-20[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.1[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.4.0[${PYTHON_USEDEP}]
+"
+# RDEPEND seems specifically needed in BDEPEND, at least jupyter
+# bug #816486
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/ipyparallel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile
+ # Use python3 in kernel.json configuration, bug #784764
+ sed -i -e '/python3.[0-9]\+/s//python3/' \
+ "${BUILD_DIR}/install${EPREFIX}/usr/share/jupyter/kernels/python3/kernel.json" || die
+}
+
+src_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_debugger.py::test_attach_debug
+ tests/test_debugger.py::test_breakpoint_in_cell_with_leading_empty_lines
+ tests/test_debugger.py::test_rich_inspect_at_breakpoint
+ tests/test_debugger.py::test_rich_inspect_not_at_breakpoint
+ tests/test_debugger.py::test_set_breakpoints
+ tests/test_debugger.py::test_stop_on_breakpoint
+ tests/test_debugger.py::test_copy_to_globals
+ # hangs?
+ tests/test_eventloop.py::test_tk_loop
+ # doesn't like pyside2?
+ tests/test_eventloop.py::test_qt_enable_gui
+ )
+
+ virtx distutils-r1_src_test
+}