summaryrefslogtreecommitdiff
path: root/dev-python/ipykernel/ipykernel-6.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-python/ipykernel/ipykernel-6.2.0.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-python/ipykernel/ipykernel-6.2.0.ebuild')
-rw-r--r--dev-python/ipykernel/ipykernel-6.2.0.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/ipykernel/ipykernel-6.2.0.ebuild b/dev-python/ipykernel/ipykernel-6.2.0.ebuild
deleted file mode 100644
index 245f56213f05..000000000000
--- a/dev-python/ipykernel/ipykernel-6.2.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-PYTHON_REQ_USE="threads(+)"
-inherit distutils-r1
-
-DESCRIPTION="IPython Kernel for Jupyter"
-HOMEPAGE="https://github.com/ipython/ipykernel"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv sparc x86"
-
-RDEPEND="
- >=dev-python/debugpy-1.0.0[${PYTHON_USEDEP}]
- <dev-python/debugpy-2.0[${PYTHON_USEDEP}]
- >=dev-python/ipython-7.23.1[${PYTHON_USEDEP}]
- <dev-python/ipython-8.0[${PYTHON_USEDEP}]
- >=dev-python/traitlets-4.1.0[${PYTHON_USEDEP}]
- <dev-python/traitlets-6.0[${PYTHON_USEDEP}]
- <dev-python/jupyter_client-8.0[${PYTHON_USEDEP}]
- >=www-servers/tornado-4.2[${PYTHON_USEDEP}]
- <www-servers/tornado-7.0[${PYTHON_USEDEP}]
- >=dev-python/matplotlib-inline-0.1.0[${PYTHON_USEDEP}]
- <dev-python/matplotlib-inline-0.2.0[${PYTHON_USEDEP}]
-"
-# RDEPEND seems specifically needed in BDEPEND, at least jupyter
-# bug #816486
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/nose_warnings_filters[${PYTHON_USEDEP}]
- dev-python/ipyparallel[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e 's:^TIMEOUT = .*:TIMEOUT = 120:' ipykernel/tests/*.py || die
- distutils-r1_src_prepare
-}