summaryrefslogtreecommitdiff
path: root/dev-python/ipy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/ipy
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/ipy')
-rw-r--r--dev-python/ipy/Manifest4
-rw-r--r--dev-python/ipy/ipy-1.00.ebuild45
-rw-r--r--dev-python/ipy/ipy-1.01.ebuild2
3 files changed, 2 insertions, 49 deletions
diff --git a/dev-python/ipy/Manifest b/dev-python/ipy/Manifest
index d7fe320047a3..7199ce37e5c5 100644
--- a/dev-python/ipy/Manifest
+++ b/dev-python/ipy/Manifest
@@ -1,5 +1,3 @@
-DIST IPy-1.00.tar.gz 35324 BLAKE2B a0e04201a59c61e5cc8f7ce2837c83dded99d0d786406e2e341183a0903d43ed5496ae8ea05d1bee019007bfef7420be623ab3dc08cce33812f1720a59ca413d SHA512 94a8f26cad0d966fdf8d4e57284eadf4cfde88515af6f5aafc8f9597eb0758324b876039d1a121021ba1ac26be2e2ffa89a3f5803dddefdee03fdb5d65b07a81
DIST IPy-1.01.tar.gz 33641 BLAKE2B 10d5ac5c3df00a562393ee762e9ad0f458ecf4745f894ab23e686b7112842adcbb3f25064c0010630745273fa72280ba5ef92a951d687d0f46f341acd6c041ad SHA512 f0983254523025a1819d543877d9651fb6a9e39dabd3b043488495f681b02e43b544a0121658a0430a418a1c39b360a59db1699af87a75a16a2bdc29fcb2b74c
-EBUILD ipy-1.00.ebuild 1151 BLAKE2B ac80bdf58329ebb15d1d82f5451b7f5f95ee83e21d6c386f5e855b5b29d802c070ac8fad01c9ac306733a64453a2d56173434cb5b231ff48690b55fb957c6d95 SHA512 8f94664e26a18da51104f1799256f1e487b5bdbbfc2823e78dbd957cd35535bc439092aae0e5d9dcc1cb49eef0e3fa15b872073b6b3942518545d93247e3c0d2
-EBUILD ipy-1.01.ebuild 1106 BLAKE2B 1cf4b913bd71a87e87fa09ef86ea68338ab9cb34d7a29472970a9c7fbe1d7136ff4ce519be604593d5e1b6ae4468fb76f02e8cf7f86fbdb07b352427c7ae4045 SHA512 081b54c3260df1845d7436fcc97ae82d871eecaa46db78f1ff482885bfb449c78e9099ac596287f5eae094301b66fc1bc3a1f79ffcc4b7ad4a3e50781e2cfbe4
+EBUILD ipy-1.01.ebuild 1104 BLAKE2B 2a916647e99083d5cf520f79b03e4e6acad18a5a43ff728e7c3951c798f20f89a85a04eef006512f4f5adbc5480081d022b758b1d88b9cb2be07a7f67e01f45e SHA512 f494e3eb0021bc9924dfe0eaf8f9ba614c26249e8e68093fbb0f0fdaadcfeda6af54e6bc06c2118cda432baae40efa62f82201c1698fcc9cfbad5232f475fcf4
MISC metadata.xml 403 BLAKE2B 20229385e1b06c38601686268fbbf06c3f797933946b58fad8becc44166dcebe0969ec658a7a5ebc8825cb46d11ffe6c141daf4202f290b891ea1bf4ed0be531 SHA512 07d57dc63949778a70b1c6e2976943d747cf425fa35c86409d6458783f517eac17ecd2443a9bac80d599059ea9487e1c6b9f60ebd283b1978844d22ca4c20486
diff --git a/dev-python/ipy/ipy-1.00.ebuild b/dev-python/ipy/ipy-1.00.ebuild
deleted file mode 100644
index 8a8a3fc87436..000000000000
--- a/dev-python/ipy/ipy-1.00.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( python{3_7,3_8} )
-
-inherit distutils-r1
-
-MY_PN="IPy"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Class and tools for handling of IPv4 and IPv6 addresses and networks"
-HOMEPAGE="https://github.com/autocracy/python-ipy/wiki https://pypi.org/project/IPy/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc x86"
-IUSE="examples"
-
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND=""
-RDEPEND=""
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_test() {
- # 1 test fail under pypy, persistent from 0.82a, not a regression.
- cp -r test_doc.py README.rst test "${BUILD_DIR}" || die
- pushd "${BUILD_DIR}" > /dev/null || die
- "${PYTHON}" test/test_IPy.py || die "Tests fail with ${EPYTHON}"
- "${PYTHON}" test_doc.py || die "Doctests fail with ${EPYTHON}"
- popd > /dev/null || die
-}
-
-python_install_all() {
- if use examples; then
- docinto examples
- dodoc -r example/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/ipy/ipy-1.01.ebuild b/dev-python/ipy/ipy-1.01.ebuild
index a8260ce8a9d2..fc72e6719760 100644
--- a/dev-python/ipy/ipy-1.01.ebuild
+++ b/dev-python/ipy/ipy-1.01.ebuild
@@ -18,7 +18,7 @@ S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc x86"
IUSE="examples"
python_test() {