summaryrefslogtreecommitdiff
path: root/dev-python/ipy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/ipy
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/ipy')
-rw-r--r--dev-python/ipy/Manifest4
-rw-r--r--dev-python/ipy/ipy-0.83.ebuild39
-rw-r--r--dev-python/ipy/ipy-1.00.ebuild7
3 files changed, 7 insertions, 43 deletions
diff --git a/dev-python/ipy/Manifest b/dev-python/ipy/Manifest
index 52a36b84e80d..a24114f93546 100644
--- a/dev-python/ipy/Manifest
+++ b/dev-python/ipy/Manifest
@@ -1,5 +1,3 @@
-DIST IPy-0.83.tar.gz 31816 BLAKE2B 89ca11d292ff3ed6f633aacc2c689e710c5ed43ada32e75425f653bfe87bcf6eb777d5ede33133362833099e51b2248f5e846bae82b28a6050500f25679ddbfb SHA512 6bd69d96fa77dc4ceaf119b81c19a524b871badb37665a763a055e1c8b2ce3433c6e9534f03aa64d02e559dca2fac2c4e1d09b7fd78ed79c0fded88f803ad2de
DIST IPy-1.00.tar.gz 35324 BLAKE2B a0e04201a59c61e5cc8f7ce2837c83dded99d0d786406e2e341183a0903d43ed5496ae8ea05d1bee019007bfef7420be623ab3dc08cce33812f1720a59ca413d SHA512 94a8f26cad0d966fdf8d4e57284eadf4cfde88515af6f5aafc8f9597eb0758324b876039d1a121021ba1ac26be2e2ffa89a3f5803dddefdee03fdb5d65b07a81
-EBUILD ipy-0.83.ebuild 1058 BLAKE2B fd29c552b9dcff840c2c9eeac7e0401d08de9aae28db5f05138a37c20b4c3ef395a77c3162387655e306cf4692410b06081d0c3e8fdacade120454ea1d9ac9a2 SHA512 b17d98b52072d3352b8e86ce350e5d60fe7b919881f5d3c2e1e70bb69f3115784e9fe9c34d8c6c5d65ee03f4905d8e3c90903f545ad1314b5f5329cbb0b60494
-EBUILD ipy-1.00.ebuild 1083 BLAKE2B 3f8fd17d47498ab4002009b586c194152acd33675a42b26235bf8d72db97afed03b3c44dd2ce77cd9a904e417fb0d4924be43c420df634280eef0e0dc843b582 SHA512 46b03c42d007d84ae87d5e655ac256d396473df5a8ff9a644cd3d97b62f285679dbd3acce4501b7e0b305ca26d5a5a86f411efe44800b51574d9e53daf4a810f
+EBUILD ipy-1.00.ebuild 1151 BLAKE2B 620f5a62a5a0b364c7c9331271dd11b57e26423a318e48091307967f43f74b9eeb18661cca61291aac1355d14ca08db634902c2bee12f0294b08d57c200a65c0 SHA512 8ccb2cdf9bbe88dd28ce98e6a5a61d25ead10442b77bee342420a8812d0a38d73ef28f9ba2cf759f90d62444adbf8fa9d081d8fa05bfe45f30f3a42537d8cb4e
MISC metadata.xml 374 BLAKE2B 89f26050a20821b1ea3b45177a02c91f3682abd65aaeb775bf6d03688a37a6fe57b8a47037ffbf1f7deea7ede60fc1e3c95b74b76f8be28afae73ec87be5bfcc SHA512 8c12c38a49ffef811e6107d003f44cd8174bc95fc71dcc3296511e3356a0203cf12479a36c7d649f1933c6a90820c3212de25166b61eac8de06728cb8cb25566
diff --git a/dev-python/ipy/ipy-0.83.ebuild b/dev-python/ipy/ipy-0.83.ebuild
deleted file mode 100644
index 7ac7cac08ff4..000000000000
--- a/dev-python/ipy/ipy-0.83.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-MY_PN="IPy"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Class and tools for handling of IPv4 and IPv6 addresses and networks"
-HOMEPAGE="https://github.com/haypo/python-ipy/wiki https://pypi.org/project/IPy/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc x86"
-IUSE="examples"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_test() {
- # 1 test fail under pypy, persistent from 0.82a, not a regression.
- cp -r test_doc.py README test "${BUILD_DIR}" || die
- pushd "${BUILD_DIR}" > /dev/null || die
- "${PYTHON}" test/test_IPy.py || die "Tests fail with ${EPYTHON}"
- "${PYTHON}" test_doc.py || die "Doctests fail with ${EPYTHON}"
- popd > /dev/null || die
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( example/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/ipy/ipy-1.00.ebuild b/dev-python/ipy/ipy-1.00.ebuild
index d387087d8088..afbead463014 100644
--- a/dev-python/ipy/ipy-1.00.ebuild
+++ b/dev-python/ipy/ipy-1.00.ebuild
@@ -35,6 +35,11 @@ python_test() {
}
python_install_all() {
- use examples && local EXAMPLES=( example/. )
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
distutils-r1_python_install_all
}